Bug 11142 - Cairo does not do proper scaling / minification filtering in bitmaps
Summary: Cairo does not do proper scaling / minification filtering in bitmaps
Status: RESOLVED MOVED
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.6
Hardware: Other All
: medium normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 5589
  Show dependency treegraph
 
Reported: 2007-06-04 18:37 UTC by Marcus Granado
Modified: 2018-08-25 13:52 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
bitmaps display in acroread and evince (47.20 KB, image/png)
2007-07-15 06:17 UTC, Pablo Rodríguez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Granado 2007-06-04 18:37:02 UTC
It seems that this lack of functionality is affecting pdf viewers/backends such as poppler (see bug #5589):
https://bugs.freedesktop.org/show_bug.cgi?id=5589
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/92296

See how this manifests itself visually:
http://launchpadlibrarian.net/6805265/evince_vs_xpdf.png

The problem is present in latest cairo 1.4.6 / poppler 0.5.4 / evince 0.9.0.
Comment 1 Pablo Rodríguez 2007-07-15 06:16:13 UTC
Using cairo 1.4.10, poppler 0.5.9 and evince 0.9.2, I think I get even worse results (see atached image acrobatvsevince.png).

I hope it helps,


Pablo
Comment 2 Pablo Rodríguez 2007-07-15 06:17:07 UTC
Created attachment 10739 [details]
bitmaps display in acroread and evince
Comment 3 Pablo Rodríguez 2007-07-21 02:38:38 UTC
I guess the bug above was wrong reported, because the bug might have been introduced in poppler-0.5.9 (see bug 5589 for that).
Comment 4 GitLab Migration User 2018-08-25 13:52:45 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/cairo/cairo/issues/243.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.