Bug 111484 - Intel IceLake corruption at top of screen caused by fbc
Summary: Intel IceLake corruption at top of screen caused by fbc
Status: RESOLVED DUPLICATE of bug 103167
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: high critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on: 108085
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-26 03:59 UTC by You-Sheng Yang [:vicamo]
Modified: 2019-09-14 11:59 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: display/FBC


Attachments
dmesg, v5.3-rc6, drm.debug=0xe (173.83 KB, text/plain)
2019-08-26 04:00 UTC, You-Sheng Yang [:vicamo]
no flags Details
glxinfo (37.84 KB, text/plain)
2019-08-26 04:00 UTC, You-Sheng Yang [:vicamo]
no flags Details
lspci output (32.91 KB, text/plain)
2019-08-26 04:01 UTC, You-Sheng Yang [:vicamo]
no flags Details
proposed patch (1.18 KB, application/mbox)
2019-08-26 04:05 UTC, You-Sheng Yang [:vicamo]
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description You-Sheng Yang [:vicamo] 2019-08-26 03:59:05 UTC
This is a duplicate to https://bugs.freedesktop.org/show_bug.cgi?id=108085 that happens on IceLake platform as well.

It can be reproduced on linux v5.3-rc6 today, with the reproduce steps listed in bug 108085, but one can easily found a horizontal line of corruption at the top of the screen when logging in from gdm.

Blacklist IceLake as https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=396dd8143bdd94bd1c358a228a631c8c895a1126 did for GeminiLake is a known work-around so far.
Comment 1 You-Sheng Yang [:vicamo] 2019-08-26 04:00:12 UTC
Created attachment 145160 [details]
dmesg, v5.3-rc6, drm.debug=0xe
Comment 2 You-Sheng Yang [:vicamo] 2019-08-26 04:00:40 UTC
Created attachment 145161 [details]
glxinfo
Comment 3 You-Sheng Yang [:vicamo] 2019-08-26 04:01:20 UTC
Created attachment 145162 [details]
lspci output
Comment 4 You-Sheng Yang [:vicamo] 2019-08-26 04:05:34 UTC
Created attachment 145163 [details]
proposed patch
Comment 5 Jani Saarinen 2019-08-26 05:50:28 UTC
ICL issue tracked on fdo 103167 and WIP there.
Comment 6 Lakshmi 2019-09-03 09:53:43 UTC
(In reply to Jani Saarinen from comment #5)
> ICL issue tracked on fdo 103167 and WIP there.

Accordingly, all the above details are set.
Comment 7 Lakshmi 2019-09-10 11:27:13 UTC
@Maarten, Is this issue related to Bug 111484? Since you investigated Bug 111484 any suggestions here?
Comment 8 Jani Saarinen 2019-09-10 14:04:36 UTC
You mean Lakshmi if 103167 is same?
Comment 9 Lakshmi 2019-09-11 14:44:04 UTC
(In reply to Jani Saarinen from comment #8)
> You mean Lakshmi if 103167 is same?

Sorry, yes it's Bug 103167 .
Comment 10 Maarten Lankhorst 2019-09-13 13:26:44 UTC
Likely identical, especially if disabling fbc from command line works.
Comment 11 Jani Saarinen 2019-09-13 13:59:55 UTC
marking this as dup. WIP on that has been already a while to understand cause of it.

*** This bug has been marked as a duplicate of bug 103167 ***
Comment 12 Jani Saarinen 2019-09-13 14:02:29 UTC
Reporter, please also try as suggested using i915.enable_fbc=0 if issue still exists.
Comment 13 Jani Saarinen 2019-09-13 14:14:22 UTC
Ah, so suggested workaround using i915.enable_fbc=0 also works?
Comment 14 You-Sheng Yang [:vicamo] 2019-09-14 11:59:48 UTC
Yes, basically whatever turns off fbc would work. Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.