Bug 111497 - Connect a thunderbolt/usb-c dock hang the laptop after resume
Summary: Connect a thunderbolt/usb-c dock hang the laptop after resume
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-27 07:46 UTC by zioalex
Modified: 2019-09-17 07:07 UTC (History)
1 user (show)

See Also:
i915 platform: CFL
i915 features: display/USB-C


Attachments
Kernel trace (144.32 KB, text/plain)
2019-08-27 07:46 UTC, zioalex
no flags Details
Kernel trace with debug enanled (19.02 MB, text/x-log)
2019-09-06 09:39 UTC, zioalex
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zioalex 2019-08-27 07:46:06 UTC
Created attachment 145175 [details]
Kernel trace

I experimenting random hang of my Lenovo T490 laptop after resuming.
Follow a stack trace of what happen:

Aug 27 09:22:32 lenovo-t490 kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000318
Aug 27 09:22:32 lenovo-t490 kernel: #PF error: [WRITE]
Aug 27 09:22:32 lenovo-t490 kernel: PGD 0 P4D 0
Aug 27 09:22:32 lenovo-t490 kernel: Oops: 0002 [#1] PREEMPT SMP NOPTI
Aug 27 09:22:32 lenovo-t490 kernel: CPU: 3 PID: 3653 Comm: Xorg Tainted: G           OE     5.0.0-050000-lowlatency #201903032031
Aug 27 09:22:32 lenovo-t490 kernel: Hardware name: LENOVO 20N2S0M700/20N2S0M700, BIOS N2IET71W (1.49 ) 07/03/2019
Aug 27 09:22:32 lenovo-t490 kernel: RIP: 0010:mutex_lock+0x14/0x30
Aug 27 09:22:32 lenovo-t490 kernel: Code: 00 48 89 e5 e8 ed fa ff ff 5d c3 66 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 55 31 c0 65 48 8b 14 25 00 5c 01 00 48 89 e5 <f0> 48 0f b1 17 74 05 e8 c0 ff ff ff 5d c3 66 66 2e 0f 1f 84 00 00
Aug 27 09:22:32 lenovo-t490 kernel: RSP: 0018:ffffa17bc2bd78b0 EFLAGS: 00010246
Aug 27 09:22:32 lenovo-t490 kernel: RAX: 0000000000000000 RBX: ffff8c463af64400 RCX: ffffa17bc6b4fc20
Aug 27 09:22:32 lenovo-t490 kernel: RDX: ffff8c4857e92680 RSI: 0000000000000287 RDI: 0000000000000318
Aug 27 09:22:32 lenovo-t490 kernel: RBP: ffffa17bc2bd78b0 R08: ffff8c48be49ac18 R09: 000000000001741e
Aug 27 09:22:32 lenovo-t490 kernel: R10: 0000000000001138 R11: ffff8c48be4e1c04 R12: 0000000000000f6a
Aug 27 09:22:32 lenovo-t490 kernel: R13: ffff8c48adb05ad0 R14: ffff8c482343ff00 R15: 0000000000000f6a
Aug 27 09:22:32 lenovo-t490 kernel: FS:  00007f1c638da600(0000) GS:ffff8c48be4c0000(0000) knlGS:0000000000000000
Aug 27 09:22:32 lenovo-t490 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Aug 27 09:22:32 lenovo-t490 kernel: CR2: 0000000000000318 CR3: 0000000417eac001 CR4: 00000000003606e0
Aug 27 09:22:32 lenovo-t490 kernel: Call Trace:
Aug 27 09:22:32 lenovo-t490 kernel:  drm_dp_mst_wait_tx_reply+0x14c/0x1f0 [drm_kms_helper]
Aug 27 09:22:32 lenovo-t490 kernel:  ? wait_woken+0x80/0x80
Aug 27 09:22:32 lenovo-t490 kernel:  drm_dp_mst_i2c_xfer+0x1a5/0x270 [drm_kms_helper]
Aug 27 09:22:32 lenovo-t490 kernel:  __i2c_transfer+0x14a/0x4a0
Aug 27 09:22:32 lenovo-t490 kernel:  i2c_transfer+0x5a/0xd0
Aug 27 09:22:32 lenovo-t490 kernel:  drm_do_probe_ddc_edid+0xbe/0x140 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  drm_get_edid+0x51/0x390 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  drm_dp_mst_get_edid+0x6f/0x90 [drm_kms_helper]
Aug 27 09:22:32 lenovo-t490 kernel:  intel_dp_mst_get_modes+0x34/0x70 [i915]
Aug 27 09:22:32 lenovo-t490 kernel:  drm_helper_probe_single_connector_modes+0x18b/0x700 [drm_kms_helper]
Aug 27 09:22:32 lenovo-t490 kernel:  ? drm_atomic_get_property+0x19d/0x560 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  drm_mode_getconnector+0x4c3/0x4f0 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  ? drm_connector_property_set_ioctl+0x60/0x60 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  drm_ioctl_kernel+0xad/0xf0 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  ? ___sys_recvmsg+0x16c/0x200
Aug 27 09:22:32 lenovo-t490 kernel:  drm_ioctl+0x233/0x410 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  ? drm_connector_property_set_ioctl+0x60/0x60 [drm]
Aug 27 09:22:32 lenovo-t490 kernel:  ? __fget+0x73/0xa0
Aug 27 09:22:32 lenovo-t490 kernel:  do_vfs_ioctl+0xa9/0x640
Aug 27 09:22:32 lenovo-t490 kernel:  ? __fget+0x73/0xa0
Aug 27 09:22:32 lenovo-t490 kernel:  ksys_ioctl+0x67/0x90
Aug 27 09:22:32 lenovo-t490 kernel:  __x64_sys_ioctl+0x1a/0x20
Aug 27 09:22:32 lenovo-t490 kernel:  do_syscall_64+0x5a/0x110
Aug 27 09:22:32 lenovo-t490 kernel:  entry_SYSCALL_64_after_hwframe+0x44/0xa9
Aug 27 09:22:32 lenovo-t490 kernel: RIP: 0033:0x7f1c60cdd5d7
Aug 27 09:22:32 lenovo-t490 kernel: Code: b3 66 90 48 8b 05 b1 48 2d 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 81 48 2d 00 f7 d8 64 89 01 48
Aug 27 09:22:32 lenovo-t490 kernel: RSP: 002b:00007ffecaafd648 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
Aug 27 09:22:32 lenovo-t490 kernel: RAX: ffffffffffffffda RBX: 0000555be3cc2f18 RCX: 00007f1c60cdd5d7
Aug 27 09:22:32 lenovo-t490 kernel: RDX: 00007ffecaafd680 RSI: 00000000c05064a7 RDI: 000000000000000c
Aug 27 09:22:32 lenovo-t490 kernel: RBP: 00007ffecaafd680 R08: 0000000000000001 R09: 0000000000000000
Aug 27 09:22:32 lenovo-t490 kernel: R10: 0000000000000001 R11: 0000000000000246 R12: 00000000c05064a7
Aug 27 09:22:32 lenovo-t490 kernel: R13: 000000000000000c R14: 000000000000000c R15: 00007ffecaafd680
Aug 27 09:22:32 lenovo-t490 kernel: Modules linked in: rfcomm nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT pci_stub vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) l2tp_ppp l2tp_netlink l2tp_core ip6_udp_tunnel udp_tunnel pppox ipt_MASQUERADE nf_conntrack_netlink xt_addrtype br_netfilter md4 xfrm_user xfrm4_tunnel tunnel4 ipcomp xfrm_ipcomp nls_utf8 esp4 ah4 cifs af_key xfrm_algo fscache xt_tcpudp ccm ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 ipt_REJECT nf_reject_ipv4 xt_conntrack cmac ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_nat_ipv6 ip6table_mangle ip6table_raw overlay ip6table_security iptable_nat nf_nat_ipv4 nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter bpfilter bnep binfmt_misc nls_iso8859_1 arc4 snd_hda_codec_hdmi snd_soc_skl uvcvideo intel_rapl snd_soc_hdac_hda x86_pkg_temp_thermal videobuf2_vmalloc intel_powerclamp videobuf2_memops
Aug 27 09:22:32 lenovo-t490 kernel:  snd_hda_ext_core videobuf2_v4l2 coretemp videobuf2_common snd_soc_skl_ipc kvm_intel videodev snd_soc_sst_ipc snd_hda_codec_realtek snd_soc_sst_dsp intel_cstate snd_soc_acpi_intel_match media intel_rapl_perf snd_hda_codec_generic cdc_ether snd_seq_dummy snd_soc_acpi usbnet snd_soc_core snd_seq_oss r8152 mii snd_compress iwlmvm ac97_bus btusb snd_pcm_dmaengine snd_seq_midi btrtl btbcm snd_seq_midi_event btintel mac80211 snd_hda_intel snd_hda_codec joydev bluetooth input_leds snd_hda_core serio_raw snd_hwdep snd_rawmidi thinkpad_acpi snd_pcm nvram ecdh_generic intel_wmi_thunderbolt wmi_bmof iwlwifi ledtrig_audio snd_seq mei_me idma64 snd_seq_device virt_dma mei cfg80211 intel_lpss_pci snd_timer ucsi_acpi intel_lpss typec_ucsi snd processor_thermal_device intel_pch_thermal intel_soc_dts_iosf typec soundcore int3403_thermal int340x_thermal_zone int3400_thermal acpi_thermal_rel acpi_pad mac_hid sch_fq_codel nfsd parport_pc auth_rpcgss ppdev nfs_acl lockd grace lp sunrpc parport
Aug 27 09:22:32 lenovo-t490 kernel:  ip_tables x_tables autofs4 btrfs zstd_compress algif_skcipher af_alg dm_crypt raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq libcrc32c raid1 raid0 multipath linear hid_generic usbhid hid i915 crct10dif_pclmul crc32_pclmul ghash_clmulni_intel kvmgt vfio_mdev mdev vfio_iommu_type1 vfio kvm irqbypass i2c_algo_bit aesni_intel drm_kms_helper sdhci_pci syscopyarea aes_x86_64 sysfillrect crypto_simd nvme sysimgblt cryptd fb_sys_fops glue_helper thunderbolt cqhci e1000e psmouse drm nvme_core sdhci wmi pinctrl_cannonlake video pinctrl_intel
Aug 27 09:22:32 lenovo-t490 kernel: CR2: 0000000000000318
Aug 27 09:22:32 lenovo-t490 kernel: ---[ end trace 4cc44c70a856a605 ]---

Following the outcome of https://bugs.freedesktop.org/show_bug.cgi?id=107738 , I tried to install the latest commit from here: https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/ .
Now I am running on 5.0.0-050000-lowlatency but I noticed the same problem

This is not always reproduciblem as sometime it works.
In attach you can see the full log.
Comment 1 Lakshmi 2019-08-28 07:06:26 UTC
Can you please attach the dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?
Comment 2 zioalex 2019-09-01 18:44:48 UTC
Sure. Will post back when it will reoccur.
Comment 3 zioalex 2019-09-06 09:39:00 UTC
Hi,
update logs with debug attached.
Unfortunately I think that the interesting part was not collected.
Nevertheless may you can see something interesting with the debug enabled.

Can I force somehow to sync the logs before forcing the shutdown with the button?
Comment 4 zioalex 2019-09-06 09:39:59 UTC
Created attachment 145274 [details]
Kernel trace with debug enanled
Comment 5 Lakshmi 2019-09-06 10:09:54 UTC
(In reply to zioalex from comment #4)
> Created attachment 145274 [details]
> Kernel trace with debug enanled

Attached logs are from kernel 5.0. Can you please try to upgrade to latest kernel (drmtip) and give your feedback?

Here you can find the drmtip kernel https://cgit.freedesktop.org/drm-tip. We always recommend to verify the issue with drmtip. Logs from drmtip will help during investigation.
Comment 6 zioalex 2019-09-16 08:56:07 UTC
Hi,
I update to the latest drmtip kernel (5.3.0-994-lowlatency) available for Ubuntu (https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/)
and the problem didn't reoccur anymore in the last week.
Comment 7 Lakshmi 2019-09-16 15:12:49 UTC
(In reply to zioalex from comment #6)
> Hi,
> I update to the latest drmtip kernel (5.3.0-994-lowlatency) available for
> Ubuntu (https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/)
> and the problem didn't reoccur anymore in the last week.

Can I close this issue as WORKSFORME, if this issue is not seen with upgraded kernel?
Comment 8 zioalex 2019-09-16 15:57:28 UTC
Yes, I think so.
Do you have any visibility on when this will be available on the main release?
Comment 9 Lakshmi 2019-09-17 07:07:12 UTC
(In reply to zioalex from comment #8)
> Yes, I think so.
> Do you have any visibility on when this will be available on the main
> release?

Thanks for confirming.
Since we don't the fix that help you in this case, its hard to say when it will be available main release. I would recommend you to upgrade to main release after 2-4 weeks or so and check if that helps.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.