Bug 111510 - [gallium-nine] [build failure] change in clang CompilerInvocation::CreateFromArgs breaks build
Summary: [gallium-nine] [build failure] change in clang CompilerInvocation::CreateFrom...
Status: RESOLVED DUPLICATE of bug 111523
Alias: None
Product: Mesa
Classification: Unclassified
Component: Gallium/StateTracker/Clover (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: not set not set
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-28 22:41 UTC by LoneVVolf
Modified: 2019-09-02 13:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
build log (268.10 KB, text/plain)
2019-08-30 23:13 UTC, LoneVVolf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LoneVVolf 2019-08-28 22:41:22 UTC
building gallium-nine with mesa trunk rev cfbde3282d9 breaks with message 

/usr/include/clang/Frontend/CompilerInvocation.h:157:15: note:   candidate expects 3 arguments, 4 provided

checking llvm/clang commits indicates CompilerInvocation was changed recently .

See 
https://github.com/llvm/llvm-project/commit/1fac68b0dc19b03fd2c5e9856f0f2c5a11691348

and https://reviews.llvm.org/D66797 .
Comment 1 Axel Davy 2019-08-29 21:28:10 UTC
Gallium-nine doesn't use llvm directly. It uses it possibly through radeonsi or llvmpipe.

I assume you get the same problem when building mesa without gallium nine ?

Could you tell if the problem is when compiling radeonsi files or llvmpipe files ?

Thanks
Comment 2 LoneVVolf 2019-08-30 23:13:54 UTC
Created attachment 145221 [details]
build log
Comment 3 LoneVVolf 2019-08-30 23:18:57 UTC
You're right, Axel.

I didn't have logs of the fail, so did a fresh build (log attached).
The problem is not with gallium-nine, but with clover / opencl .

When building with gallium-opencl=disabled build finishes normally.

Changing component and title (if that's possible) to reflect this.
Comment 4 Dieter Nützel 2019-08-30 23:48:15 UTC
Maybe duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=111523 ?
Comment 5 LoneVVolf 2019-09-02 13:06:59 UTC

*** This bug has been marked as a duplicate of bug 111523 ***
Comment 6 LoneVVolf 2019-09-02 13:07:42 UTC
Yes, that's the same error. closing this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.