Bug 111535 - gdm freezes when using iris driver on Intel HD520
Summary: gdm freezes when using iris driver on Intel HD520
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/Iris (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: not set normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-02 10:33 UTC by David Heidelberg (okias)
Modified: 2019-09-25 18:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
journalctl log (31.62 KB, text/plain)
2019-09-03 09:58 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Heidelberg (okias) 2019-09-02 10:33:10 UTC
HW: Dell 7350 Intel HD520.
SW: Gentoo, kernel 5.2.11, ~amd64, Wayland setup.

When using
MESA_LOADER_DRIVER_OVERRIDE=iris
in /etc/environment, gdm freeze. Only printed lines into logs are:

gnome-shell[932]: meta_drm_buffer_gbm_new failed: drmModeAddFB failed: Nepřípustný argument (translated as Unacceptable argument)
gnome-shell[932]: meta_drm_buffer_gbm_new failed: drmModeAddFB failed: Nepřípustný argument (translated as Unacceptable argument)

I tried compile git mesa with debug, but it didn't get me further.

Feel free to ask me to get specific debugging, can compile mesa/libdrm or kernel with specific patches.
Comment 1 Paul 2019-09-03 09:58:33 UTC
Created attachment 145250 [details]
journalctl log

Hello David, thanks for the report.

I've reproduced the issue on my SKL (Intel® HD Graphics 520) with ubuntu 18.04 and mesa commit cf652205cff25dbb0d8c0f642f8a6d097e51a010 (around the first commit with iris support).
The machine freezes when Wayland is set and MESA_LOADER_DRIVER_OVERRIDE=iris enabled.
Also, I've tried to reproduce the issue on my KBL (Intel® UHD Graphics 620) - no freeze.

I attach journalctl log
Comment 2 Paul 2019-09-11 14:28:02 UTC
UPD - the issue is also actual on KBL (Intel® UHD Graphics 620).

Also, I've checked the issue with the latest version of drm-tip - the issue is also actual.
Comment 3 GitLab Migration User 2019-09-25 18:47:43 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1361.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.