Bug 111547 - [CI][SHARDS] igt@gem_exec_schedule@pi-ringfull-blt - fail - Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0
Summary: [CI][SHARDS] igt@gem_exec_schedule@pi-ringfull-blt - fail - Failed assertion:...
Status: RESOLVED DUPLICATE of bug 111561
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-03 11:35 UTC by Martin Peres
Modified: 2019-09-07 13:17 UTC (History)
1 user (show)

See Also:
i915 platform: BXT
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-03 11:35:21 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6825/shard-apl5/igt@gem_exec_schedule@pi-ringfull-blt.html

Starting subtest: pi-ringfull-blt
(gem_exec_schedule:3559) CRITICAL: Test assertion failure function bind_to_cpu, file ../tests/i915/gem_exec_schedule.c:1478:
(gem_exec_schedule:3559) CRITICAL: Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0
(gem_exec_schedule:3559) CRITICAL: Last errno: 22, Invalid argument
Comment 2 Chris Wilson 2019-09-03 12:20:05 UTC
Definitely smells like a funky rc7, see also #111548
Comment 3 CI Bug Log 2019-09-03 13:17:39 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL ICL: igt@gem_exec_schedule@pi-ringfull-blt - fail - Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0 -}
{+ APL KBL ICL: igt@gem_exec_schedule@pi-ringfull-blt - fail - Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0 +}


  No new failures caught with the new filter
Comment 4 CI Bug Log 2019-09-03 13:25:01 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL KBL ICL: igt@gem_exec_schedule@pi-ringfull-blt - fail - Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0 -}
{+ APL KBL ICL: igt@gem_exec_schedule@pi-ringfull-* - fail - Failed assertion: sched_setaffinity(getpid(), sizeof(cpu_set_t), &allowed) == 0 +}


  No new failures caught with the new filter
Comment 5 Chris Wilson 2019-09-07 13:17:19 UTC

*** This bug has been marked as a duplicate of bug 111561 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.