Bug 111577 - Ensure correct buffer size when allocating / swrast
Summary: Ensure correct buffer size when allocating / swrast
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/swrast (show other bugs)
Version: git
Hardware: All Linux (All)
: not set normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-06 14:23 UTC by Marius Vlad
Modified: 2019-09-18 18:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Vlad 2019-09-06 14:23:37 UTC
The following 
https://gitlab.freedesktop.org/mesa/mesa/commit/30a01cd9232ed83a0259d184b82e050bae219ed3 has to be re-worked to work/to be integrated into with the software renderer as well. 

Related https://bugs.freedesktop.org/show_bug.cgi?id=109594
and https://gitlab.freedesktop.org/wayland/weston/merge_requests/256.
Comment 1 Marius Vlad 2019-09-06 14:27:59 UTC
Forget to add https://gitlab.freedesktop.org/mesa/mesa/merge_requests/818 as related.
Comment 2 Marius Vlad 2019-09-06 14:52:31 UTC
Apologies, the commit that fixes the problem is actually 903ad59407ac965f9fbc8c0c397cc6f09263a2b8:  not the one that I posted initially (it fixes that actually).
Comment 3 Eric Engestrom 2019-09-07 14:54:18 UTC
Giving this a quick stab, is this what you mean?
https://gitlab.freedesktop.org/mesa/mesa/merge_requests/1902
Comment 4 Marius Vlad 2019-09-16 08:54:07 UTC
This seems to happen only when resizing the window before having a change to flip the back/current buffers. Pushed I fix which works but not sure if fixes the problem at the correct level:

https://gitlab.freedesktop.org/marius.vlad0/mesa/commit/7eb1aab17c740b84acf25ab5fe643c141af31946
Comment 5 GitLab Migration User 2019-09-18 18:45:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/328.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.