Bug 111620 - [regression][bisected] Virtual Reality HMDs fail to power off when SteamVR closes
Summary: [regression][bisected] Virtual Reality HMDs fail to power off when SteamVR cl...
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: Other All
: not set major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-09 17:38 UTC by Andres Rodriguez
Modified: 2019-11-19 09:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Rodriguez 2019-09-09 17:38:30 UTC
When SteamVR is closed the attached HMD no longer powers off. This is due to the display still being driven by the GPU.

The first bad commit for this behaviour is:
"drm/amd/display: Allow commits with no planes active"
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=bc92c06525e5865c94256ef0227bfe870c095823

My understanding is that the commit above does fix a bug in amdgpu/dc. However, due to current Xorg versions failing to shut down outputs after re-claiming a drm lease, this commit ends up breaking userspace.

Following is the x server patch to help illustrate what X is doing incorrectly:
https://gitlab.freedesktop.org/xorg/xserver/merge_requests/279

Additional reference:
https://github.com/ValveSoftware/SteamVR-for-Linux/issues/235
Comment 1 Martin Peres 2019-11-19 09:51:09 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/903.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.