Bug 111625 - [CI][SHARDS]igt@gem_create@create-clear - timeout - Failed assertion: __gem_read(fd, handle, offset, buf, length) == 0
Summary: [CI][SHARDS]igt@gem_create@create-clear - timeout - Failed assertion: __gem_r...
Status: RESOLVED DUPLICATE of bug 108686
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-10 06:40 UTC by Lakshmi
Modified: 2019-09-10 10:32 UTC (History)
1 user (show)

See Also:
i915 platform: SNB
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-09-10 06:40:05 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5172/shard-snb6/igt@gem_create@create-clear.html

Starting subtest: create-clear
(gem_create:2837) ioctl_wrappers-CRITICAL: Test assertion failure function gem_read, file ../lib/ioctl_wrappers.c:388:
(gem_create:2837) ioctl_wrappers-CRITICAL: Test assertion failure function gem_read, file ../lib/ioctl_wrappers.c:388:
(gem_create:2837) ioctl_wrappers-CRITICAL: Failed assertion: __gem_read(fd, handle, offset, buf, length) == 0
(gem_create:2837) ioctl_wrappers-CRITICAL: Failed assertion: __gem_read(fd, handle, offset, buf, length) == 0
(gem_create:2837) ioctl_wrappers-CRITICAL: Last errno: 12, Cannot allocate memory
(gem_create:2837) ioctl_wrappers-CRITICAL: error: -12 != 0
(gem_create:2837) ioctl_wrappers-CRITICAL: Last errno: 12, Cannot allocate memory
(gem_create:2837) ioctl_wrappers-CRITICAL: error: -12 != 0
Comment 1 CI Bug Log 2019-09-10 06:42:26 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* SNB: igt@gem_create@create-clear - timeout - Failed assertion: __gem_read(fd, handle, offset, buf, length) == 0
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5172/shard-snb6/igt@gem_create@create-clear.html
Comment 2 Chris Wilson 2019-09-10 10:32:11 UTC
The underlying issue here is bug 108686 (direct reclaim failure under swap conditions). The only slight conundrum is that gem_create/create-clear strives to avoid running into swap in the first place. But I can simply blame java for that and focus on the kernel problem.

*** This bug has been marked as a duplicate of bug 108686 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.