Bug 111627 - [CI][RESUME] igt@gem_mocs_settings@mocs-.*-dirty-.* - skip - Test requirement: !(intel_gen(intel_get_drm_devid(fd)) >= 11), SKIP
Summary: [CI][RESUME] igt@gem_mocs_settings@mocs-.*-dirty-.* - skip - Test requirement...
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-10 08:33 UTC by Martin Peres
Modified: 2019-09-13 21:05 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-10 08:33:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-dirty-render.html

Starting subtest: mocs-rc6-dirty-render
Test requirement not met in function run_test, file ../tests/i915/gem_mocs_settings.c:504:
Test requirement: !(intel_gen(intel_get_drm_devid(fd)) >= 11)
Subtest mocs-rc6-dirty-render: SKIP (0.000s)
Comment 1 CI Bug Log 2019-09-10 08:33:35 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@gem_mocs_settings@mocs-.*-dirty-.* - skip - Test requirement: !(intel_gen(intel_get_drm_devid(fd)) >= 11), SKIP
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@gem_mocs_settings@mocs-settings-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-settings-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-settings-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_362/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_365/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_mocs_settings@mocs-settings-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_mocs_settings@mocs-settings-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_mocs_settings@mocs-reset-ctx-dirty-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-tgl-u/igt@gem_mocs_settings@mocs-rc6-dirty-render.html
Comment 2 prathap.kumar.valsan 2019-09-13 20:55:47 UTC
Not a BUG.



        /* As mocs is global for GEN11+, trying privileged write to dirty
         * the mocs and testing context save and restore of mocs between
         * contexts is bound to fail.
         */
        if (flags & MOCS_DIRTY_VALUES)
                igt_skip_on(intel_gen(intel_get_drm_devid(fd)) >= 11);


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.