Bug 111667 - gem_render_copy failing on CCS subtests
Summary: gem_render_copy failing on CCS subtests
Status: RESOLVED DUPLICATE of bug 111771
Alias: None
Product: DRI
Classification: Unclassified
Component: IGT (show other bugs)
Version: DRI git
Hardware: Other Linux (All)
: not set major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-12 07:16 UTC by Mika Kahola
Modified: 2019-09-23 11:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
gem_render_copy --run-subtest y-tiled-ccs-to-linear (168.21 KB, text/x-log)
2019-09-19 07:46 UTC, Mika Kahola
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mika Kahola 2019-09-12 07:16:40 UTC
gem_render_copy is failing on CCS subtests on TGL

y-tiled-ccs-to-linear
y-tiled-ccs-to-x-tiled
y-tiled-ccs-to-y-tiled
y-tiled-ccs-to-yf-tiled
yf-tiled-ccs-to-linear
yf-tiled-ccs-to-x-tiled
yf-tiled-ccs-to-y-tiled
yf-tiled-ccs-to-yf-tiled

It seems that at least, rendercopy support for GEN12 is missing from upstream IGT.
Comment 1 Mika Kahola 2019-09-12 10:43:05 UTC
Test results show as 
./tests/gem_render_copy
IGT-Version: 1.24-g07f67caf (x86_64) (Linux: 5.3.0-rc8-CI-CI_DIS_719+ x86_64)
Starting subtest: linear
Subtest linear: SUCCESS (0,255s)
Starting subtest: x-tiled
Subtest x-tiled: SUCCESS (0,251s)
Starting subtest: y-tiled
Subtest y-tiled: SUCCESS (0,252s)
Starting subtest: yf-tiled
Subtest yf-tiled: SUCCESS (0,237s)
Starting subtest: y-tiled-ccs-to-linear
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest y-tiled-ccs-to-linear failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest y-tiled-ccs-to-linear: FAIL (41,146s)
Starting subtest: y-tiled-ccs-to-x-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest y-tiled-ccs-to-x-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest y-tiled-ccs-to-x-tiled: FAIL (46,971s)
Starting subtest: y-tiled-ccs-to-y-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest y-tiled-ccs-to-y-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest y-tiled-ccs-to-y-tiled: FAIL (47,999s)
Starting subtest: y-tiled-ccs-to-yf-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest y-tiled-ccs-to-yf-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x1006401a at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest y-tiled-ccs-to-yf-tiled: FAIL (47,992s)
Starting subtest: yf-tiled-ccs-to-linear
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest yf-tiled-ccs-to-linear failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest yf-tiled-ccs-to-linear: FAIL (49,025s)
Starting subtest: yf-tiled-ccs-to-x-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest yf-tiled-ccs-to-x-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest yf-tiled-ccs-to-x-tiled: FAIL (47,999s)
Starting subtest: yf-tiled-ccs-to-y-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest yf-tiled-ccs-to-y-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest yf-tiled-ccs-to-y-tiled: FAIL (47,998s)
Starting subtest: yf-tiled-ccs-to-yf-tiled
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
Stack trace:
  #0 ../lib/igt_core.c:1674 __igt_fail_assert()
  #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
  #2 [<unknown>+0xb946f500]
Subtest yf-tiled-ccs-to-yf-tiled failed.
**** DEBUG ****
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) DEBUG: Test requirement passed: intel_gen(data->devid) >= 9
(gem_render_copy:4311) CRITICAL: Test assertion failure function scratch_buf_check, file ../tests/i915/gem_render_copy.c:491:
(gem_render_copy:4311) CRITICAL: Failed assertion: buf_val == ref_val
(gem_render_copy:4311) CRITICAL: Expected 0xff449bbb, found 0x00000000 at (10,10)
(gem_render_copy:4311) igt_core-INFO: Stack trace:
(gem_render_copy:4311) igt_core-INFO:   #0 ../lib/igt_core.c:1674 __igt_fail_assert()
(gem_render_copy:4311) igt_core-INFO:   #1 ../tests/i915/gem_render_copy.c:479 scratch_buf_check()
(gem_render_copy:4311) igt_core-INFO:   #2 [<unknown>+0xb946f500]
****  END  ****
Subtest yf-tiled-ccs-to-yf-tiled: FAIL (47,992s)
Comment 2 Chris Wilson 2019-09-12 11:20:05 UTC
There is no render copyfunc for gen12. This should have bailed out at

                data.render_copy = igt_get_render_copyfunc(data.devid);
                igt_require_f(data.render_copy,
                              "no render-copy function\n");
Comment 3 Mika Kahola 2019-09-12 13:07:29 UTC
You're right. I had a patch in my tree which, for some reason, hasn't been upstreamed yet. But the bug is real, we are missing rendercopy function for GEN12.
Comment 4 Katarzyna Dec 2019-09-13 04:58:54 UTC
Patches for Gen12 are ready, I will resend them today.
Comment 5 Mika Kahola 2019-09-19 07:46:39 UTC
Created attachment 145430 [details]
gem_render_copy --run-subtest  y-tiled-ccs-to-linear

Unfortunately, the rendercopy patches didn't help in case of CCS. The attatched dmesg is an example of the outcome of IGT test gem_render_copy@y-tiled-ccs-to-linear.

I ran the test with my IGT tree 

https://github.com/mkahola/igt.git e2e_compression
Comment 6 Chris Wilson 2019-09-23 11:02:42 UTC
Forward duping to tie in with cibuglog.

*** This bug has been marked as a duplicate of bug 111771 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.