Bug 111670 - [CI][RESUME] igt@gem_exec_whisper@normal - fail - Failed assertion: map[i] == i
Summary: [CI][RESUME] igt@gem_exec_whisper@normal - fail - Failed assertion: map[i] == i
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-12 10:06 UTC by Martin Peres
Modified: 2019-10-16 13:05 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-12 10:06:12 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_366/fi-tgl-u/igt@gem_exec_whisper@normal.html
	
Starting subtest: normal
(gem_exec_whisper:2753) CRITICAL: Test assertion failure function check_bo, file ../tests/i915/gem_exec_whisper.c:55:
(gem_exec_whisper:2753) CRITICAL: Failed assertion: map[i] == i
(gem_exec_whisper:2753) CRITICAL: error: 12648430 != 0
Comment 2 Chris Wilson 2019-09-12 10:18:21 UTC
I believe this is a tgl "feature". https://patchwork.freedesktop.org/series/66538/
Comment 3 Chris Wilson 2019-09-20 13:23:29 UTC
Prevented by

commit c45e788d95b470e9f68fabe1f3cb44beb5dd7840
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Sep 19 16:18:11 2019 +0100

    drm/i915/tgl: Suspend pre-parser across GTT invalidations

the danger though is that we should consider this as broken userspace behaviour wrt self-modifying execution that needs special care (pre-parser disable) for Tigerlake+.
Comment 4 Martin Peres 2019-10-16 13:04:50 UTC
(In reply to Chris Wilson from comment #3)
> Prevented by
> 
> commit c45e788d95b470e9f68fabe1f3cb44beb5dd7840
> Author: Chris Wilson <chris@chris-wilson.co.uk>
> Date:   Thu Sep 19 16:18:11 2019 +0100
> 
>     drm/i915/tgl: Suspend pre-parser across GTT invalidations
> 
> the danger though is that we should consider this as broken userspace
> behaviour wrt self-modifying execution that needs special care (pre-parser
> disable) for Tigerlake+.

How is this not a fix? Anyway, this has not been seen since drmtip_373 (14 runs ago) after being seen every single run. So I can confirm this is fixed.
Comment 5 CI Bug Log 2019-10-16 13:05:02 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.