Bug 111708 - [CI][RESUME] render tests - skip - Test requirement: spin, SKIP
Summary: [CI][RESUME] render tests - skip - Test requirement: spin, SKIP
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-17 07:08 UTC by Martin Peres
Modified: 2019-10-16 12:59 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-09-17 07:08:48 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u/igt@perf_pmu@most-busy-idle-check-all-rcs0.html

Test requirement: spin
Subtest most-busy-idle-check-all-rcs0: SKIP (0.000s)
Comment 1 CI Bug Log 2019-09-17 07:09:25 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: random render tests - skip - Test requirement: spin, SKIP
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u/igt@gem_exec_schedule@independent-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@gem_exec_schedule@independent-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_369/fi-tgl-u2/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u/igt@gem_exec_schedule@independent-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@gem_exec_schedule@independent-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_370/fi-tgl-u2/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u/igt@gem_exec_schedule@independent-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@gem_ctx_shared@exec-single-timeline-render.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@perf_pmu@most-busy-idle-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@perf_pmu@most-busy-check-all-rcs0.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_371/fi-tgl-u2/igt@gem_exec_schedule@independent-render.html
Comment 2 Chris Wilson 2019-09-17 07:30:58 UTC
Many engines were dying, so many engines were removed until they no longer die.
Comment 3 Martin Peres 2019-09-17 08:17:43 UTC
(In reply to Chris Wilson from comment #2)
> Many engines were dying, so many engines were removed until they no longer
> die.

NOTABUG is for things that are expected and need to fixing (a test requiring a feature that is gone for example). We plan on making use of those engines, I am re-opening the bug to keep track of the issue.
Comment 4 Chris Wilson 2019-09-17 08:36:35 UTC
The tests are skipping exactly as intended as they have *nothing* to test.
Comment 5 Martin Peres 2019-10-16 12:59:32 UTC
Used to be seen 5 times per run, now not seen since drmtip_378 (9 runs ago). I guess this means this has been fixed when re-enabling the engines!
Comment 6 CI Bug Log 2019-10-16 12:59:38 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.