Bug 111728 - regression: corrupted UI elements in Heroes of the Storm
Summary: regression: corrupted UI elements in Heroes of the Storm
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-18 07:05 UTC by tempel.julian
Modified: 2019-09-18 11:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot showing the corrupted avatar (5.55 MB, image/png)
2019-09-18 07:06 UTC, tempel.julian
Details
renderdoc capture part 1 (190.00 MB, application/x-7z-compressed)
2019-09-18 07:08 UTC, tempel.julian
Details
renderdoc capture part 2 (190.00 MB, application/octet-stream)
2019-09-18 07:12 UTC, tempel.julian
Details
renderdoc capture part 3/3 (174.99 MB, application/octet-stream)
2019-09-18 07:15 UTC, tempel.julian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tempel.julian 2019-09-18 07:05:13 UTC
Since one of the recent commits of mesa-git, there is this corruption in HotS. It doesn't occur with mesa 19.1.7.
What can't be shown on the picture is that some units' healthbars are disappearing too. Depending on what is happening on the screen, they are visible though and then neither the avatar in the left corner is broken (only broken when healthbars are missing).
Perhaps this is some viewport issue?

Uploading screenshot and renderdoc capture.
Comment 1 tempel.julian 2019-09-18 07:06:45 UTC
Created attachment 145417 [details]
screenshot showing the corrupted avatar
Comment 2 tempel.julian 2019-09-18 07:08:57 UTC
Created attachment 145418 [details]
renderdoc capture part 1
Comment 3 tempel.julian 2019-09-18 07:12:44 UTC
Created attachment 145419 [details]
renderdoc capture part 2
Comment 4 tempel.julian 2019-09-18 07:15:31 UTC
Created attachment 145420 [details]
renderdoc capture part 3/3
Comment 5 tempel.julian 2019-09-18 07:17:19 UTC
This is with an RX 570 and mesa-git 8d5f905faad76a46c732dc43c4009cbf0f5da170
Comment 6 Samuel Pitoiset 2019-09-18 07:59:12 UTC
RADV_DEBUG=nohiz?
Comment 7 tempel.julian 2019-09-18 08:10:25 UTC
Issue does not occur with RADV_DEBUG=nohiz.
Comment 8 Samuel Pitoiset 2019-09-18 08:19:05 UTC
Could be related to my recent HTILE changes. I'm looking.
Comment 10 tempel.julian 2019-09-18 09:21:25 UTC
Fixed. That was insanely fast, thanks a lot!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.