Bug 111748 - [SKL/Iris] Random asserts in SynMark Multithread test: "pipe_reference_described: Assertion `count != -1' failed"
Summary: [SKL/Iris] Random asserts in SynMark Multithread test: "pipe_reference_descri...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/Iris (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: not set not set
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-09-19 11:11 UTC by Eero Tamminen
Modified: 2019-09-25 18:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eero Tamminen 2019-09-19 11:11:50 UTC
Setup:
* HW: SKL GT2 i5-6600K
* OS: Ubuntu 18.04
* SW: Git versions of drm-tip kernel, X server, SynMark2 v7.0
* Mesa: 68820007fddbb5b79f1b2b08e66ef14092053a95 (2019-09-18 15:16:36 radv: fix loading 64-bit GS inputs)

Test-case:
* Run multiple times:
  ./synmark2 OglMultithread

Expected outcome:
* Works fine, as with i965 driver

Actual outcome:
* Half of the runs hit following assert:
  src/gallium/auxiliary/util/u_inlines.h:87:pipe_reference_described: Assertion `count != -1' failed.

Because of bug 111385, I don't know when this issue started.  That may also have been affected by enabling VT-d (which allows kernel to enable GPU IOMMU).
Comment 1 GitLab Migration User 2019-09-25 18:47:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1367.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.