Bug 111759 - [navi10] computer hang ring sdma1 timeout
Summary: [navi10] computer hang ring sdma1 timeout
Status: RESOLVED DUPLICATE of bug 111481
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-20 16:24 UTC by Michael de Lang
Modified: 2019-09-21 09:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael de Lang 2019-09-20 16:24:06 UTC
Using the soon-to-be linux 5.4.0-rc1 (574cc4539762561d96b456dbc0544d8898bd4c6e) with oibaf's ppa for DRI, I get the following messages in my kernel.log:

Sep 20 18:12:19 oipo-X570-AORUS-ELITE kernel: [23162.876229] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring sdma1 timeout, signaled seq=140067, emitted seq=140070
Sep 20 18:12:19 oipo-X570-AORUS-ELITE kernel: [23162.876310] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process GPU Process pid 16418 thread firefox:cs0 pid 16498
Sep 20 18:12:19 oipo-X570-AORUS-ELITE kernel: [23162.876312] [drm] GPU recovery disabled.


Music stops playing, desktop becomes completely unresponsive except for mouse. Mouse can be moved normally.

Hardware: Radeon RX 5700
Comment 1 Pierre-Eric Pelloux-Prayer 2019-09-20 16:37:38 UTC
See also https://bugs.freedesktop.org/show_bug.cgi?id=111481 were similar issues were reported.

For now, it seems that the only reliable workaround is to use the Mesa environment variable "AMD_DEBUG=nodma".
Comment 2 Michael de Lang 2019-09-20 16:42:35 UTC
Much appreciated, will test that and if it seems to help, then this can be closed as duplicate.
Comment 3 Michael de Lang 2019-09-21 09:47:55 UTC
Confirmed workaround from #111481 to fix freezes.

*** This bug has been marked as a duplicate of bug 111481 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.