Bug 111769 - DP-1-2-8 driven at boot, off in X, driven at shutdown
Summary: DP-1-2-8 driven at boot, off in X, driven at shutdown
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-09-23 10:33 UTC by Tony Vroon
Modified: 2019-09-23 12:35 UTC (History)
3 users (show)

See Also:
i915 platform: KBL
i915 features: display/DP MST


Attachments
dmesg (505.23 KB, text/plain)
2019-09-23 10:35 UTC, Tony Vroon
no flags Details
Xorg.0.log (85.36 KB, text/plain)
2019-09-23 10:35 UTC, Tony Vroon
no flags Details
git.diff (531 bytes, patch)
2019-09-23 10:39 UTC, Tony Vroon
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Vroon 2019-09-23 10:33:29 UTC
On my Dell XPS 9560, and Linus post-5.3 git tree, my Dell U3415W is no longer driven from X. The screen goes into standby, and attempting to use it shows:
$ xrandr --output DP-1-2-8 --above eDP-1 --auto
xrandr: cannot find crtc for output DP-1-2-8

Note that the screen lights up during boot, as it always did. Once lightdm is started, the screen turns off. When I shut the machine down and X terminates, the screen lights back up.

I will be adding attachments shortly.
Comment 1 Tony Vroon 2019-09-23 10:35:17 UTC
Created attachment 145467 [details]
dmesg

dmesg output with DRM debug, covering boot and X turn-up
Comment 2 Tony Vroon 2019-09-23 10:35:50 UTC
Created attachment 145468 [details]
Xorg.0.log

Xorg log with the "modeset" driver
Comment 3 Tony Vroon 2019-09-23 10:39:07 UTC
Created attachment 145469 [details] [review]
git.diff

I currently set enable_guc to 2, as I find the graphics behave better with this firmware loaded. I find behaviour is the same with enable_guc set to 0 or 2, and can test in either scenario for you.
Comment 4 Tony Vroon 2019-09-23 10:39:46 UTC
The bad commit for me is:
commit 574cc4539762561d96b456dbc0544d8898bd4c6e
Merge: 3c2edc36a774 945b584c94f8
Author: Linus Torvalds <torvalds@linux-foundation.org>
Date:   Thu Sep 19 16:24:24 2019 -0700

    Merge tag 'drm-next-2019-09-18' of git://anongit.freedesktop.org/drm/drm
Comment 5 Jani Nikula 2019-09-23 10:54:36 UTC
(In reply to Tony Vroon from comment #4)
> The bad commit for me is:
> commit 574cc4539762561d96b456dbc0544d8898bd4c6e
> Merge: 3c2edc36a774 945b584c94f8
> Author: Linus Torvalds <torvalds@linux-foundation.org>
> Date:   Thu Sep 19 16:24:24 2019 -0700
> 
>     Merge tag 'drm-next-2019-09-18' of git://anongit.freedesktop.org/drm/drm

Since you're able to bisect, any chance you could bisect into that merge, please? I hope Manasi and Lyude can look into this, but in the mean time bisecting to the actual regressing non-merge commit might be the quickest route to fixing this.
Comment 6 Tony Vroon 2019-09-23 11:00:35 UTC
> Since you're able to bisect, any chance you could bisect into that merge,
> please?

I've not had to bisect into a merge before, do you have a quick guide you can link to?
Comment 7 Ville Syrjala 2019-09-23 12:35:18 UTC
Already fixed with

commit e838bfa8e170415fa3cc8e83ecb171e809c0c422
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Tue Sep 3 18:40:18 2019 +0300

    Revert "drm/i915: Fix DP-MST crtc_mask"


Looks like it hasn't made it into Linus's tree yet.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.