Bug 111777 - [CI][DRMTIP] igt@kms_flip@modeset-vs-vblank-race-* - fail - Failed assertion: set_mode(o, o->fb_ids[o->current_fb_id], 0, 0) == 0
Summary: [CI][DRMTIP] igt@kms_flip@modeset-vs-vblank-race-* - fail - Failed assertion:...
Status: RESOLVED DUPLICATE of bug 111185
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 12:05 UTC by Lakshmi
Modified: 2019-11-14 16:36 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, SKL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-09-23 12:05:58 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_373/fi-icl-u4/igt@kms_flip@modeset-vs-vblank-race-interruptible.html
Starting subtest: modeset-vs-vblank-race-interruptible
(kms_flip:1542) CRITICAL: Test assertion failure function run_test_step, file ../tests/kms_flip.c:727:
(kms_flip:1542) CRITICAL: Failed assertion: set_mode(o, o->fb_ids[o->current_fb_id], 0, 0) == 0
(kms_flip:1542) CRITICAL: Last errno: 22, Invalid argument
Subtest modeset-vs-vblank-race-interruptible failed.
Comment 1 CI Bug Log 2019-09-23 12:06:29 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@kms_flip@modeset-vs-vblank-race-* - fail - Failed assertion: set_mode(o, o->fb_ids[o->current_fb_id], 0, 0) == 0
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_373/fi-icl-u4/igt@kms_flip@modeset-vs-vblank-race-interruptible.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_376/fi-icl-u4/igt@kms_flip@modeset-vs-vblank-race.html
Comment 2 Matt Roper 2019-10-02 20:39:36 UTC
Link training failure:

<7> [583.559919] [drm:intel_dp_start_link_train [i915]] Channel equalization failed 5 times
<7> [583.560117] [drm:intel_dp_start_link_train [i915]] [CONNECTOR:248:DP-4] Link Training failed at link rate = 270000, lane count = 2

causes us to downgrade the link rate to 162000 and that in turn leads to subsequent modeset failure due to no longer having enough bandwidth to support the requested mode:

<7> [583.898138] [drm:intel_dp_compute_config [i915]] DP link computation with max lane count 2 max rate 162000 max bpp 24 pixel clock 148500KHz
<7> [583.898171] [drm:intel_dp_compute_config [i915]] Force DSC en = 0
<7> [583.898205] [drm:intel_atomic_check [i915]] Encoder config failure: -22

These link training failures which lead to subsequent modeset failure is a common problem on fi-icl-u4; marking as duplicate of bug 111185.

*** This bug has been marked as a duplicate of bug 111185 ***
Comment 3 CI Bug Log 2019-10-28 11:58:15 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_flip@modeset-vs-vblank-race-* - fail - Failed assertion: set_mode(o, o-&gt;fb_ids[o-&gt;current_fb_id], 0, 0) == 0 -}
{+ ICL: igt@kms_flip@*modeset-* - fail - Failed assertion: set_mode(o, o-&gt;fb_ids[o-&gt;current_fb_id], 0, 0) == 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_394/fi-icl-u4/igt@kms_flip@flip-vs-modeset-vs-hang.html
Comment 4 CI Bug Log 2019-11-14 16:35:26 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_flip@*modeset-* - fail - Failed assertion: set_mode(o, o-&gt;fb_ids[o-&gt;current_fb_id], 0, 0) == 0 -}
{+ SKL ICL: igt@kms_flip@*modeset-* - fail - Failed assertion: set_mode(o, o-&gt;fb_ids[o-&gt;current_fb_id], 0, 0) == 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7344/fi-skl-6770hq/igt@kms_flip@basic-flip-vs-modeset.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.