Bug 111778 - [CI][DRMTIP] igt@i915_pm_dc@dc[56]-psr - fail - Failed assertion: psr_wait_entry(data->debugfs_fd, data->op_psr_mode)
Summary: [CI][DRMTIP] igt@i915_pm_dc@dc[56]-psr - fail - Failed assertion: psr_wait_e...
Status: RESOLVED DUPLICATE of bug 111608
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 12:21 UTC by Lakshmi
Modified: 2019-09-25 03:54 UTC (History)
3 users (show)

See Also:
i915 platform: CFL, TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-09-23 12:21:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_375/fi-tgl-u/igt@i915_pm_dc@dc5-psr.html

Starting subtest: dc5-psr
(i915_pm_dc:1060) CRITICAL: Test assertion failure function test_dc_state_psr, file ../tests/i915/i915_pm_dc.c:173:
(i915_pm_dc:1060) CRITICAL: Failed assertion: psr_wait_entry(data->debugfs_fd, data->op_psr_mode)
Subtest dc5-psr failed.
Comment 1 Lakshmi 2019-09-23 12:22:42 UTC
(In reply to Lakshmi from comment #0)
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_375/fi-tgl-u/
> igt@i915_pm_dc@dc5-psr.html
> 
> Starting subtest: dc5-psr
> (i915_pm_dc:1060) CRITICAL: Test assertion failure function
> test_dc_state_psr, file ../tests/i915/i915_pm_dc.c:173:
> (i915_pm_dc:1060) CRITICAL: Failed assertion:
> psr_wait_entry(data->debugfs_fd, data->op_psr_mode)
> Subtest dc5-psr failed.

CC'ing Anshuman and Jose.
Comment 3 Jose Roberto de Souza 2019-09-23 17:37:17 UTC
As already said in other bug, the panel on TGL needs to be replaced, it is probably using and old panel that requires a huge setup time:

<7> [34.442532] [drm:intel_dp_compute_config [i915]] PSR condition failed: PSR setup time (330 us) too long

And about the WHL bug, some other tests(PSR or not PSR one) caused the panel to trigger a PSR error, for now we are not trying to fix PSR errors and re-arm PSR, we are just marking a PSR implementation not reliable on this panel and PSR will be kept disable until next boot. So I would mark it a expected or not bug.
Comment 4 Jani Saarinen 2019-09-25 03:54:25 UTC

*** This bug has been marked as a duplicate of bug 111608 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.