Bug 111799 - ANGLE ComputeShaderTest.UniformDirty flaky on Intel Vulkan driver
Summary: ANGLE ComputeShaderTest.UniformDirty flaky on Intel Vulkan driver
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: not set not set
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-24 08:18 UTC by jchen10
Modified: 2019-09-24 09:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
angle_end2end_tests (37.24 MB, application/gzip)
2019-09-24 08:18 UTC, jchen10
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jchen10 2019-09-24 08:18:46 UTC
Created attachment 145488 [details]
angle_end2end_tests

Device: Mesa DRI Intel(R) Iris Pro 6200 (Broadwell GT3e)  (0x1622)
OpenGL core profile version string: 4.5 (Core Profile) 19.3.0-develgit-1c34d19f904

Also reproducible on HD 630, or the Ubuntu system mesa 19.0.8.




To reproduce, simply extract the attachment and run "/angle_end2end_tests --gtest_filter=ComputeShaderTest.UniformDirty/ES3_1_Vulkan --gtest_repeat=100".

And you will see the failure below:

Note: Google Test filter = ComputeShaderTest.UniformDirty/ES3_1_Vulkan
[==========] Running 1 test from 1 test suite.
[----------] Global test environment set-up.
[----------] 1 test from ComputeShaderTest
[ RUN      ] ComputeShaderTest.UniformDirty/ES3_1_Vulkan
../../src/tests/gl_tests/ComputeShaderTest.cpp:2806: Failure
Expected equality of these values:
  expectedValue
    Which is: 600
  outputValues[i]
    Which is: 400
 index 0
[  FAILED  ] ComputeShaderTest.UniformDirty/ES3_1_Vulkan, where GetParam() = ES3_1_Vulkan (75 ms)
[----------] 1 test from ComputeShaderTest (75 ms total)

[----------] Global test environment tear-down
[==========] 1 test from 1 test suite ran. (75 ms total)
[  PASSED  ] 0 tests.
[  FAILED  ] 1 test, listed below:
[  FAILED  ] ComputeShaderTest.UniformDirty/ES3_1_Vulkan, where GetParam() = ES3_1_Vulkan

 1 FAILED TEST
Comment 1 Paul 2019-09-24 09:06:05 UTC
Hi jchen10 
Thanks for the report

Jfyi: Since vulkan issues were moved to the GitLab I've created a new issue there - https://gitlab.freedesktop.org/mesa/mesa/issues/1204 .


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.