Bug 111802 - SegFault missing slots in framebuffer
Summary: SegFault missing slots in framebuffer
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: not set not set
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-24 13:47 UTC by Jeroen Bakker
Modified: 2019-09-25 18:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Bakker 2019-09-24 13:47:35 UTC
This fault has been detected when using Blender (2.80 or master branch)
Steps to reproduce the error:

1. Start Blender
2. Go to edit mode (press tab)
3. Start Merge vertices tool (press ALT-M)
4. Select any mode (press ENTER)

And a segmentation fault happens.
This has been tested on Mesa 18.2.2, 19.0.8 and 19.3.0~dev.

The root cause is that you have a framebuffer with multiple color slots with empty slots in between. If there is an empty color slot between the color slots, all textures after this slot are apparently skipped/discarded.

Our work around is to reuse empty slots with other slots.
`gpu_framebuffer_update_attachments_and_fill_empty_slots`
in https://developer.blender.org/diffusion/B/browse/master/source/blender/gpu/intern/gpu_framebuffer.c$429-483

This issue also existed in the official AMD drivers, but has been solved to our knowledge.

https://developer.blender.org/T70187
Comment 1 GitLab Migration User 2019-09-25 18:50:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1432.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.