Bug 111810 - [CI][BAT] igt@i915_selftest@live_requests - dmesg-warn - DEBUG_LOCKS_WARN_ON(current->softirqs_enabled)
Summary: [CI][BAT] igt@i915_selftest@live_requests - dmesg-warn - DEBUG_LOCKS_WARN_ON(...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: low minor
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-25 07:03 UTC by Lakshmi
Modified: 2019-10-10 12:42 UTC (History)
1 user (show)

See Also:
i915 platform: CML
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-09-25 07:03:11 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5202/fi-cml-h/igt@i915_selftest@live_requests.html

 irq event stamp: 3792
<4> [413.474175] irq event stamp: 7199
<4> [413.474180] hardirqs last  enabled at (3791): [<ffffffff819d7c5c>] _raw_spin_unlock_irqrestore+0x4c/0x60
<4> [413.474182] hardirqs last  enabled at (7198): [<ffffffff81001a6a>] trace_hardirqs_on_thunk+0x1a/0x20
<4> [413.474184] hardirqs last disabled at (3792): [<ffffffff81001a8a>] trace_hardirqs_off_thunk+0x1a/0x20
<4> [413.474185] hardirqs last disabled at (7199): [<ffffffff81001a8a>] trace_hardirqs_off_thunk+0x1a/0x20
<4> [413.474240] softirqs last  enabled at (3780): [<ffffffffa0650f7c>] i915_request_add+0xbc/0x390 [i915]
<4> [413.474242] softirqs last  enabled at (6962): [<ffffffff81c0033e>] __do_softirq+0x33e/0x4ae
<4> [413.474282] softirqs last disabled at (3752): [<ffffffffa0650f7c>] i915_request_add+0xbc/0x390 [i915]
<4> [413.474284] softirqs last disabled at (6983): [<ffffffff810b8459>] irq_exit+0xa9/0xc0
<4> [413.474288] DEBUG_LOCKS_WARN_ON(current->softirqs_enabled)
<4> [413.474293] WARNING: CPU: 3 PID: 5106 at kernel/locking/lockdep.c:4424 check_flags.part.23+0x161/0x1a0
<4> [413.474294] Modules linked in: i915(+) amdgpu gpu_sched ttm vgem snd_hda_codec_hdmi snd_hda_codec_generic x86_pkg_temp_thermal coretemp crct10dif_pclmul cdc_ether crc32_pclmul usbnet mii snd_intel_nhlt snd_hda_codec snd_hwdep ghash_clmulni_intel snd_hda_core snd_pcm prime_numbers i2c_hid [last unloaded: i915]
<4> [413.474304] CPU: 3 PID: 5106 Comm: igt/6.10 Tainted: G     U            5.3.0-CI-CI_DRM_6948+ #1
<4> [413.474305] Hardware name: Intel Corporation WhiskeyLake Client Platform/CometLake H SODIMM (ERB/CRB), BIOS CMLSFWR1.R00.1285.D00.1907121104 07/12/2019
<4> [413.474307] RIP: 0010:check_flags.part.23+0x161/0x1a0
<4> [413.474308] Code: 00 85 c0 0f 84 f7 fe ff ff 8b 35 6a ad 22 01 85 f6 0f 85 e9 fe ff ff 48 c7 c6 1f 9f 09 82 48 c7 c7 08 71 08 82 e8 4f 78 f9 ff <0f> 0b e9 cf fe ff ff 48 c7 c6 03 9f 09 82 48 c7 c7 08 71 08 82 e8
<4> [413.474310] RSP: 0018:ffffc90000200e60 EFLAGS: 00010082
<4> [413.474311] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000010001
<4> [413.474332] RDX: 0000000080010001 RSI: 0000000000000000 RDI: ffffffff8112e6fe
<4> [413.474333] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
<4> [413.474334] R10: 0000000000000000 R11: 0000000080000003 R12: 0000000000000002
<4> [413.474335] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000046
<4> [413.474337] FS:  0000000000000000(0000) GS:ffff88844b580000(0000) knlGS:0000000000000000
<4> [413.474338] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [413.474339] CR2: 00007f88d1544c80 CR3: 0000000005210003 CR4: 00000000003606e0
<4> [413.474340] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
<4> [413.474341] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
<4> [413.474342] Call Trace:
<4> [413.474343]  <IRQ>
<4> [413.474345]  lock_acquire+0x150/0x1c0
<4> [413.474347]  ? cpuacct_account_field+0xd8/0x1d0
<4> [413.474350]  ? tick_sched_handle.isra.5+0x60/0x60
<4> [413.474352]  account_system_index_time+0x91/0x1f0
<4> [413.474354]  ? account_system_index_time+0x46/0x1f0
<4> [413.474356]  update_process_times+0x13/0x40
<4> [413.474358]  tick_sched_timer+0x42/0x80
<4> [413.474360]  __hrtimer_run_queues+0x11e/0x4b0
<4> [413.474363]  hrtimer_interrupt+0xea/0x250
<4> [413.474366]  smp_apic_timer_interrupt+0x96/0x280
<4> [413.474368]  apic_timer_interrupt+0xf/0x20
<4> [413.474369]  </IRQ>
<4> [413.474371] RIP: 0010:osq_lock+0x6a/0x110
<4> [413.474372] Code: c0 0f 84 a5 00 00 00 83 e8 01 48 98 48 03 2c c5 80 56 16 82 48 89 6b 08 48 89 5d 00 8b 43 10 85 c0 74 0e e9 84 00 00 00 f3 90 <8b> 43 10 85 c0 75 7b 65 48 8b 04 25 00 5f 01 00 48 8b 00 a8 08 74
<4> [413.474373] RSP: 0018:ffffc90000dd7d58 EFLAGS: 00000246 ORIG_RAX: ffffffffffffff13
<4> [413.474375] RAX: 0000000080004000 RBX: ffff88844b5badc0 RCX: 000000001d80d1e9
<4> [413.474376] RDX: ffff8883febd30d0 RSI: 0000000054d85f4b RDI: ffff88842d8400a8
<4> [413.474377] RBP: ffff88844b53adc0 R08: ffff8883febd30d0 R09: 00000000fffffffe
<4> [413.474378] R10: 0000000062ee4e46 R11: 00000000fedfa641 R12: ffff8883febd2840
<4> [413.474379] R13: ffff88842d8400a8 R14: 0000000000000002 R15: ffff88842d840068
<4> [413.474382]  ? osq_lock+0x24/0x110
<4> [413.474384]  __mutex_lock+0x5d3/0x9b0
<4> [413.474386]  ? _raw_spin_unlock_irqrestore+0x4c/0x60
<4> [413.474388]  ? lockdep_hardirqs_on+0xe3/0x1c0
<4> [413.474433]  ? __igt_breadcrumbs_smoketest+0x18c/0x950 [i915]
<4> [413.474435]  ? _raw_spin_unlock_irqrestore+0x39/0x60
<4> [413.474438]  ? dma_fence_add_callback+0x67/0x1f0
<4> [413.474472]  ? timer_i915_sw_fence_wake+0x90/0x90 [i915]
<4> [413.474513]  ? __igt_breadcrumbs_smoketest+0x18c/0x950 [i915]
<4> [413.474552]  __igt_breadcrumbs_smoketest+0x18c/0x950 [i915]
<4> [413.474555]  ? lockdep_hardirqs_on+0xe3/0x1c0
<4> [413.474557]  ? _raw_spin_unlock_irqrestore+0x39/0x60
<4> [413.474595]  ? i915_request_add+0x390/0x390 [i915]
<4> [413.474597]  kthread+0x119/0x130
<4> [413.474599]  ? kthread_park+0xa0/0xa0
<4> [413.474601]  ret_from_fork+0x24/0x50
<4> [413.474605] irq event stamp: 3016
<4> [413.474606] hardirqs last  enabled at (3015): [<ffffffff819d7c5c>] _raw_spin_unlock_irqrestore+0x4c/0x60
<4> [413.474608] hardirqs last disabled at (3016): [<ffffffff81001a8a>] trace_hardirqs_off_thunk+0x1a/0x20
<4> [413.474645] softirqs last  enabled at (3004): [<ffffffffa0650f7c>] i915_request_add+0xbc/0x390 [i915]
<4> [413.474680] softirqs last disabled at (2976): [<ffffffffa0650f7c>] i915_request_add+0xbc/0x390 [i915]
<4> [413.474683] WARNING: CPU: 3 PID: 5106 at kernel/locking/lockdep.c:4424 check_flags.part.23+0x161/0x1a0
<4> [413.474684] ---[ end trace d6de88282e69b4d3 ]---
Comment 1 CI Bug Log 2019-09-25 07:05:58 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* CML: igt@i915_selftest@live_requests - dmesg-warn - DEBUG_LOCKS_WARN_ON(current-&gt;softirqs_enabled)
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5202/fi-cml-h/igt@i915_selftest@live_requests.html

* CML: igt@runner@aborted - fail - Previous test: i915_selftest (live_requests)
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-bdw-5557u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-bdw-gvtdvm/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-bsw-kefka/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-bxt-dsi/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-cfl-8109u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-cfl-8700k/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-gdg-551/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-ilk-650/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-kbl-7500u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-kbl-8809g/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-kbl-r/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-kbl-x1275/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-pnv-d510/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-tgl-u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-tgl-u2/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5019/fi-whl-u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-bdw-gvtdvm/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-bsw-kefka/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-bsw-n3050/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-cfl-8700k/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-cml-u2/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-gdg-551/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-ilk-650/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-kbl-x1275/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-pnv-d510/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-tgl-u/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_5020/fi-tgl-u2/igt@runner@aborted.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_5202/fi-cml-h/igt@runner@aborted.html
Comment 2 Chris Wilson 2019-09-25 07:39:08 UTC
NOTOURBUG, but we should pass on the splat to somebody else.
Comment 3 Francesco Balestrieri 2019-10-10 06:19:58 UTC
Seen once in 280 runs, looks minor (for now)
Comment 4 Chris Wilson 2019-10-10 12:42:16 UTC
If we can't reproduce it well, we can't help upstream debug it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.