Bug 111885 - Display broken on CHV (Different colors in the screen console)
Summary: Display broken on CHV (Different colors in the screen console)
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high major
Assignee: Swati Sharma
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-02 13:58 UTC by Jani Saarinen
Modified: 2019-10-10 06:17 UTC (History)
3 users (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/color management


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2019-10-02 13:58:31 UTC
When booting BSW system to Console then seeing blue color on screen console. 
Regression caused by drmtip_367 having atleast these patches:

4d154d33941d drm/i915/display: Extract chv_read_luts()
^^^^^^^^^^

8efd06989df4 drm/i915/display: Extract i965_read_luts()
b0a7c754140b drm/i915/display: Add gamma precision function for CHV

Suspected patch highlighted.
Comment 2 Swati Sharma 2019-10-04 09:45:51 UTC
Following patch should fix the issue
https://patchwork.freedesktop.org/patch/334349/?series=67586&rev=1
Comment 3 Jani Saarinen 2019-10-04 10:23:30 UTC
Will test when CI builds build.
Comment 4 Jani Saarinen 2019-10-04 11:34:52 UTC
See normal colors with this build now.
Comment 5 Jani Saarinen 2019-10-09 13:32:01 UTC
Swati, any update here?
Comment 6 Swati Sharma 2019-10-09 16:17:57 UTC
Patches 1-2 of series https://patchwork.freedesktop.org/series/67586/) pushed to dinq by Ville. It should fix the issue.
Comment 7 Jani Saarinen 2019-10-09 16:51:31 UTC
Will test tomorrow latest drm-tip.
Comment 8 Jani Saarinen 2019-10-10 06:13:31 UTC
Fix in https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7042/git-log-oneline.txt 
tested latest 7046 and works, closing.
Comment 9 Jani Saarinen 2019-10-10 06:17:19 UTC
Thanks Swati, closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.