Bug 111907 - [HSW] Monitor black with DP connected (Ubuntu 19.04)
Summary: [HSW] Monitor black with DP connected (Ubuntu 19.04)
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev, Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-04 13:03 UTC by Jani Saarinen
Modified: 2019-10-10 11:49 UTC (History)
1 user (show)

See Also:
i915 platform: HSW
i915 features: display/DP


Attachments
dmesg_with_DP_connected (57.10 KB, text/plain)
2019-10-04 13:03 UTC, Jani Saarinen
no flags Details
Display_info (2.50 KB, text/plain)
2019-10-04 13:04 UTC, Jani Saarinen
no flags Details
Dmesg_with_DP (debugs) (202.14 KB, text/plain)
2019-10-07 05:37 UTC, Jani Saarinen
no flags Details
Xorg log (42.44 KB, text/plain)
2019-10-07 05:37 UTC, Jani Saarinen
no flags Details
Xorg with Intel driver (22.55 KB, text/plain)
2019-10-07 05:53 UTC, Jani Saarinen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2019-10-04 13:03:13 UTC
Created attachment 145643 [details]
dmesg_with_DP_connected

With Ubuntu 19.04 booted to desktop no picture on monitor when booting to UI. 
there was some during boot on DP monitor but when booted to UI no picture at all. This with latest drm-tip (CI_DRM_7000) 

See dmesg and i915_display_info
Comment 1 Jani Saarinen 2019-10-04 13:04:14 UTC
Created attachment 145644 [details]
Display_info
Comment 2 Lakshmi 2019-10-04 15:32:21 UTC
(In reply to Jani Saarinen from comment #0)
> Created attachment 145643 [details]
> dmesg_with_DP_connected
> 
> With Ubuntu 19.04 booted to desktop no picture on monitor when booting to
> UI. 
> there was some during boot on DP monitor but when booted to UI no picture at
> all. This with latest drm-tip (CI_DRM_7000) 
> 
> See dmesg and i915_display_info

Jani, Can you attach with debug parameters?
Comment 3 Jani Saarinen 2019-10-07 05:37:29 UTC
Created attachment 145669 [details]
Dmesg_with_DP (debugs)
Comment 4 Jani Saarinen 2019-10-07 05:37:48 UTC
Created attachment 145670 [details]
Xorg log
Comment 5 Jani Saarinen 2019-10-07 05:53:34 UTC
Created attachment 145671 [details]
Xorg with Intel driver
Comment 6 Jani Saarinen 2019-10-07 12:17:49 UTC
Testes with other monitor (HP ZR24w) and with that picture from DP port was shown.
Comment 7 Lakshmi 2019-10-10 08:09:12 UTC
Not sure, if this issue is a duplicate of bug 111878 ?
Comment 8 Jani Saarinen 2019-10-10 08:19:06 UTC
Well on this other monitor worked better, I think we can close this now.
Comment 9 Lakshmi 2019-10-10 11:49:34 UTC
(In reply to Jani Saarinen from comment #8)
> Well on this other monitor worked better, I think we can close this now.

Resolving this issue as WORKSFORME.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.