Bug 111930 - [CI][DRMTIP]igt@prime_vgem@basic-sync-default - incomplete - BUG: sleeping function called from invalid context at kernel/sched/completion.c:99
Summary: [CI][DRMTIP]igt@prime_vgem@basic-sync-default - incomplete - BUG: sleeping fu...
Status: RESOLVED DUPLICATE of bug 111512
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-08 17:23 UTC by Lakshmi
Modified: 2019-10-08 20:48 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-10-08 17:23:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_384/fi-tgl-u/igt@prime_vgem@basic-sync-default.html
<3> [373.078854] BUG: sleeping function called from invalid context at kernel/sched/completion.c:99
<3> [373.078874] in_atomic(): 0, irqs_disabled(): 0, non_block: 0, pid: 2395, name: prime_vgem
<4> [373.079033] INFO: lockdep is turned off.
<3> [373.079039] Preemption disabled at:
<4> [373.079041] [<0000000000000000>] 0x0
<4> [373.079050] CPU: 2 PID: 2395 Comm: prime_vgem Tainted: G     UD           5.4.0-rc1-gf99065c68952-drmtip_384+ #1
<4> [373.079059] Hardware name: Intel Corporation Tiger Lake Client Platform/TigerLake U DDR4 SODIMM RVP, BIOS TGLSFWI1.R00.2321.A08.1909162051 09/16/2019
<4> [373.079069] Call Trace:
<4> [373.079078]  dump_stack+0x67/0x9b
<4> [373.079086]  ___might_sleep+0x178/0x260
<4> [373.079095]  wait_for_completion+0x37/0x1a0
<4> [373.079104]  virt_efi_query_variable_info+0x161/0x1b0
<4> [373.079113]  efi_query_variable_store+0xb3/0x1a0
<4> [373.079121]  ? efivar_entry_set_safe+0x19c/0x220
<4> [373.079126]  efivar_entry_set_safe+0x19c/0x220
<4> [373.079133]  ? efi_pstore_write+0x10b/0x150
<4> [373.079137]  efi_pstore_write+0x10b/0x150
<4> [373.079147]  pstore_dump+0x127/0x340
<4> [373.079155]  kmsg_dump+0x87/0x1c0
<4> [373.079163]  oops_end+0x3e/0x90
<4> [373.079168]  do_trap+0x80/0x100
<4> [373.079176]  ? dma_buf_release+0xd8/0xf0
<4> [373.079183]  do_invalid_op+0x31/0x40
<4> [373.079188]  ? dma_buf_release+0xd8/0xf0
<4> [373.079195]  invalid_op+0x23/0x30
<4> [373.079200] RIP: 0010:dma_buf_release+0xd8/0xf0
<4> [373.079206] Code: 00 00 e8 1b ec a9 ff 48 89 df e8 03 24 b8 ff 31 c0 5b c3 48 8b 93 d0 00 00 00 48 8b 83 d8 00 00 00 48 89 42 08 48 89 10 eb 96 <0f> 0b e8 31 36 00 00 eb c8 0f 0b b8 ea ff ff ff c3 0f 1f 80 00 00
<4> [373.079220] RSP: 0018:ffffb73700687e98 EFLAGS: 00010206
<4> [373.079226] RAX: 0000000000000005 RBX: ffff967a18dfae68 RCX: 0000000000000000
<4> [373.079232] RDX: 0000000000000000 RSI: ffff967a16b7b840 RDI: ffff967a077589e8
<4> [373.079240] RBP: 0000000000000010 R08: 0000000000000000 R09: 0000000000000000
<4> [373.079249] R10: ffff967a077589e8 R11: ffff967a16b7b850 R12: 0000000000080005
<4> [373.079257] R13: ffff967a077589e8 R14: ffff967a1e9cef20 R15: ffff967a0d84ebe8
<4> [373.079269]  __fput+0xbf/0x250
<4> [373.079276]  task_work_run+0x82/0xb0
<4> [373.079282]  exit_to_usermode_loop+0xad/0xb0
<4> [373.079287]  do_syscall_64+0x1b9/0x210
<4> [373.079292]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [373.079297] RIP: 0033:0x7f148c78e421
<4> [373.079301] Code: f7 d8 64 89 02 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 66 90 8b 05 ea cf 20 00 85 c0 75 16 b8 03 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 3f f3 c3 0f 1f 44 00 00 53 89 fb 48 83 ec 10
<4> [373.079315] RSP: 002b:00007ffc11e5ce78 EFLAGS: 00000246 ORIG_RAX: 0000000000000003
<4> [373.079322] RAX: 0000000000000000 RBX: 00007f148d255000 RCX: 00007f148c78e421
<4> [373.079330] RDX: 00007ffc11e5ce60 RSI: 0000000040086200 RDI: 0000000000000008
<4> [373.079337] RBP: 0000000000000008 R08: 0000000000000000 R09: 000000000000003c
<4> [373.079345] R10: 00000000ffffffc4 R11: 0000000000000246 R12: 0000000000000000
<4> [373.079352] R13: 0000000000000000 R14: 0000000000000006 R15: 0000000000000000
Comment 1 CI Bug Log 2019-10-08 17:23:46 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@prime_vgem@basic-sync-default - incomplete - BUG: sleeping function called from invalid context at kernel/sched/completion.c:99
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_384/fi-tgl-u/igt@prime_vgem@basic-sync-default.html
Comment 2 CI Bug Log 2019-10-08 20:42:39 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@runner@aborted - fail - Previous test: prime_vgem (basic-sync-default)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_384/fi-tgl-u/igt@runner@aborted.html
Comment 3 Chris Wilson 2019-10-08 20:48:49 UTC

*** This bug has been marked as a duplicate of bug 111512 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.