Bug 111993 - [CI][BAT][BSW] igt@i915_selftest@live_execlists - incomplete - BUG: sleeping function called from invalid context at ./include/linux/percpu-rwsem.h:38
Summary: [CI][BAT][BSW] igt@i915_selftest@live_execlists - incomplete - BUG: sleeping...
Status: CLOSED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-14 09:09 UTC by Lakshmi
Modified: 2019-10-14 10:16 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: GEM/execlists


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-10-14 09:09:34 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7021/fi-bsw-cyan/igt@i915_selftest@live_execlists.html
<4> [590.161047] RIP: 0010:__i915_schedule+0x794/0x9d0 [i915]
<4> [590.161061] Code: 24 28 4d 89 38 8b b5 68 ff ff ff 41 39 b6 48 05 00 00 7d 2f 49 8b 86 08 05 00 00 41 89 b6 48 05 00 00 48 8b 00 48 85 c0 74 19 <8b> 80 e0 01 00 00 ba ff ff ff ff 83 c8 01 0f 48 c2 39 c6 0f 8f 4e
<4> [590.161068] RSP: 0018:ffffc9000045f7c8 EFLAGS: 00010002
<4> [590.161075] RAX: 0000000000fc0040 RBX: ffffc9000045f7f0 RCX: 0000000000000000
<4> [590.161081] RDX: 0000000000000002 RSI: 0000000000000003 RDI: ffffffff822479a0
<4> [590.161086] RBP: ffffc9000045f878 R08: 0000000000000000 R09: 0000000000000001
<4> [590.161092] R10: 0000000000000000 R11: ffff888071f7a880 R12: ffff888026fc01f0
<4> [590.161098] R13: ffffc9000045f7c0 R14: ffff88806292a158 R15: ffff888026fc0210
<4> [590.161104] FS:  00007fe3bb953e40(0000) GS:ffff888079a80000(0000) knlGS:0000000000000000
<4> [590.161110] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [590.161116] CR2: 0000000000fc0220 CR3: 000000005e5d2000 CR4: 00000000001006e0
<3> [590.161123] BUG: sleeping function called from invalid context at ./include/linux/percpu-rwsem.h:38
<3> [590.161130] in_atomic(): 1, irqs_disabled(): 1, non_block: 0, pid: 4615, name: i915_selftest
<4> [590.161135] INFO: lockdep is turned off.
<4> [590.161141] irq event stamp: 0
<4> [590.161148] hardirqs last  enabled at (0): [<0000000000000000>] 0x0
<4> [590.161159] hardirqs last disabled at (0): [<ffffffff810aca88>] copy_process+0x538/0x1d80
<4> [590.161166] softirqs last  enabled at (0): [<ffffffff810aca88>] copy_process+0x538/0x1d80
<4> [590.161173] softirqs last disabled at (0): [<0000000000000000>] 0x0
<3> [590.161177] Preemption disabled at:
<4> [590.161179] [<0000000000000000>] 0x0
<4> [590.161190] CPU: 1 PID: 4615 Comm: i915_selftest Tainted: G     UD           5.4.0-rc2-CI-CI_DRM_7021+ #1
<4> [590.161196] Hardware name: GOOGLE Cyan/Cyan, BIOS MrChromebox 02/15/2018
<4> [590.161201] Call Trace:
<4> [590.161218]  dump_stack+0x67/0x9b
<4> [590.161228]  ___might_sleep+0x178/0x260
<4> [590.161239]  exit_signals+0x2b/0x350
<4> [590.161248]  do_exit+0xa3/0xd70
<4> [590.161264]  rewind_stack_do_exit+0x17/0x20
<6> [590.161587] note: i915_selftest[4615] exited with preempt_count 2
Comment 1 CI Bug Log 2019-10-14 09:10:26 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* BSW: igt@i915_selftest@live_execlists - incomplete -  BUG: sleeping function called from invalid context at ./include/linux/percpu-rwsem.h:38
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7021/fi-bsw-cyan/igt@i915_selftest@live_execlists.html
Comment 2 Chris Wilson 2019-10-14 09:14:21 UTC
The curse of an incomplete dmesg. That backtrace is not what it says it, i.e. it's not the cause of the bug.
Comment 3 Lakshmi 2019-10-14 10:16:33 UTC
This failure is now associated to bug 111542
. 
Closing and archiving the bug.
Comment 4 CI Bug Log 2019-10-14 10:16:44 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.