Bug 112028 - (S)VGA outputs from i915 defunct after upgrade to Kernel 5.3
Summary: (S)VGA outputs from i915 defunct after upgrade to Kernel 5.3
Status: RESOLVED DUPLICATE of bug 111966
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-16 11:17 UTC by Jiri Slaby
Modified: 2019-10-29 08:54 UTC (History)
4 users (show)

See Also:
i915 platform: CFL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Slaby 2019-10-16 11:17:47 UTC
We have a downstream report:
https://bugzilla.suse.com/show_bug.cgi?id=1152971

The users report VGA and SVGA outputs become dead during boot after they upgraded from 5.2.x to 5.3.x. The new message in dmesg is:
[drm] failed to retrieve link info, disabling eDP
Comment 1 Jiri Slaby 2019-10-17 06:54:27 UTC
> [drm:intel_dp_init_connector [i915]] Adding eDP connector on port A
> [drm:intel_pps_dump_state [i915]] cur t1_t3 0 t8 0 t9 0 t10 0 t11_t12 0
> [drm:intel_pps_dump_state [i915]] vbt t1_t3 2000 t8 10 t9 2000 t10 500 t11_t12 6000
> [drm:intel_dp_init_panel_power_sequencer [i915]] panel power up delay 200, power down delay 50, power cycle delay 600
> [drm:intel_dp_init_panel_power_sequencer [i915]] backlight on delay 1, off delay 200
> [drm:intel_dp_init_panel_power_sequencer_registers [i915]] panel power sequencer register settings: PP_ON 0x7d00001, PP_OFF 0x1f40001, PP_DIV 0x60
> [drm:intel_edp_panel_vdd_sanitize [i915]] VDD left on by BIOS, adjusting state tracking
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> PM: Image not found (code -22)
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> usb 1-7: new full-speed USB device number 2 using xhci_hcd
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:intel_dp_aux_xfer [i915]] dp_aux_ch timeout status 0x7d4003ff
> [drm:drm_dp_dpcd_access [drm_kms_helper]] Too many retries, giving up. First error: -110
> [drm:drm_dp_dpcd_read [drm_kms_helper]] DPDDC-A: 0x00000 AUX -> (ret=-110)
> [drm] failed to retrieve link info, disabling eDP
> [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
> [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x00000000 PP_CONTROL: 0x00000060
Comment 2 Jiri Slaby 2019-10-17 09:43:05 UTC
(In reply to Jiri Slaby from comment #16)
> > -[drm:parse_ddi_port [i915]] port A trying to use the same AUX CH (0x40) as port E, disabling port A DP support
> > +[drm:parse_ddi_port [i915]] port E trying to use the same AUX CH (0x40) as port A, disabling port E DP support
> 
> So 5.3.x disables port E, 5.2.x disables port A (due to conflict).

Likely due to:
commit 36a0f92020dc8794d3aa69b7fb4c5d2bf99b0099
Author: Jani Nikula <jani.nikula@intel.com>
Date:   Fri May 31 16:14:51 2019 +0300

    drm/i915/bios: make child device order the priority order
Comment 3 Lakshmi 2019-10-17 12:34:03 UTC
Jiri, Can you please attach the dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?

Also, can you please verify the issue with drmtip?
(https://cgit.freedesktop.org/drm-tip)

Did it ever show the output with kernel 5.3.x?
Comment 4 Jiri Slaby 2019-10-17 18:03:16 UTC
(In reply to Lakshmi from comment #3)
> Jiri, Can you please attach the dmesg from boot with kernel parameters
> drm.debug=0x1e log_buf_len=4M?

It is attached to the downstream bug from several reporters. BTW, with debug=0x10e which is more appropriate for this bugreport, I would say.

> Also, can you please verify the issue with drmtip?
> (https://cgit.freedesktop.org/drm-tip)

Sorry, I cannot reproduce, try asking them.

> Did it ever show the output with kernel 5.3.x?

Detto.
Comment 5 Jiri Slaby 2019-10-20 08:07:06 UTC
(In reply to Jiri Slaby from comment #2)
> commit 36a0f92020dc8794d3aa69b7fb4c5d2bf99b0099
> Author: Jani Nikula <jani.nikula@intel.com>
> Date:   Fri May 31 16:14:51 2019 +0300
> 
>     drm/i915/bios: make child device order the priority order

Reverting the patch:
https://apibugzilla.suse.com/attachment.cgi?id=821977&action=diff

fixes the issue.
Comment 6 Jiri Slaby 2019-10-20 08:08:09 UTC
(In reply to Jiri Slaby from comment #5)
> (In reply to Jiri Slaby from comment #2)
> > commit 36a0f92020dc8794d3aa69b7fb4c5d2bf99b0099
> > Author: Jani Nikula <jani.nikula@intel.com>
> > Date:   Fri May 31 16:14:51 2019 +0300
> > 
> >     drm/i915/bios: make child device order the priority order
> 
> Reverting the patch:
> https://apibugzilla.suse.com/attachment.cgi?id=821977&action=diff

Correct link:
https://bugzilla.suse.com/attachment.cgi?id=821977&action=diff

> fixes the issue.
Comment 7 Lakshmi 2019-10-21 05:48:44 UTC
(In reply to Jiri Slaby from comment #2)
> (In reply to Jiri Slaby from comment #16)
> > > -[drm:parse_ddi_port [i915]] port A trying to use the same AUX CH (0x40) as port E, disabling port A DP support
> > > +[drm:parse_ddi_port [i915]] port E trying to use the same AUX CH (0x40) as port A, disabling port E DP support
> > 
> > So 5.3.x disables port E, 5.2.x disables port A (due to conflict).
> 
> Likely due to:
> commit 36a0f92020dc8794d3aa69b7fb4c5d2bf99b0099
> Author: Jani Nikula <jani.nikula@intel.com>
> Date:   Fri May 31 16:14:51 2019 +0300
> 
>     drm/i915/bios: make child device order the priority order

(In reply to Jiri Slaby from comment #6)
> (In reply to Jiri Slaby from comment #5)
> > (In reply to Jiri Slaby from comment #2)
> > > commit 36a0f92020dc8794d3aa69b7fb4c5d2bf99b0099
> > > Author: Jani Nikula <jani.nikula@intel.com>
> > > Date:   Fri May 31 16:14:51 2019 +0300
> > > 
> > >     drm/i915/bios: make child device order the priority order
> > 
> > Reverting the patch:
> > https://apibugzilla.suse.com/attachment.cgi?id=821977&action=diff
> 
> Correct link:
> https://bugzilla.suse.com/attachment.cgi?id=821977&action=diff
> 
> > fixes the issue.

@Jani, any comments?
Comment 8 Jiri Slaby 2019-10-29 08:54:58 UTC

*** This bug has been marked as a duplicate of bug 111966 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.