Bug 112036 - [CI][RESUME]igt@kms_big_fb@yf-tiled-addfb|igt@kms_concurrent@pipe-a|igt@kms_dp_dsc@basic-dsc-enable-edp - incomplete - system hang
Summary: [CI][RESUME]igt@kms_big_fb@yf-tiled-addfb|igt@kms_concurrent@pipe-a|igt@kms_d...
Status: RESOLVED DUPLICATE of bug 111996
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-16 12:54 UTC by Lakshmi
Modified: 2019-10-18 11:33 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 CI Bug Log 2019-10-16 12:54:54 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL: igt@kms_big_fb@yf-tiled-addfb|igt@kms_concurrent@pipe-a|igt@kms_dp_dsc@basic-dsc-enable-edp - incomplete - system hang
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7058/re-tgl1-display/igt@kms_big_fb@yf-tiled-addfb.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7058/re-tgl1-display/igt@kms_concurrent@pipe-a.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7058/re-tgl1-display/igt@kms_dp_dsc@basic-dsc-enable-edp.html
Comment 2 Manasi 2019-10-16 21:05:07 UTC
Assessment:
All the boot logs show that for a hotplug on DP-1 , it asks for AUX B power enable for Combo PHY AUX power well enable which is not set in HSW_PWR_WELL_CTL_STATE and hence power well timeout. This can occur if TBT DP tunnel is down which looks like a case with this TGL board.

Manasi
Comment 3 Jani Saarinen 2019-10-17 06:07:38 UTC
So on boot log:
<7>[   21.974202] [drm:hsw_wait_for_power_well_enable.isra.13 [i915]] AUX B power well enable timeout
<4>[   21.974205] ------------[ cut here ]------------
<4>[   21.974208] WARN_ON(!power_well->desc->hsw.is_tc_tbt)

And this is then duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=111996?
Comment 4 shashank.sharma@intel.com 2019-10-17 07:12:54 UTC
This warning will come only if it's not a TBT port, so definitely not TBT case. 

The signature of the issue is same, before accessing the Aux channel, we are trying to enable AUX_B, which is not getting enabled, getting timed-out. So this could be a duplicate.

- Shashank
Comment 5 Lakshmi 2019-10-18 11:33:31 UTC

*** This bug has been marked as a duplicate of bug 111996 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.