Bug 112051 - Got call trace message "eDP powered off while attempting aux channel communication" while boot up
Summary: Got call trace message "eDP powered off while attempting aux channel communic...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-18 09:12 UTC by Cyrus
Modified: 2019-11-13 12:22 UTC (History)
5 users (show)

See Also:
i915 platform: CML
i915 features: display/eDP


Attachments
dmesg (477.41 KB, text/x-log)
2019-10-18 09:12 UTC, Cyrus
no flags Details
lspci -vv (21.98 KB, text/x-log)
2019-10-18 09:13 UTC, Cyrus
no flags Details
dmesg from drm-tip 54d0d8863278 (839.97 KB, text/plain)
2019-10-21 07:11 UTC, Cyrus
no flags Details
Fix PCH type detection (1.68 KB, patch)
2019-10-21 11:44 UTC, Imre Deak
no flags Details | Splinter Review
dmesg with 0001-drm-i915-Add-new-CNL-PCH-ID-seen-on-a-CML-platform.patch (568.22 KB, text/x-log)
2019-10-22 03:28 UTC, Cyrus
no flags Details
dmesg with patch on Vostro (290.69 KB, text/x-log)
2019-10-24 10:03 UTC, Cyrus
no flags Details
dmesg without patch on Vostro (563.57 KB, text/x-log)
2019-10-24 10:05 UTC, Cyrus
no flags Details
Attempt to fix the VBT DDC pin mapping (1.05 KB, patch)
2019-10-28 18:38 UTC, Imre Deak
no flags Details | Splinter Review
Fix PCH type detection again (2.18 KB, patch)
2019-10-30 16:34 UTC, Imre Deak
no flags Details | Splinter Review
dmesg-optiplex-AIO-drm-i915-fix-detection-for-a-cmp-v-pch.log (729.13 KB, text/plain)
2019-10-31 07:11 UTC, Cyrus
no flags Details
dmesg-vostro-desktop-drm-i915-fix-detection-for-a-cmp-v-pch.log (681.78 KB, text/plain)
2019-10-31 07:12 UTC, Cyrus
no flags Details
xranr-q-optiplex.log (2.33 KB, text/plain)
2019-10-31 07:13 UTC, Cyrus
no flags Details
xranr-q-vostro.log (1.22 KB, text/plain)
2019-10-31 07:13 UTC, Cyrus
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrus 2019-10-18 09:12:48 UTC
Created attachment 145771 [details]
dmesg

Bug description:

Got the call trace message during system boot up.

[    2.999233] ------------[ cut here ]------------
[    2.999238] eDP powered off while attempting aux channel communication.
[    2.999338] WARNING: CPU: 2 PID: 296 at drivers/gpu/drm/i915/display/intel_dp.c:1148 intel_dp_aux_xfer+0x767/0x900 [i915]
[    2.999341] Modules linked in: i915(+) i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm r8169 ahci realtek libahci wmi video
[    2.999350] CPU: 2 PID: 296 Comm: systemd-udevd Not tainted 5.3.0-997-generic #201910072204
[    2.999352] Hardware name: Dell Inc. OptiPlex 3280 AIO/, BIOS 99.00.08 10/01/2019
[    2.999391] RIP: 0010:intel_dp_aux_xfer+0x767/0x900 [i915]
[    2.999394] Code: e8 ee b5 ff ff 84 c0 0f 85 ec f9 ff ff 48 8b 7d 80 e8 5d b6 ff ff 84 c0 0f 85 db f9 ff ff 48 c7 c7 50 22 5d c0 e8 84 ea b5 d1 <0f> 0b 48 8b 7d 80 48 8d 75 90 4c 8d ab a8 07 00 00 e8 63 b4 ff ff
[    2.999398] RSP: 0018:ffffb7000040b5b8 EFLAGS: 00010286
[    2.999400] RAX: 0000000000000000 RBX: ffff9bfa9dc20000 RCX: 0000000000000396
[    2.999402] RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000246
[    2.999404] RBP: ffffb7000040b698 R08: 0000000000000396 R09: 0000000000000019
[    2.999406] R10: 000000000000072e R11: ffffb7000040b420 R12: 0000000000000004
[    2.999408] R13: ffff9bfa9fbca120 R14: ffff9bfa9dc20000 R15: ffff9bfa9dc207a8
[    2.999410] FS:  00007f0d8613a680(0000) GS:ffff9bfaaec80000(0000) knlGS:0000000000000000
[    2.999412] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    2.999414] CR2: 00007ffca955ae58 CR3: 000000041e67e002 CR4: 00000000003606e0
[    2.999416] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[    2.999418] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[    2.999420] Call Trace:
[    2.999425]  ? vprintk_default+0x29/0x50
[    2.999464]  intel_dp_aux_transfer+0x15e/0x220 [i915]
[    2.999472]  drm_dp_dpcd_access+0x72/0x110 [drm_kms_helper]
[    2.999478]  drm_dp_dpcd_read+0x33/0xc0 [drm_kms_helper]
[    2.999515]  intel_dp_read_dpcd+0x41/0x130 [i915]
[    2.999551]  intel_edp_init_connector+0x136/0x540 [i915]
[    2.999587]  intel_dp_init_connector+0x47f/0x870 [i915]
[    2.999623]  intel_ddi_init+0x425/0x590 [i915]
[    2.999660]  intel_setup_outputs+0x8e4/0xc60 [i915]

System environment:
-- chipset: CML-S
-- system architecture: 64-bit
-- xf86-video-intel: xserver-xorg-video-intel-hwe-18.04 2:2.99.917+git20171229-1ubuntu1~18.04.1
-- xserver: xserver-xorg-core-hwe-18.04 2:1.20.4-1ubuntu3~18.04.2
-- mesa: 19.0.8-0ubuntu0~18.04.3 
-- libdrm: 2.4.99-1
-- kernel: 5.2.9-arch1-1-ARCH
-- Linux distribution: Ubuntu
-- Machine or mobo model:  Dell Inc. OptiPlex 3280 AIO
-- Display connector: eDP-1
Comment 1 Cyrus 2019-10-18 09:13:56 UTC
Created attachment 145772 [details]
lspci -vv
Comment 2 Lakshmi 2019-10-19 07:19:43 UTC
(In reply to Cyrus from comment #1)
> Created attachment 145772 [details]
> lspci -vv

Please try to reproduce this issue using drm-tip (https://cgit.freedesktop.org/drm-tip) with kernel parameters drm.debug=0x1e log_buf_len=4M. If the problem persists attach the full dmesg from boot.
Comment 3 Cyrus 2019-10-21 07:11:50 UTC
Created attachment 145783 [details]
dmesg from drm-tip 54d0d8863278

Still observed lot of call trace messages with drm-tip (54d0d8863278).
Comment 4 Jani Saarinen 2019-10-21 07:25:23 UTC
On CI there is also CML-S. Is that seen there?
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7137/fi-cml-s/boot0.txt
Comment 5 Imre Deak 2019-10-21 11:44:24 UTC
Created attachment 145786 [details] [review]
Fix PCH type detection

Could you try the attached patch?
Comment 6 Cyrus 2019-10-22 03:28:53 UTC
Created attachment 145790 [details]
dmesg with 0001-drm-i915-Add-new-CNL-PCH-ID-seen-on-a-CML-platform.patch

No more drm call trace messages with 0001-drm-i915-Add-new-CNL-PCH-ID-seen-on-a-CML-platform.patch.

Thanks!
Comment 7 Imre Deak 2019-10-23 19:00:29 UTC
Thanks for the report, the fix is now merged.
Comment 8 Cyrus 2019-10-24 10:03:02 UTC
Created attachment 145804 [details]
dmesg with patch on Vostro

I have got bad news, the patch causes black screen issue on another one specific machine.
Comment 9 Cyrus 2019-10-24 10:05:15 UTC
Created attachment 145805 [details]
dmesg without patch on Vostro
Comment 10 Imre Deak 2019-10-24 10:33:31 UTC
(In reply to Cyrus from comment #8)
> Created attachment 145804 [details]
> dmesg with patch on Vostro
> 
> I have got bad news, the patch causes black screen issue on another one
> specific machine.

Nothing obvious from the log, the only issue I see is 

[    2.020663] irq 45: nobody cared (try booting with the "irqpoll" option)
[    2.020667] CPU: 3 PID: 0 Comm: swapper/3 Not tainted 5.4.0-rc3+ #1
[    2.020671] Hardware name: Dell Inc. Vostro 3681/06CV2N, BIOS 0.6.13 10/07/2019
[    2.020673] Call Trace:
[    2.020679]  <IRQ>
[    2.020683]  dump_stack+0x63/0x85
[    2.020685]  __report_bad_irq+0x35/0xc0
[    2.020687]  note_interrupt+0x24b/0x2a0
[    2.020689]  handle_irq_event_percpu+0x54/0x80
[    2.020690]  handle_irq_event+0x3b/0x60
[    2.020691]  handle_fasteoi_irq+0x7c/0x130
[    2.020693]  do_IRQ+0x54/0xe0
[    2.020695]  common_interrupt+0xf/0xf
[    2.020696]  </IRQ>

but that's in both logs.

Did you try this with the latest drm-tip and then with the patch reverted on top top of that?

Is it 100% reproducible?

Do you get an FB console? (booting to bootlevel 3 adding "3" to the kernel parameters).
Comment 11 Cyrus 2019-10-25 05:03:01 UTC
(In reply to Imre Deak from comment #10)
> (In reply to Cyrus from comment #8)
> > Created attachment 145804 [details]
> > dmesg with patch on Vostro
> > 
> > I have got bad news, the patch causes black screen issue on another one
> > specific machine.
> 
> Nothing obvious from the log, the only issue I see is 
> 
> [    2.020663] irq 45: nobody cared (try booting with the "irqpoll" option)
> [    2.020667] CPU: 3 PID: 0 Comm: swapper/3 Not tainted 5.4.0-rc3+ #1
> [    2.020671] Hardware name: Dell Inc. Vostro 3681/06CV2N, BIOS 0.6.13
> 10/07/2019
> [    2.020673] Call Trace:
> [    2.020679]  <IRQ>
> [    2.020683]  dump_stack+0x63/0x85
> [    2.020685]  __report_bad_irq+0x35/0xc0
> [    2.020687]  note_interrupt+0x24b/0x2a0
> [    2.020689]  handle_irq_event_percpu+0x54/0x80
> [    2.020690]  handle_irq_event+0x3b/0x60
> [    2.020691]  handle_fasteoi_irq+0x7c/0x130
> [    2.020693]  do_IRQ+0x54/0xe0
> [    2.020695]  common_interrupt+0xf/0xf
> [    2.020696]  </IRQ>
> 
> but that's in both logs.
> 
> Did you try this with the latest drm-tip and then with the patch reverted on
> top top of that?
Tried the patch on top of drm-tip (commit 54d0d8863278).
With the patch that Vostro machine got black screen after boot and it become normal after revert the patch.

> 
> Is it 100% reproducible?
Yes

> 
> Do you get an FB console? (booting to bootlevel 3 adding "3" to the kernel
> parameters).
Yes, can get to console in runlevel 3.
Comment 12 Imre Deak 2019-10-28 18:38:41 UTC
Created attachment 145836 [details] [review]
Attempt to fix the VBT DDC pin mapping

The problem seems to be that the VBT DDC pin mapping info on your CFL doesn't match the ones we use for CNP PCHs based on the VBT specification. Either the VBT on your machines or the VBT spec we use is incorrect or my assumption that the PCH with ID 0xA3C1 was wrong; I'll try to clarify this. 

For now could you try if the attached patch gets rid of the problem on the CFL machine? Please also try your CML machine which should have an HDMI output and I suspect it has the same problem.
Comment 13 Imre Deak 2019-10-30 16:34:36 UTC
Created attachment 145843 [details] [review]
Fix PCH type detection again

The PCH is actually a CMP-V on both of these machines. CMP-V is in turn based on KBP not on CNP like other CMP PCHs. My first attempt to fix the detection is thus incorrect, since the DDC pin routing is different on KBP as it's on CNP. I attached a new attempt to fix it correctly.

Cyrus,
could you try the new patch on top of drm-tip if it works with both machines, trying also any external outputs?

Thanks.
Comment 14 Cyrus 2019-10-31 07:10:38 UTC
Both machines works well with patch 0001-drm-i915-Fix-detection-for-a-CMP-V-PCH.patch on top of drm-tip (5efc505498d2). External outputs also works well on both machines.

Thanks for the help!
Comment 15 Cyrus 2019-10-31 07:11:47 UTC
Created attachment 145844 [details]
dmesg-optiplex-AIO-drm-i915-fix-detection-for-a-cmp-v-pch.log
Comment 16 Cyrus 2019-10-31 07:12:13 UTC
Created attachment 145845 [details]
dmesg-vostro-desktop-drm-i915-fix-detection-for-a-cmp-v-pch.log
Comment 17 Cyrus 2019-10-31 07:13:11 UTC
Created attachment 145846 [details]
xranr-q-optiplex.log
Comment 18 Cyrus 2019-10-31 07:13:35 UTC
Created attachment 145847 [details]
xranr-q-vostro.log
Comment 19 Timo Aaltonen 2019-11-12 10:00:17 UTC
the new patch isn't merged yet
Comment 20 Imre Deak 2019-11-13 12:22:04 UTC
Patch now is merged:

commit 015330c6f76fccf47b2227048adc44dc453a17be
Author: Imre Deak <imre.deak@intel.com>
Date:   Wed Oct 30 18:05:48 2019 +0200

    drm/i915: Fix detection for a CMP-V PCH

Thanks for the reports, tests, re-reports and re-tests, hopefully now it's fixed properly.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.