Bug 112062 - [CI][SHARDS] igt@i915_selftest@live_coherency - timeout - GEM_BUG_ON\(gt->awake\)
Summary: [CI][SHARDS] igt@i915_selftest@live_coherency - timeout - GEM_BUG_ON\(gt->awa...
Status: RESOLVED DUPLICATE of bug 111944
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-18 12:45 UTC by Lakshmi
Modified: 2019-10-19 06:48 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-10-18 12:45:56 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7098/shard-kbl2/igt@i915_selftest@live_coherency.html
<3> [2438.531424] BUG: sleeping function called from invalid context at kernel/sched/completion.c:99
<3> [2438.531433] in_atomic(): 0, irqs_disabled(): 0, non_block: 0, pid: 8150, name: i915_selftest
<4> [2438.531986] INFO: lockdep is turned off.
<3> [2438.531993] Preemption disabled at:
<4> [2438.531995] [<0000000000000000>] 0x0
<4> [2438.532007] CPU: 0 PID: 8150 Comm: i915_selftest Tainted: G     UD           5.4.0-rc2-CI-CI_DRM_7098+ #1
<4> [2438.532017] Hardware name:  /NUC7i5BNB, BIOS BNKBL357.86A.0054.2017.1025.1822 10/25/2017
<4> [2438.532027] Call Trace:
<4> [2438.532034]  dump_stack+0x67/0x9b
<4> [2438.532041]  ___might_sleep+0x178/0x260
<4> [2438.532049]  wait_for_completion+0x37/0x1a0
<4> [2438.532060]  virt_efi_query_variable_info+0x161/0x1b0
<4> [2438.532070]  efi_query_variable_store+0xb3/0x1a0
<4> [2438.532082]  ? efivar_entry_set_safe+0x19c/0x220
<4> [2438.532090]  ? efi_delete_dummy_variable+0x90/0x90
<4> [2438.532099]  efivar_entry_set_safe+0x19c/0x220
<4> [2438.532109]  ? efi_pstore_write+0x10b/0x150
<4> [2438.532117]  efi_pstore_write+0x10b/0x150
<4> [2438.532129]  pstore_dump+0x127/0x340
<4> [2438.532139]  kmsg_dump+0x87/0x1c0
<4> [2438.532146]  oops_end+0x3e/0x90
<4> [2438.532152]  do_trap+0x80/0x100
<4> [2438.532223]  ? intel_gt_driver_remove+0x54/0x60 [i915]
<4> [2438.532233]  do_invalid_op+0x23/0x30
<4> [2438.532294]  ? intel_gt_driver_remove+0x54/0x60 [i915]
<4> [2438.532303]  invalid_op+0x23/0x30
<4> [2438.532359] RIP: 0010:intel_gt_driver_remove+0x54/0x60 [i915]
<4> [2438.532369] Code: db 0d de e0 48 8b 35 03 8e 25 00 49 c7 c0 20 84 50 a0 b9 7e 01 00 00 48 c7 c2 d0 4f 4a a0 48 c7 c7 af a1 34 a0 e8 9c 08 e5 e0 <0f> 0b 66 2e 0f 1f 84 00 00 00 00 00 e9 0b 85 fd ff 90 66 2e 0f 1f
<4> [2438.532389] RSP: 0018:ffffc9000037bac0 EFLAGS: 00010282
<4> [2438.532396] RAX: 000000000000000a RBX: ffff88824c340000 RCX: 0000000000000000
<4> [2438.532405] RDX: 0000000000000001 RSI: 0000000000000008 RDI: ffff888275b78008
<4> [2438.532413] RBP: ffff88824c34a088 R08: 0000000000702017 R09: ffff88824dc57000
<4> [2438.532421] R10: 0000000000000000 R11: ffff888275b78008 R12: 0000000000000003
<4> [2438.532429] R13: ffffffffa0592250 R14: ffffffffa05921e0 R15: ffffc9000037be88
<4> [2438.532504]  i915_gem_driver_remove+0x34/0xc0 [i915]
<4> [2438.532560]  i915_driver_remove+0xe9/0x110 [i915]
<4> [2438.532616]  i915_pci_remove+0x19/0x40 [i915]
<4> [2438.532668]  i915_pci_probe+0xa3/0x1b0 [i915]
<4> [2438.532678]  pci_device_probe+0x9e/0x120
<4> [2438.532688]  really_probe+0xea/0x420
<4> [2438.532696]  driver_probe_device+0x10b/0x120
<4> [2438.532704]  device_driver_attach+0x4a/0x50
<4> [2438.532712]  __driver_attach+0x97/0x130
<4> [2438.532718]  ? device_driver_attach+0x50/0x50
<4> [2438.532725]  bus_for_each_dev+0x74/0xc0
<4> [2438.532733]  bus_add_driver+0x142/0x220
<4> [2438.532739]  ? 0xffffffffa0626000
<4> [2438.532745]  driver_register+0x56/0xf0
<4> [2438.532751]  ? 0xffffffffa0626000
<4> [2438.532756]  do_one_initcall+0x58/0x2ff
<4> [2438.532764]  ? rcu_read_lock_sched_held+0x4d/0x80
<4> [2438.532772]  ? kmem_cache_alloc_trace+0x290/0x2c0
<4> [2438.532780]  do_init_module+0x56/0x1f8
<4> [2438.532789]  load_module+0x243e/0x29f0
<4> [2438.532803]  ? __do_sys_finit_module+0xe9/0x110
<4> [2438.532811]  __do_sys_finit_module+0xe9/0x110
<4> [2438.532823]  do_syscall_64+0x4f/0x210
<4> [2438.532831]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [2438.532840] RIP: 0033:0x7f2b7630a839
<4> [2438.532847] Code: 00 f3 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 40 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 1f f6 2c 00 f7 d8 64 89 01 48
<4> [2438.532866] RSP: 002b:00007ffe225e4e38 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
<4> [2438.532876] RAX: ffffffffffffffda RBX: 00005631adb88250 RCX: 00007f2b7630a839
<4> [2438.532884] RDX: 0000000000000000 RSI: 00005631adb80df0 RDI: 0000000000000006
<4> [2438.532892] RBP: 00005631adb80df0 R08: 0000000000000004 R09: 00005631adb89a60
<4> [2438.532900] R10: 00007ffe225e4f80 R11: 0000000000000246 R12: 0000000000000000
<4> [2438.532908] R13: 00005631adb7a000 R14: 0000000000000020 R15: 0000000000000048
Comment 1 CI Bug Log 2019-10-18 12:46:57 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* KBL: igt@i915_selftest@live_coherency - timeout - BUG: sleeping function called from invalid context at kernel/sched/completion.c:99
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_14760/fi-kbl-soraka/igt@i915_selftest@live_coherency.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7098/shard-kbl2/igt@i915_selftest@live_coherency.html
Comment 2 CI Bug Log 2019-10-18 13:22:32 UTC
A CI Bug Log filter associated to this bug has been updated:

{- KBL: igt@i915_selftest@live_coherency - timeout - BUG: sleeping function called from invalid context at kernel/sched/completion.c:99 -}
{+ KBL: igt@i915_selftest@live_coherency - timeout - GEM_BUG_ON(gt-&gt;awake) +}


  No new failures caught with the new filter
Comment 3 CI Bug Log 2019-10-18 14:01:21 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* KBL: igt@runner@aborted - fail - Previous test: i915_selftest (live_coherency)
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7098/shard-kbl2/igt@runner@aborted.html
Comment 4 Chris Wilson 2019-10-18 21:57:39 UTC

*** This bug has been marked as a duplicate of bug 111944 ***
Comment 5 CI Bug Log 2019-10-19 06:48:08 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.