Bug 11211 - [945GM] MacBook mini-DVI to S-video adapter not working
[945GM] MacBook mini-DVI to S-video adapter not working
Status: RESOLVED INVALID
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Daniel Vetter
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 15:58 UTC by J Lange
Modified: 2012-10-21 14:29 UTC (History)
11 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf which display "something" on the tv (4.67 KB, text/plain)
2008-01-04 13:49 UTC, J Lange
no flags Details
Xorg.0.log (with the s-video adaptor plugged at boot time) (110.83 KB, text/plain)
2008-01-04 13:49 UTC, J Lange
no flags Details
xorg log (110.36 KB, text/plain)
2008-03-17 07:08 UTC, J Lange
no flags Details
xrandr output (737 bytes, application/octet-stream)
2008-03-17 07:08 UTC, J Lange
no flags Details
xrandr --prop with adapter attached (1.71 KB, text/plain)
2008-04-21 10:58 UTC, Filippo Giunchedi
no flags Details
Use VGA edid info for TV detect on MacBook (1.97 KB, patch)
2009-02-01 19:45 UTC, Wang Zhenyu
no flags Details | Splinter Review
please try the debug patch on your machine, thanks. (1.90 KB, application/octet-stream)
2009-06-17 06:21 UTC, MaLing
no flags Details
xrandr output with patch from 2009-06-17 (6.62 KB, text/plain)
2009-06-17 18:47 UTC, Luis Felipe
no flags Details
Xorg.0.log with the patch from 20090617 (442.78 KB, text/plain)
2009-06-17 18:50 UTC, Luis Felipe
no flags Details
xrandr output with patch from 2009-06-17 and ignoring CRT and TMDS-1 (5.52 KB, text/plain)
2009-06-17 20:56 UTC, Luis Felipe
no flags Details
Xorg.0.log with patch from 2009-06-17 and ignoring CRT and TMDS-1 (172.54 KB, text/plain)
2009-06-17 20:57 UTC, Luis Felipe
no flags Details
clear dac sense mask (1.57 KB, patch)
2009-06-17 21:35 UTC, Michael Fu
no flags Details | Splinter Review
please try the debug patch, thanks (354 bytes, application/octet-stream)
2009-06-18 02:31 UTC, MaLing
no flags Details
Xorg.0.log from 22/06/2009 with the return SVideo hack (128.87 KB, text/plain)
2009-06-22 18:42 UTC, Luis Felipe
no flags Details
Xorg.0.log from 22/06/2009 with the "Use VGA edid info for TV detect" patch (96.04 KB, text/plain)
2009-06-22 18:44 UTC, Luis Felipe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description J Lange 2007-06-08 15:58:09 UTC
System : Ubuntu 7.04 (2.6.20-16-generic)


It seems that the Tv Out doesn't work with intel-945 in the MacBook (mine is second generation, but it should be the same for others gen).

We have to use an adapter mini-DVI->S-Video but the only things I have on my tv is "crapy"... i can just see something move when I move a window for instance. It looks like the refresh rate is completely bad...
I had to put Option "MonitorLayout" "CRT,LFP" in xorg.conf in order to see something on the tv (with "TV" replacing CRT, i got a black tv).
I tried with the tv plugged at boot time, nothing change... and I tried several way of configure Xorg too...

If it can helps you, apple say that on its web site :
---------------------------------------------------------------
The cable detect function on pin 25 is implemented by connecting pin 25 to +5V in the adapters. The computer detects which adapter is present by reading its EDID (Extended Display Identification Data) via DDC. The EDID for video is in the adapter; the EDID for VGA and DVI is in the display.
---------------------------------------------------------------


---------------
--Other links--
---------------
Here is the bug report on ubuntu launchpad : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/116207

Mail on freedesktop list : http://lists.freedesktop.org/archives/xorg/2006-October/018739.html

Post on ubuntu forum : http://ubuntuforums.org/showthread.php?t=449506

Gentoo wiki : http://gentoo-wiki.com/Talk:HARDWARE_Apple_MacBook#DVI_and_TV_Out
Comment 1 maarten lichtert 2007-12-13 15:12:10 UTC
I can confirm this bug.
I tried xrandr to setup the Tv output in Ubuntu 7.10 on a first generation macbook but it keeps saying it is disconnected
I only get some noisy output when I boot with the cable connected, until the xserver starts.
Comment 2 Michael Fu 2008-01-03 19:09:51 UTC
maarten or J Lange, would you please post your x.org log file and xorg.conf to this bug. Sorry for no response for a long time...
Comment 3 J Lange 2008-01-04 13:49:02 UTC
Created attachment 13534 [details]
xorg.conf which display "something" on the tv
Comment 4 J Lange 2008-01-04 13:49:55 UTC
Created attachment 13535 [details]
Xorg.0.log (with the s-video adaptor plugged at boot time)
Comment 5 unggnu 2008-03-16 09:20:21 UTC
This still seems to be an issue in Ubuntu Hardy Heron 8.04 with Intel driver 2:2.2.1-1ubuntu5.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/116207
Comment 6 Wang Zhenyu 2008-03-17 01:27:52 UTC
You should try with "intel" driver instead of "i810". And if that's not working, pls attach xorg log with ModeDebug option turned on.

Comment 7 J Lange 2008-03-17 07:08:17 UTC
Created attachment 15225 [details]
xorg log

It still doesn't work... I attached the corresponding log and the output of xrandr.
Comment 8 J Lange 2008-03-17 07:08:40 UTC
Created attachment 15226 [details]
xrandr output
Comment 9 Filippo Giunchedi 2008-04-21 10:58:12 UTC
Created attachment 16086 [details]
xrandr --prop with adapter attached
Comment 10 Filippo Giunchedi 2008-04-21 10:58:36 UTC
I'm experiencing this bug as well, attached there is a xrandr --prop output.

Apparently the adapter provides some special EDID data to announce itself as svideo/composite adapter, then the mini-dvi output analog pins can be sent the actual analog signals (my best guess).

some "more" information is provided here:

http://developer.apple.com/documentation/Hardware/Developer_Notes/Macintosh_CPUs-G4/12inchPowerBookG4/3_Input-Output/chapter_4_section_15.html#//apple_ref/doc/uid/TP40001763-CH207-TPXREF119|12-inch

many thanks for your excellent work!
Comment 11 Gordon Jin 2008-09-11 23:29:46 UTC
As a side note, https://bugs.freedesktop.org/show_bug.cgi?id=17342 indicates DVI->TV-out basically works on MacMini.
Comment 12 Wang Zhenyu 2008-11-20 21:35:16 UTC
Have you tried with newer ubuntu release for this bug? I think mini-DVI to VGA and DVI should work fine, we don't know if S-video adapter can work or not. Please attach new X log with ModeDebug option on.
Comment 13 Michael Fu 2008-11-20 22:45:37 UTC
bug# 17342 has prove TV works in 2.4.0, but not work in 2.5.0. A good enough hint for zhenyu to find out why...
Comment 14 Wang Zhenyu 2009-02-01 19:44:09 UTC
It looks mini-DVI adapter with S-Video TV does work as in bug 17342, although that one has EDID with TV info through SDVO port, but this one is through VGA port. Because this one is MacBook (laptop with LVDS), but 17342 is Mac Mini (desktop). They have different display configuration.

I'll attach a patch which try to use VGA EDID in Macbook case.
Comment 15 Wang Zhenyu 2009-02-01 19:45:19 UTC
Created attachment 22454 [details] [review]
Use VGA edid info for TV detect on MacBook

Please help to test this patch, it's against current git master of xf86-video-intel. Thanks.
Comment 16 Michael Fu 2009-02-01 21:31:44 UTC
(In reply to comment #14)
> It looks mini-DVI adapter with S-Video TV does work as in bug 17342, although
> that one has EDID with TV info through SDVO port, but this one is through VGA
> port. 

have you ruled out the hack code Eric added to i830_sdvo_get_ddc_modes? it steal DDC data from VGA for Mac Mini...which looks like SDVO is capable to get DDC data itself.

>Because this one is MacBook (laptop with LVDS), but 17342 is Mac Mini
> (desktop). They have different display configuration.
> 

HW form factor looks different. Google shows that MacMini use a DVI-I connector, but I doubt the internal mechanism is still same...
Comment 17 Luis Felipe 2009-06-15 19:17:36 UTC
(In reply to comment #15)
> Created an attachment (id=22454) [details]
> Use VGA edid info for TV detect on MacBook
> 
> Please help to test this patch, it's against current git master of
> xf86-video-intel. Thanks.
> 

I've tested this patch here and it did not solve the issue for me.
Comment 18 Michael Fu 2009-06-16 22:44:24 UTC
(In reply to comment #17)
> (In reply to comment #15)
> > Created an attachment (id=22454) [details] [details]
> > Use VGA edid info for TV detect on MacBook
> > 
> > Please help to test this patch, it's against current git master of
> > xf86-video-intel. Thanks.
> > 
> 
> I've tested this patch here and it did not solve the issue for me.
> 

Luis, would you please kindly post your log with ModeDebug turns on in xorg.conf?  thanks.
Comment 19 MaLing 2009-06-17 06:21:41 UTC
Created attachment 26885 [details]
please try the debug patch on your machine, thanks.

the xrandr output in comments #8 indicates VGA, LVDS connected, TV disconnected. We have modified VGA and TV detections. So could you please try the debug patch against latest 2D driver , then upload log file with modedebug option on.

Thanks for your help
Ma Ling
Comment 20 Luis Felipe 2009-06-17 18:47:22 UTC
Created attachment 26902 [details]
xrandr output with patch from 2009-06-17
Comment 21 Luis Felipe 2009-06-17 18:50:55 UTC
Created attachment 26903 [details]
Xorg.0.log with the patch from 20090617

This is the Xorg.0.log with the latest patch attached. I also didn't get any output on the TV. If there are any more information or tests you guys need, please just tell me. I'm really interested in having this fixed. Thanks alot for the work so far.
Comment 22 Michael Fu 2009-06-17 20:06:57 UTC
(In reply to comment #21)
> Created an attachment (id=26903) [details]
> Xorg.0.log with the patch from 20090617
> 
> This is the Xorg.0.log with the latest patch attached. I also didn't get any
> output on the TV. If there are any more information or tests you guys need,
> please just tell me. I'm really interested in having this fixed. Thanks alot
> for the work so far.
> 

would you please ignore the CRT and TMDS-1 using xorg.conf, and have a try again ( with the patch )?

to ignore, do similar thing like this:

Section "Device"
	...
        Option    "monitor-VGA"    "VGA"
        ...
EndSection
        ...
Section "Monitor" 
        Identifier      "VGA" 
        Option          "Ignore" "True" 
EndSection 
Comment 23 Luis Felipe 2009-06-17 20:56:17 UTC
Created attachment 26904 [details]
xrandr output with patch from 2009-06-17 and ignoring CRT and TMDS-1
Comment 24 Luis Felipe 2009-06-17 20:57:14 UTC
Created attachment 26905 [details]
Xorg.0.log with patch from 2009-06-17 and ignoring CRT and TMDS-1

Still no output whatsoever on the TV.
Comment 25 Michael Fu 2009-06-17 21:35:06 UTC
Created attachment 26908 [details] [review]
clear dac sense mask

how about with this patch? Note: might need you do some hand-editing to resolve conflict... thanks.
Comment 26 MaLing 2009-06-18 02:16:23 UTC
(In reply to comment #25)
> Created an attachment (id=26908) [details]
> clear dac sense mask
> how about with this patch? Note: might need you do some hand-editing to resolve
> conflict... thanks.

This patch has been merged into our master tree, so the patch in comments #19 has include the same behavior.

Comment 27 MaLing 2009-06-18 02:31:09 UTC
Created attachment 26913 [details]
please try the debug patch, thanks

With comments #22 to ignore CRT and TMDS, this patch will directly return our expected result. I think if your hardware interface closely match our tv spec,
we should clearly see the tv image although I know you ever saw vague tv image under i810 driver.

Thanks
Ma Ling
Comment 28 Michael Fu 2009-06-18 18:20:26 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > Created an attachment (id=26908) [details] [details]
> > clear dac sense mask
> > how about with this patch? Note: might need you do some hand-editing to resolve
> > conflict... thanks.
> 
> This patch has been merged into our master tree, so the patch in comments #19
> has include the same behavior.
> 

right.. but I noticed that Luis is using 2.7.1 in his log...not sure if he has the mask definition in i830_reg.h which wasn't included in your patch in comment# 19.. Hmm..
Comment 29 Luis Felipe 2009-06-18 18:48:09 UTC
(In reply to comment #28)
> (In reply to comment #26)
> > (In reply to comment #25)
> > > Created an attachment (id=26908) [details] [details] [details]
> > > clear dac sense mask
> > > how about with this patch? Note: might need you do some hand-editing to resolve
> > > conflict... thanks.
> > 
> > This patch has been merged into our master tree, so the patch in comments #19
> > has include the same behavior.
> > 
> 
> right.. but I noticed that Luis is using 2.7.1 in his log...not sure if he has
> the mask definition in i830_reg.h which wasn't included in your patch in
> comment# 19.. Hmm..
> 

I added the definition of the masks to i830_reg.h by hand, got them from git. I'm using the X packages that are provided here https://edge.launchpad.net/~ubuntu-x-swat on the stable updates. I'm gonna see about changing to the more bleeding edge stuff here, but I can't do any more testing today, I'll probably have to do them on the weekend. Will update here as soon as I have more info.
Comment 30 MaLing 2009-06-19 01:13:23 UTC
Could you kindly please try the patch in comments #27?

Thanks
Ma Ling
Comment 31 Luis Felipe 2009-06-19 06:31:50 UTC
(In reply to comment #30)
> Could you kindly please try the patch in comments #27?
> 
> Thanks
> Ma Ling
> 

I've tried this patch and it also did not show any output whatsoever. I've tested it with both the TV_TYPE_SVIDEO and TV_TYPE_COMPOSITE return values, since the mini-dvi to tv-out adaptor has both connections and the cable I'm using is an S-Video (connected on the TV) to Composite (connected on the Macbook) cable, and I wasn't sure exactly which type should actually be returned in this setup.
Comment 32 Michael Fu 2009-06-21 21:02:53 UTC
(In reply to comment #31)
> (In reply to comment #30)
> > Could you kindly please try the patch in comments #27?
> > 
> > Thanks
> > Ma Ling
> > 
> 
> I've tried this patch and it also did not show any output whatsoever. I've
> tested it with both the TV_TYPE_SVIDEO and TV_TYPE_COMPOSITE return values,
> since the mini-dvi to tv-out adaptor has both connections and the cable I'm
> using is an S-Video (connected on the TV) to Composite (connected on the
> Macbook) cable, and I wasn't sure exactly which type should actually be
> returned in this setup.
> 

Oh, no, please don't use it in that way. The Svideo-Composite cable is only for you to connect Svideo on the computer side and Composite on the TV side.

Do you have a SVideo-to-Svideo cable or Composite-to-Composite cable to try?
Comment 33 Luis Felipe 2009-06-22 15:51:30 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > (In reply to comment #30)
> > > Could you kindly please try the patch in comments #27?
> > > 
> > > Thanks
> > > Ma Ling
> > > 
> > 
> > I've tried this patch and it also did not show any output whatsoever. I've
> > tested it with both the TV_TYPE_SVIDEO and TV_TYPE_COMPOSITE return values,
> > since the mini-dvi to tv-out adaptor has both connections and the cable I'm
> > using is an S-Video (connected on the TV) to Composite (connected on the
> > Macbook) cable, and I wasn't sure exactly which type should actually be
> > returned in this setup.
> > 
> 
> Oh, no, please don't use it in that way. The Svideo-Composite cable is only for
> you to connect Svideo on the computer side and Composite on the TV side.
> 
> Do you have a SVideo-to-Svideo cable or Composite-to-Composite cable to try?
> 

Just tried it again with a regular SVideo-to-SVideo cable and got the same results (which is, no image displayed on the tv). 
Comment 34 Michael Fu 2009-06-22 17:59:36 UTC
(In reply to comment #33)
> (In reply to comment #32)
> > (In reply to comment #31)
> > > (In reply to comment #30)
> > > > Could you kindly please try the patch in comments #27?
> > > > 
> > > > Thanks
> > > > Ma Ling
> > > > 
> > > 
> > > I've tried this patch and it also did not show any output whatsoever. I've
> > > tested it with both the TV_TYPE_SVIDEO and TV_TYPE_COMPOSITE return values,
> > > since the mini-dvi to tv-out adaptor has both connections and the cable I'm
> > > using is an S-Video (connected on the TV) to Composite (connected on the
> > > Macbook) cable, and I wasn't sure exactly which type should actually be
> > > returned in this setup.
> > > 
> > 
> > Oh, no, please don't use it in that way. The Svideo-Composite cable is only for
> > you to connect Svideo on the computer side and Composite on the TV side.
> > 
> > Do you have a SVideo-to-Svideo cable or Composite-to-Composite cable to try?
> > 
> 
> Just tried it again with a regular SVideo-to-SVideo cable and got the same
> results (which is, no image displayed on the tv). 
> 

so I assume you've tried the HW on Mac OS to prove it can work, right?

Did you test above with the debug patch in comment# 27? 

Also as we discussed in comment# 11 to comment# 16, would you please try to contact izero79@gmail.com in bug# 17342? At least he can get a working TV after start. With the hacky patch in comment# 27, it should at least give some signal on your TV...

thanks.
Comment 35 Luis Felipe 2009-06-22 18:22:28 UTC
(In reply to comment #34)
> 
> so I assume you've tried the HW on Mac OS to prove it can work, right?
> 
> Did you test above with the debug patch in comment# 27? 
> 
> Also as we discussed in comment# 11 to comment# 16, would you please try to
> contact izero79@gmail.com in bug# 17342? At least he can get a working TV after
> start. With the hacky patch in comment# 27, it should at least give some signal
> on your TV...
> 
> thanks.
> 

I don't have MacOSX installed anymore to try, but when I did I used it normally, including with that SVideo-Composite cable I mentioned.
I tried again the patch in comment #27, and the only feedback I've on the TV is when I leave X (for example, when rebooting or something like that). But inside X, I get no signal. I'll try contacting that person and will post here if I get any new results. 
It's worth mentioning that I'm getting an error message on xrandr all the time about VGA being connected (which it isn't) but having no modes available.
Comment 36 Michael Fu 2009-06-22 18:27:00 UTC
(In reply to comment #35)
> (In reply to comment #34)
> > 
> It's worth mentioning that I'm getting an error message on xrandr all the time
> about VGA being connected (which it isn't) but having no modes available.
> 

I see. would you please continue to ignore the bogus CRT and TMDS as you did in comment# 23 ( sorry, didn't clarify this to you before ) and post your xorg.log with modedebug turns on? thanks.
Comment 37 Luis Felipe 2009-06-22 18:42:45 UTC
Created attachment 27020 [details]
Xorg.0.log from 22/06/2009 with the return SVideo hack
Comment 38 Luis Felipe 2009-06-22 18:44:24 UTC
Created attachment 27021 [details]
Xorg.0.log from 22/06/2009 with the "Use VGA edid info for TV detect" patch

Also attaching the Xorg.0.log from this one, decided to give it another try just to make sure that the SVideo-Composite cable wasn't getting in the way.
Comment 39 Michael Fu 2009-06-22 19:16:53 UTC
(In reply to comment #38)
> Created an attachment (id=27021) [details]
> Xorg.0.log from 22/06/2009 with the "Use VGA edid info for TV detect" patch
> 
> Also attaching the Xorg.0.log from this one, decided to give it another try
> just to make sure that the SVideo-Composite cable wasn't getting in the way. 
> 

so you said you can see the signal on TV until X start, right? but all the regs that controls TV are empty...Hmm..

this is the log from bug# 17342 comment# 32. pay attention to the reg dump before X start
Comment 40 Luis Felipe 2009-06-22 19:27:02 UTC
(In reply to comment #39)
> (In reply to comment #38)
> > Created an attachment (id=27021) [details] [details]
> > Xorg.0.log from 22/06/2009 with the "Use VGA edid info for TV detect" patch
> > 
> > Also attaching the Xorg.0.log from this one, decided to give it another try
> > just to make sure that the SVideo-Composite cable wasn't getting in the way. 
> > 
> 
> so you said you can see the signal on TV until X start, right? but all the regs
> that controls TV are empty...Hmm..
> 
> this is the log from bug# 17342 comment# 32. pay attention to the reg dump
> before X start
> 

Sorry, just to be more clear, outside of X I get some random noise on the TV, like white dots and lines, not proper signal.
Comment 41 MaLing 2009-06-22 20:13:30 UTC
Could you please tell me which log file is from the scenario:
we use the patch in comments #27, SVideo-to-SVideo connected between Macbook and TV,  xorg.conf to ignor VGA and TMDS1?

Thanks
Ma Ling  
Comment 42 Luis Felipe 2009-06-22 20:28:46 UTC
(In reply to comment #41)
> Could you please tell me which log file is from the scenario:
> we use the patch in comments #27, SVideo-to-SVideo connected between Macbook
> and TV,  xorg.conf to ignor VGA and TMDS1?
> 
> Thanks
> Ma Ling  
> 

The one called "Xorg.0.log from 22/06/2009 with the return SVideo hack".

Comment 43 Michael Fu 2009-06-23 00:18:26 UTC
(In reply to comment #40)
> (In reply to comment #39)
> > (In reply to comment #38)
> 
> Sorry, just to be more clear, outside of X I get some random noise on the TV,
> like white dots and lines, not proper signal.
> 

looks like we might have some problem on the Macbook. It might be really different as Mac Mini, though I think it shouldn't, in terms of TV connection..

Windows can't work as well. See http://www.mac-forums.com/forums/windows-classic-linux-other-os/138205-macbook-got-s-video-out-working-under-xp-bootcamp.html
Comment 44 ykzhao 2009-08-05 10:04:10 UTC
From the xorg log in comment #3 it seems that it is misregarded as VGA when the mini-DVI to S-video is used.(VGA is detected as connected and EDID can be obtained). In such case the TV is not detected correctly.
And it is very interesting that the TMDS-1 is also detected as connected. 
In fact there exists only one mini-DVI connector. And from http://en.wikipedia.org/wiki/Mini-DVI we can know that mini-DVI can carry the DVI-D, VGA, TV signal.
Maybe on mini mac there exists so much mystery about the hardware design that our driver can't handle this.
thanks.
Comment 45 Luis Felipe 2009-08-05 10:46:53 UTC
(In reply to comment #44)
> From the xorg log in comment #3 it seems that it is misregarded as VGA when the
> mini-DVI to S-video is used.(VGA is detected as connected and EDID can be
> obtained). In such case the TV is not detected correctly.
> And it is very interesting that the TMDS-1 is also detected as connected. 
> In fact there exists only one mini-DVI connector. And from
> http://en.wikipedia.org/wiki/Mini-DVI we can know that mini-DVI can carry the
> DVI-D, VGA, TV signal.

Not sure if it means anything, but the adaptor in question is mini-DVI to both S-VIDEO and RCA.
http://www.screencapturenews.com/wp-content/uploads/mini-dvi-to-tv-video.gif

Could this account for both outputs being turned on? (I really don't know much about this, sorry if the question is stupid)

> Maybe on mini mac there exists so much mystery about the hardware design that
> our driver can't handle this.

Just making sure, you're talking about the macbook here right? I think that the mini mac already works ok, but I don't have one to test here.

--lf


> thanks.
> 

Comment 46 Filippo Giunchedi 2010-01-08 13:12:23 UTC
Hi,
as another data point this is what I'm seeing with the adapter connected:

$ xrandr --prop
xrandr: Output VGA1 is not disconnected but has no modes
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA1 connected (normal left inverted right x axis y axis)
	EDID:
		00ffffffffffff000610089d01010101
		070c0103100000963067a9a056479926
		11484c00006101010101010101010101
		01010101010101010101010101010101
		01010101010101010101010101010101
		01010101010101010101010101010101
		010101010101010101010101000000fc
		004e5453432f50414c0a202020200038
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 286mm x 179mm
	EDID:
		00ffffffffffff0006105f9c00000000
		08100103801d12780a2f309758538b29
		25505400000001010101010101010101
		010101010101bc1b00a0502017303020
		36001eb3100000180000000100061020
		00000000000000000a20000000fe004c
		503133335758312d544c4131000000fe
		00436f6c6f72204c43440a20202000c2
	scaling mode:	Fullscreen
		supported: Non-GPU      Fullscreen   No scale     Aspect      
   1280x800       59.9*+
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
DVI1 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)
	bottom margin: 37 (0x00000025)	range:  (0,100)
	right margin: 46 (0x0000002e)	range:  (0,100)
	top margin: 36 (0x00000024)	range:  (0,100)
	left margin: 54 (0x00000036)	range:  (0,100)
	mode:	NTSC-M
		supported: NTSC-M       NTSC-443     NTSC-J       PAL-M       
		           PAL-N        PAL          480p@59.94Hz 480p@60Hz   
		           576p         720p@60Hz    720p@59.94Hz 720p@50Hz   
		           1080i@50Hz   1080i@60Hz   1080i@59.94H

I'm currently running on debian with kernel 2.6.31-1-amd64 with
xserver-xorg 1:7.5+1 and xserver-xorg-video-intel 2:2.9.1-2 and using KMS

I guess the latest patch won't apply since it is all moved to the kernel driver?

thanks in advance,
filippo
Comment 47 Jesse Barnes 2010-07-15 10:49:19 UTC
Looks like a failure to retrieve the EDID over the dongle, we might need more permissive timings (as in #28843).
Comment 48 Eugeni Dodonov 2011-08-23 12:32:57 UTC
Is this issue still valid with latest version of Intel graphics stack or was it eventually fixed meanwhile? There were lots of updates and bug #28843 was closed a long time ago.
Comment 49 Mads 2011-09-03 08:23:57 UTC
Testing now with Gentoo LiveDVD 11.2 which has 3.0.0 kernel, xorg-server 1.10.3 and xf86-video-intel-2.15.0, still only shows VGA1 as active, TV1 as disconnected. Only shows snow on the TV.

It's on a MacBook with 945GM/GMS and a MiniDVI to RCA and S-Video out, testing out the S-Video.
Comment 50 Daniel Vetter 2012-02-08 10:43:38 UTC
3.3-rc1 has a bunch of tv-out timing fixes. Can you please retest?
Comment 51 Chris Wilson 2012-10-21 14:29:44 UTC
Timeout. Please do reopen if you can still reproduce the issue and help us diagnose the problem, thanks.