Bug 112234 - [REGRESSION] navi10: writing to pp_table fails (5.4-rc6 = working)
Summary: [REGRESSION] navi10: writing to pp_table fails (5.4-rc6 = working)
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: not set normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-08 16:47 UTC by Matt Coffin
Modified: 2019-11-11 23:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg log (journalctl -k) for the failure. (117.61 KB, text/x-log)
2019-11-08 16:47 UTC, Matt Coffin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Coffin 2019-11-08 16:47:01 UTC
Created attachment 145913 [details]
dmesg log (journalctl -k) for the failure.

On 5.4-rc6, with navi10, writing to the sysfs pp_table works, with the SMU resetting successfully.

On amd-staging-drm-next (270209307880ec946cfe9b98a6a58d285dbc5a2e), this fails. I can bisect, but unfortunately I'm not too sure on where to start, since the amd-staging-drm-next branch is currently rebased off of an older version (5.3-rcX I think?). Tips on where to start would be helpful and appreciated, but my guess that this would be introduced in the big refactor to remove the swSMU code layer.
Comment 1 Matt Coffin 2019-11-08 20:51:07 UTC
Bisected, and traced back to

faa695c715e5c9203af824315127037499b33921
drm/amd/powerplay: do proper cleanups on hw_fini
Comment 2 Matt Coffin 2019-11-11 23:27:23 UTC
This was resolved on amd-staging-drm-next by https://patchwork.freedesktop.org/series/69284/


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.