Bug 11326 - Strange mouse scrolling behavior when scrolling up
Summary: Strange mouse scrolling behavior when scrolling up
Status: RESOLVED DUPLICATE of bug 5483
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Mouse (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) FreeBSD
: high normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Depends on:
Reported: 2007-06-21 08:57 UTC by Matthew Wraith
Modified: 2012-01-02 20:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Matthew Wraith 2007-06-21 08:57:32 UTC
This is similar to bug #5483 http://bugs.freedesktop.org/show_bug.cgi?id=5483 and this is also similar to the problems experienced here: 
I also looked at FreeBSD mailing list archives and found almost nothing but reports of this happening. There were no solid fixes, and if there were any suggestions, they had no effect. Also, all of the reports of this happening were under Xorg 6.9.

I am using an Optical Microsoft IntelliMouse (USB and PS/2 compatible). This is plugged into a USB to PS/2 adapter which is plugged into a KVM switch. I am using Xorg 7.2 (Which I upgraded to using portupgrade in FreeBSD 6.2-RELEASE), and I'm using FVWM 2.5.21.

I was using Opera when I found that scrolling up created a right-click (and also apparently a left click too) and a scroll while scrolling down only had a scrolling down click. When I scroll up with the mouse it highlights text as the mouse scrolls by, and it also brings up a context menu (sort of, it brings up strange grey boxes that aren't rendering properly, but with some testing I found they were context menus). Scrolling down only scrolls down. I tested if this occurs in other programs, and Firefox experienced the same problem. While Dillo, aterm, and a few other programs don't experience this at all. Others have reported this problem in Thunderbird and other programs which I have not used or tested with this problem.

I then investigated my xorg.conf
I added: Option "Buttons" "5"
and changed: Option "ZAxisMapping" "4 5 6 7" to Option "ZAxisMapping" "4 5"
with no effect.

Here is my current configuration:
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "Buttons" "5"
        Option      "ZAxisMapping" "4 5"

I then looked at my /var/log/Xorg.0.log and found something strange.
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/sysmouse"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/sysmouse"
(**) Option "Buttons" "5"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9

Notice the declaration of 9 mouse buttons. The Option "Buttons" "5" did not take effect. It recognized my mouse as having 9 buttons (it has 7 buttons but I don't use the side buttons). So, I looked at xmodmap -pp.

There are 9 pointer buttons defined.

    Physical        Button
     Button          Code
        1              1
        2              2
        3              3
        4              4
        5              5
        6              6
        7              7
        8              8
        9              9

So, my Options "Buttons" "5" was completely ignored by X.

This is similar to bug #5483 in that xmodmap was showing more buttons than the mouse has, and also one of the people described strange mouse behavior similar to mine. However, they experienced 11 buttons being created, and I experience 9.

I looked at xev and there were more mouse events on scrolling up than there were on scrolling down. Also, when I ran Opera with -debugmouse it gave me strange messages about pushing buttons 8 and 9 (along with the normal button 4) when I scroll up, and only button 5 when I scroll down.

I tried remapping my mouse every which way, and it just had strange effects. I mapped 8 and 9 to physical 4 and 5 and I got Opera to go forward and backward through history. So, I remapped the buttons back to normal.

I tested the side buttons in xev, and there was no response.

There was a fix suggested in bug #5483, but that's for Xorg 6.9, and I don't trust that will work for Xorg 7.2.

I also have another computer running FreeBSD 6.2-RELEASE Xorg 7.2 with a Dell USB Optical mouse (plugged into the USB port, and not connected to the KVM switch), and this mouse works fine with scrolling (however, it's a 5 button mouse and it's being recognized as an 11 button mouse, but that does not affect the scrolling). This leads me to believe that there's a problem with either X and my KVM switch, or there's a problem with X and the USB to PS/2 adapter (or both at the same time). I'm leaning towards X and the USB to PS/2 adapter being the problem because there were some other reports of this causing similar problems to what I'm experiencing on mailing lists that I saw.

Also, some people suggested that the problem might be with the moused. I turned off the moused and set Xorg to receive information from /dev/psm0 (instead of /dev/sysmouse) and the same thing occurred. So, I believe there's no problem with the moused. I also had Xorg working before with the moused and there was no problem (but then again, I had Xorg working with the mouse and the USB to PS/2 adapter and the KVM switch before, so that's no a really solid argument). 

I have not tried just plugging the mouse into the USB port (but the point of this is to get it to work with the KVM switch and the USB to PS/2 adapter). I have also not tried plugging my other computer into the KVM switch.

I haven't looked into the Xorg code yet, but I'm going to do that soon, but at the moment I'm completely stuck on how to go about fixing this.

Is anybody else experiencing this?
Is there any way to fix this that I'm just not seeing?
Comment 1 joe 2011-12-14 14:27:51 UTC
i'm having problems vertically scrolling up and down on libre office. 

it jumps too quickly and i overshoot when scrolling up or down on a documnet. very frustrating.
Comment 2 Jeremy Huddleston Sequoia 2012-01-02 20:14:40 UTC
Yeah, this sounds like a dupe of #5483

*** This bug has been marked as a duplicate of bug 5483 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.