Bug 11405 - _cairo_format_from_pixman_format failure when program directs display to HP/UX
Summary: _cairo_format_from_pixman_format failure when program directs display to HP/UX
Status: RESOLVED DUPLICATE of bug 4945
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.4
Hardware: x86 (IA32) Linux (All)
: high enhancement
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-28 10:33 UTC by Peter Walsall
Modified: 2007-07-12 05:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Walsall 2007-06-28 10:33:17 UTC
When running a program on Fedora 7 and displaying to HP/UX 11 CDE, many programs (e.g. emacs, system-config-samba) fail as follows:

Error: Cairo 1.4.4 does not yet support the requested image format:
        Depth: 8
        Alpha mask: 0x00000000
        Red   mask: 0x00000000
        Green mask: 0x00000000
        Blue  mask: 0x00000000
Please file an enhancement request (quoting the above) at:
http://bugs.freedesktop.org/enter_bug.cgi?product=cairo
python2: cairo-image-surface.c:199: _cairo_format_from_pixman_format: Assertion `NOT_REACHED' failed.

while the program name on the last line (e.g. python2) may change, the error detail is consistent.
Comment 1 Kalle Vahlman 2007-07-12 05:16:33 UTC
Lack of support for 8-bit PseudoColor visuals is tracked in bug 4945, marking as duplicate

*** This bug has been marked as a duplicate of bug 4945 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.