Bug 11421 - Low-quality scaling makes JSTOR document unreadable at normal size
Summary: Low-quality scaling makes JSTOR document unreadable at normal size
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-29 15:16 UTC by Nathaniel Smith
Modified: 2008-02-21 20:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
sample pdf document (556.34 KB, application/pdf)
2007-06-29 15:16 UTC, Nathaniel Smith
Details
evince.png (124.66 KB, image/png)
2007-06-29 15:17 UTC, Nathaniel Smith
Details
evince-then-scaled-down-by-gimp.png (26.93 KB, image/png)
2007-06-29 15:17 UTC, Nathaniel Smith
Details
xpdf.png (247.64 KB, image/png)
2007-06-29 15:17 UTC, Nathaniel Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathaniel Smith 2007-06-29 15:16:00 UTC
The attached PDF, downloaded from JSTOR, appears to have originally been scanned, and so the text is bitmapped.  Evince 0.8.1 using poppler 0.5.4 (cairo backend) renders it very poorly at normal scaling factors, as if it were using a low quality scaler -- the text is essentially unreadable.

This is not due to the original scan simply being of too low quality -- if I zoom in far enough in evince the text becomes clear, and if I then use the gimp's bicubic scaler to scale it back down to equivalent size, the text remains readable.  It is something evince/poppler's scaling that is failing -- perhaps just using a linear instead of bicubic scaler as a speed optimization, which would be a very poor tradeoff for this document.

Similarly, xpdf renders the text entirely readably.

Attached files:
  test.pdf -- look at, say, equation (2) on the second page, and surrounding text
  evince.png -- screenshot of evince showing this text, very ugly
  xpdf.png -- screenshot of xpdf showing the same text, perfectly readably
  evince-then-scaled-down-by-gimp.png -- zooming in in evince, then taking a screenshot and scaling the screenshot back down to equivalent size, results in readable text
Comment 1 Nathaniel Smith 2007-06-29 15:16:37 UTC
Created attachment 10508 [details]
sample pdf document
Comment 2 Nathaniel Smith 2007-06-29 15:17:03 UTC
Created attachment 10509 [details]
evince.png
Comment 3 Nathaniel Smith 2007-06-29 15:17:16 UTC
Created attachment 10510 [details]
evince-then-scaled-down-by-gimp.png
Comment 4 Nathaniel Smith 2007-06-29 15:17:30 UTC
Created attachment 10511 [details]
xpdf.png
Comment 5 Greg Grossmeier 2008-02-10 13:58:41 UTC
Confirmed with a bug report from Launchpad:
https://launchpad.net/bugs/190777

Comment 6 Jeff Muizelaar 2008-02-21 20:08:14 UTC

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.