Bug 11446 - Not able to link with Font and PNg
Summary: Not able to link with Font and PNg
Status: RESOLVED DUPLICATE of bug 11445
Alias: None
Product: cairo
Classification: Unclassified
Component: freetype font backend (show other bugs)
Version: 1.2.4
Hardware: ARM Linux (All)
: highest major
Assignee: Behdad Esfahbod
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-01 22:42 UTC by Satyanarayana K V P
Modified: 2007-07-02 05:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Satyanarayana K V P 2007-07-01 22:42:53 UTC
Dear sir,
 I am cross compiling cairo on PC(i686) with arm_v5t_le-gcc.I want to build Pango with Cairo Back End.But it is not accepting Cairo As Back End.Then I have started debugging it and I found that Cairo is not able to take Freetype componets and PNG components.I am using freetype-2.3.4.I am getting error while make check ,but cairo is installing properly.But When I am installing Pango the Same errors  I got in config.log of Pango.Here I am giving those errors which I got during make check of cairo.

../src/.libs/libcairo.so: undefined reference to `png_get_IHDR@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_destroy_write_struct@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcPatternAddInteger'
../src/.libs/libcairo.so: undefined reference to `png_write_end@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Get_PS_Font_Info'
../src/.libs/libcairo.so: undefined reference to `png_set_tRNS_to_alpha@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Init_FreeType'
../src/.libs/libcairo.so: undefined reference to `FcPatternAddBool'
../src/.libs/libcairo.so: undefined reference to `png_set_write_fn@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcPatternGetBool'
../src/.libs/libcairo.so: undefined reference to `png_destroy_read_struct@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_create_read_struct@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Load_Glyph'
../src/.libs/libcairo.so: undefined reference to `png_set_palette_to_rgb@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Done_Face'
../src/.libs/libcairo.so: undefined reference to `FcNameConstant'
../src/.libs/libcairo.so: undefined reference to `FT_Render_Glyph'
../src/.libs/libcairo.so: undefined reference to `png_set_read_fn@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_bKGD@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_filler@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Get_Char_Index'
../src/.libs/libcairo.so: undefined reference to `FT_Outline_Translate'
../src/.libs/libcairo.so: undefined reference to `png_read_image@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_interlace_handling@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_get_io_ptr@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_error@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_read_end@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_read_info@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_read_update_info@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Outline_Decompose'
../src/.libs/libcairo.so: undefined reference to `FT_Set_Pixel_Sizes'
../src/.libs/libcairo.so: undefined reference to `png_create_write_struct@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcPatternGetString'
../src/.libs/libcairo.so: undefined reference to `FT_Get_Glyph_Name'
../src/.libs/libcairo.so: undefined reference to `FcPatternGetInteger'
../src/.libs/libcairo.so: undefined reference to `FT_Outline_Transform'
../src/.libs/libcairo.so: undefined reference to `png_set_IHDR@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcPatternCreate'
../src/.libs/libcairo.so: undefined reference to `FcPatternAddString'
../src/.libs/libcairo.so: undefined reference to `png_get_valid@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_packing@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcPatternDel'
../src/.libs/libcairo.so: undefined reference to `FcPatternGet'
../src/.libs/libcairo.so: undefined reference to `FT_Outline_Get_Bitmap'
../src/.libs/libcairo.so: undefined reference to `png_create_info_struct@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Load_Sfnt_Table'
../src/.libs/libcairo.so: undefined reference to `png_convert_from_time_t@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_gray_to_rgb@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcConfigSubstitute'
../src/.libs/libcairo.so: undefined reference to `FcPatternDestroy'
../src/.libs/libcairo.so: undefined reference to `FT_Vector_Transform'
../src/.libs/libcairo.so: undefined reference to `FT_Done_FreeType'
../src/.libs/libcairo.so: undefined reference to `FT_Set_Char_Size'
../src/.libs/libcairo.so: undefined reference to `FT_Set_Transform'
../src/.libs/libcairo.so: undefined reference to `png_write_info@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_Outline_Get_CBox'
../src/.libs/libcairo.so: undefined reference to `png_write_image@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_read_user_transform_fn@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_gray_1_2_4_to_8@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FT_New_Face'
../src/.libs/libcairo.so: undefined reference to `FcFontMatch'
../src/.libs/libcairo.so: undefined reference to `png_set_tIME@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_write_user_transform_fn@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `png_set_strip_16@PNG12_0'
../src/.libs/libcairo.so: undefined reference to `FcDefaultSubstitute'
collect2: ld returned 1 exit status
make[2]: *** [imagediff] Error 1
make[2]: Leaving directory `/home/satyanarayana/Desktop/cairo-1.2.4/test'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/satyanarayana/Desktop/cairo-1.2.4/test'
make: *** [check-recursive] Error 1



Thanks in advance,
Satyanarayana K V P.
Comment 1 Satyanarayana K V P 2007-07-02 04:12:50 UTC
Dear sir,
 Sorry for my mistake.I am usin freetype-2.1.8 not 2.3.4.
Comment 2 Owen Taylor 2007-07-02 05:39:38 UTC

*** This bug has been marked as a duplicate of bug 11445 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.