Bug 11510 - build without record extension fails
Summary: build without record extension fails
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.2 (2007.02)
Hardware: All All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 16486 (view as bug list)
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2007-07-09 08:38 UTC by Martin Wyser
Modified: 2008-06-24 09:19 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wyser 2007-07-09 08:38:06 UTC
I have configured --disable-record, but the build fails during the make phase with the following symptoms:

- Fails to find the record headers while compiling in SUBDIR record
- Fails to compile recordmod.c in hw/xfree86/dixmods (again headers)

I don't think it should compile in the record directory at all.

I don't think the record extension is so important or required by another part, it should be optional (and the existence of --disable-record in configure points to that too).

Should I try to patch and submit?
Comment 1 Adam Jackson 2008-03-24 10:39:31 UTC
Fixed in git, thanks!
Comment 2 Julien Cristau 2008-06-23 16:15:53 UTC
*** Bug 16486 has been marked as a duplicate of this bug. ***
Comment 3 Maarten ter Huurne 2008-06-24 09:19:01 UTC
In xorg-server-1.4.2, released 2008-06-11, the bug is still present. If there are going to be more releases in the 1.4.x series, please merge the fix on the 1.4 branch.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.