Bug 11526 - 24-bit depth unavailable with i965GM
Summary: 24-bit depth unavailable with i965GM
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
Depends on:
Reported: 2007-07-10 04:18 UTC by Peter Ganzhorn
Modified: 2007-09-02 02:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Peter Ganzhorn 2007-07-10 04:18:05 UTC
I am currently running the xf86-video-intel driver from git (most recent version as of now) and I am not able to get 24-bit color depth working.
But the most strange thing about it is that after a update of my OS (Debian unstable) the xorg-video-intel driver was updated overwriting my self-compiled git version. After a restart of X with the Debian driver I got 24-bit color depth!

So I thought maybe you want to check this out because the guys from Debian seem to be way ahead...actually git should be more up2date than they are, but the opposite seems to be true?! Actually I can't think of any reasons for this, so maybe I am just too stupid to build that driver from source?
If there is a trick involved to get 24-bit depth with the git driver it must be badly documented, because I was not able to find any hint of such a trick in the README or with configure --help.

If there is no problem at all and I'm just all wrong, please let me know what I'm doing wrong!

BTW: I don't know what version of xorg I'm running, my xorg only reports "1.3.0" and I guess it's pretty current:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Debian

Comment 1 Eric Anholt 2007-08-08 11:58:57 UTC
24-bit depth works fine for me.  Xorg.0.log and xorg.conf required to tell what's going on with your setup.
Comment 2 Peter Ganzhorn 2007-09-02 02:55:04 UTC
I just tried the latest version of the driver available via git and the problem seems to be gone - 24 bit colors work perfectly without any changes to my configs.
Maybe I fetched a buggy version of the driver as the older one shipped with Debian worked and the new one does work as well...

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.