Bug 11605 - glxgears cause X to crash
Summary: glxgears cause X to crash
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: GLX (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-14 15:53 UTC by hajma
Modified: 2009-09-17 17:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.74 KB, text/plain)
2007-07-14 15:54 UTC, hajma
Details
strace (69.34 KB, text/plain)
2007-07-14 15:54 UTC, hajma
Details
gdb output (1.55 KB, text/plain)
2007-07-14 15:55 UTC, hajma
Details
another gdb output (2.49 KB, text/plain)
2007-07-14 15:56 UTC, hajma
Details
xorg log (39.88 KB, text/plain)
2007-07-14 15:59 UTC, hajma
Details
ltrace (16.58 KB, application/octet-stream)
2007-07-16 13:30 UTC, hajma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hajma 2007-07-14 15:53:24 UTC
With mesa 7.0, radeon driver for an ati 9600 XT, everytime I start glxgears, X crash, the same happens when I run just gears.
I am using Option "NoAccel" "1" in my xorg.conf. When I used acceleration, some other programs were crashing X - xine for example.

attaching xorg.conf, xorg.log, strace and gdb log of the crash
Comment 1 hajma 2007-07-14 15:54:10 UTC
Created attachment 10727 [details]
xorg.conf
Comment 2 hajma 2007-07-14 15:54:41 UTC
Created attachment 10729 [details]
strace
Comment 3 hajma 2007-07-14 15:55:32 UTC
Created attachment 10730 [details]
gdb output
Comment 4 hajma 2007-07-14 15:56:33 UTC
Created attachment 10731 [details]
another gdb output

seems that when I step through more slowly, glxgears crash a bit later
Comment 5 hajma 2007-07-14 15:59:49 UTC
Created attachment 10732 [details]
xorg log
Comment 6 hajma 2007-07-16 13:30:46 UTC
Created attachment 10764 [details]
ltrace

output of
$ ltrace -f -i -n 2 -o ltracegears -s 1024 -S -t /usr/bin/gears
Comment 7 Roland Scheidegger 2007-07-28 07:34:55 UTC
With NoAccel, you're not using dri. Only the mesa version which you've compiled your xorg server against thus matters (if you've compiled your xorg server from git, I've seen a couple versions which broke indirect rendering completely, these things do happen). Moving to mesa/glx, though maybe it should rather be xorg/lib/glx.
Comment 8 hajma 2007-07-30 13:40:44 UTC
does not happen when AGP is set to 4x in the xorg.conf
Comment 9 Roland Scheidegger 2007-07-31 02:17:58 UTC
(In reply to comment #8)
> does not happen when AGP is set to 4x in the xorg.conf
Have you removed the NoAccel line? I fail to see how that AGP line can make any difference without Accel enabled. Please don't mix different issues.

Comment 10 hajma 2007-07-31 15:32:33 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > does not happen when AGP is set to 4x in the xorg.conf
> Have you removed the NoAccel line? I fail to see how that AGP line can make any
> difference without Accel enabled. Please don't mix different issues.
> 

yes, I the NoAccel line is no longer there
Comment 11 Michel Dänzer 2007-08-01 04:25:50 UTC
What is the AGP transfer rate set to in the BIOS setup, and any other AGP related settings? Also, please attach a log file from starting the X server without Option "AGPMode".
Comment 12 hajma 2007-08-14 09:41:34 UTC
(In reply to comment #11)
> What is the AGP transfer rate set to in the BIOS setup, and any other AGP
> related settings? Also, please attach a log file from starting the X server
> without Option "AGPMode".
> 

Hi, there is no AGP rate setting in the BIOS

Anyway, in the meantime I took inspiration in blino's blog about solving similar problem (http://blino.org/blog/mandriva/composited-desktop/compiz-gconf-mesa-gcc.html) - 
https://bugs.freedesktop.org/show_bug.cgi?id=11380, which is apparently caused by gcc bug http://gcc.gnu.org/bugzilla/show_bug.cgi?id=32544.

So I asked him to provide mesa packages built with no gcc optimizations and the problem went away.
I also tested mesa built with -O1, which were almost OK - glxgears running, 3d games running, but I got an X.org freeze when resizing a window in jedit.
Comment 13 Michel Dänzer 2007-08-14 09:59:55 UTC

*** This bug has been marked as a duplicate of bug 11380 ***
Comment 14 Olivier Blin 2007-08-14 10:17:37 UTC
It's not exactly the same as bug 11380, since even building with -O1 triggers the crash here.
There must be some additional problem, but I can't tell yet if it comes from mesa or from gcc.
Comment 15 Bernhard Rosenkraenzer 2007-08-14 11:25:08 UTC
Definitely not the same as 11380 because 11380 doesn't crash the X server -- it just garbles the output.
Comment 16 Jerome Glisse 2009-05-18 01:46:02 UTC
Do you still have this issue with more recent mesa ?
Comment 17 Adam Jackson 2009-08-24 12:27:20 UTC
Mass version move, cvs -> git
Comment 18 Ian Romanick 2009-09-17 17:00:44 UTC
4 months with no reply from submitter.  Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.