Bug 11663 - latest intel driver breaks 1680x1050 mode on TMDS-1 output
Summary: latest intel driver breaks 1680x1050 mode on TMDS-1 output
Status: RESOLVED DUPLICATE of bug 11606
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-20 02:35 UTC by Stefan Dirsch
Modified: 2007-08-03 10:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf.good-bad (4.31 KB, text/plain)
2007-07-20 02:36 UTC, Stefan Dirsch
no flags Details
Xorg.0.log.good (56.62 KB, text/plain)
2007-07-20 02:37 UTC, Stefan Dirsch
no flags Details
Xorg.0.log.bad (56.62 KB, text/plain)
2007-07-20 02:37 UTC, Stefan Dirsch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Dirsch 2007-07-20 02:35:53 UTC
Latest intel driver breaks 1680x1050 mode on TMDS-1 output only (works fine on with VGA output). Monitor gets 1680x1053 instead and breaks the picture by scaling in y direction. I bisected the driver to figure out which commit commit changed the behaviour:

> git bisect good
1e2e301348b4168aeed38b3fdc6b0e43d5678a86 is first bad commit
commit 1e2e301348b4168aeed38b3fdc6b0e43d5678a86
Author: Keith Packard <keithp@dulcimer.keithp.com>
Date:   Sat Jun 30 12:45:24 2007 -0700

    Fix load detection to use border region instead of blanking.

    Make sure there is some border area to use by changing how the pipe is
    configured, then pick a scanline in the middle of the border for load
    detection. This lets the load detect code use an active pipe instead of
    requiring an idle one.

I'll add config and logfiles.
Comment 1 Stefan Dirsch 2007-07-20 02:36:54 UTC
Created attachment 10809 [details]
xorg.conf.good-bad
Comment 2 Stefan Dirsch 2007-07-20 02:37:22 UTC
Created attachment 10810 [details]
Xorg.0.log.good
Comment 3 Stefan Dirsch 2007-07-20 02:37:43 UTC
Created attachment 10811 [details]
Xorg.0.log.bad
Comment 4 Stefan Dirsch 2007-07-20 02:39:47 UTC
Logfiles have been generated with "Xorg -verbose 9 -logverbose 9". There are no real differences between the "good" and the "bad" one.
Comment 5 Brice Goglin 2007-07-20 11:27:58 UTC
Several problem have been reported in driver 2.1.0 due to this commit, and they have been fixed since then. So your bug is very probably fixed in current git HEAD.
Comment 6 Eric Dorland 2007-07-20 23:03:31 UTC

*** This bug has been marked as a duplicate of bug 11606 ***
Comment 7 Stefan Dirsch 2007-07-21 01:21:02 UTC
Subject: Re: Latest intel driver breaks 1680x1050 mode on TMDS-1 output
From: Keith Packard
To: Stefan Dirsch <sndirsch@suse.de>
Date: Fri, 20 Jul 2007 11:29:22 -0700

On Fri, 2007-07-20 at 12:00 +0200, Stefan Dirsch wrote:
> Hi
>
> Latest intel driver breaks 1680x1050 mode on TMDS-1 output only (works
> fine when using VGA output). Monitor gets 1680x1053 instead and breaks
> the picture by scaling in y direction.

Did you try master? Should be fixed already.
Comment 8 Stefan Dirsch 2007-08-03 10:12:09 UTC
Yes, this has been fixed in master branch. Latest changelog entry:

commit 15f71edba37738f8ba279fa07452fda10cc65298
Author: Zhenyu Wang <zhenyu.z.wang@intel.com>
Date:   Sat Jul 28 17:43:29 2007 +0800

    Update Lenovo TV quirk info


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.