Bug 11968 - ati driver : suspend to ram works only if glx and dri and disable
Summary: ati driver : suspend to ram works only if glx and dri and disable
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-12 23:39 UTC by djibb
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
lspci -v output (4.68 KB, application/octet-stream)
2007-08-13 06:44 UTC, djibb
no flags Details
Xorg.0.log just after a failed resume. (40.21 KB, application/octet-stream)
2007-08-13 06:45 UTC, djibb
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description djibb 2007-08-12 23:39:15 UTC
Hi all :)
I'm running x11-server-xorg-1.3.0.0 on a ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] with free driver and a 2.6.22.1 kernel.

Laptop is suspend and resuming well only if I comment "load dri' and "load glx" in xorg.conf and adding vga=0 to kernel boot line.

If not, suspending to ram goes well but resuming end on a corrupted X. (or console).

I've tried all quirks before submit bug here. (vbe restore etc.)

I'm not a programmer but have a good knowledge of Linux in general and have time to test what you will tell me ;)

Thanks.
Comment 1 Dave Airlie 2007-08-12 23:43:30 UTC
please attach lspci -v from the machine, and an Xorg.0.log from across a suspend if possible,..

Comment 2 Alex Deucher 2007-08-13 06:19:17 UTC
Several users have reported that the problem is in the acpi scripts.  The fix was to edit /etc/default/acpi-support and disable various video-related options like SAVE_VBE_STATE, POST_VIDEO, USE_DPMS.
Comment 3 djibb 2007-08-13 06:44:43 UTC
Created attachment 11118 [details]
lspci -v output
Comment 4 djibb 2007-08-13 06:45:31 UTC
Created attachment 11119 [details]
Xorg.0.log just after a failed resume.
Comment 5 djibb 2007-08-13 06:52:07 UTC
"Several users have reported that the problem is in the acpi scripts.  The fix
was to edit /etc/default/acpi-support and disable various video-related options
like SAVE_VBE_STATE, POST_VIDEO, USE_DPMS."

I have no "/etc/default/acpi-support" neither pre-choosen options in pm-utils configuration.

I'm using : s2ram -f  to do suspend, so no options are passed (and none helps ;) )

txs
Comment 6 Martin Peres 2019-10-14 13:20:23 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.