Bug 12021 - unichrome - invalid assert in viaSwapOutWork
Summary: unichrome - invalid assert in viaSwapOutWork
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/Unichrome (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 15668 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-15 18:50 UTC by Gabriel Mansi
Modified: 2019-09-18 20:34 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Mansi 2007-08-15 18:50:23 UTC
I think this assert is no longer valid:
assert(sz == vmesa->total_alloc[heap])
in via_tex.c line 429

There are a few linked lists to maintain references to the textures in use, one of those lists contains the textures pending to be released but that assert does not consider it.
Comment 1 Diego 2007-10-16 07:08:05 UTC
There are many, many bugs depending on this assert on the net.
Googling "viaSwapOutWork" will show some of these.
I have a similar problem: when I use glCallLists() on lists returned by glXUseXFont(), the first time I run my program, I have this error:

via_tex.c: viaSwapOutWork: Assertion 'sz == vmesa->total_alloc[heap]' failed.
Aborted

from the second run on, everything runs fine.

If this assert is unnecessary, I think it should be removed as soon as possible, since it is the root of many other bugs, for example:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-via/+bug/104569

http://www.nabble.com/Mesa-glut-demos-was:-Re:-Mesa-DRI-installed-correctly,-but-3D-apps-dont-work-t1982539.html
Comment 2 Xavier Bachelot 2008-04-25 04:56:28 UTC
*** Bug 15668 has been marked as a duplicate of this bug. ***
Comment 3 Adam Jackson 2009-08-24 12:27:47 UTC
Mass version move, cvs -> git
Comment 4 GitLab Migration User 2019-09-18 20:34:49 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/openchrome/old-bug-database/issues/5.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.