Bug 12069 - r300 & intel: poor 2D performance in some apps
Summary: r300 & intel: poor 2D performance in some apps
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/XAA (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-20 07:30 UTC by Nicolò Chieffo
Modified: 2008-03-27 11:22 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolò Chieffo 2007-08-20 07:30:03 UTC
I have a radeon mobility 9700 64MB ram r300

I don't have compiz enabled.
Some 2D apps are a bit slow. I will give you examples:

- a maximized terminal, with "man bash" open, when scrolling down fast (lots of cpu usage and huggy scrolling)
- other apps in the terminal, especially if maximized, when scrolling
- firefox, when viewing flash (flashplugin-nonfree) big animations (lots of cpu usage, very slow animations, in some case)
     example: http://notebookitalia.it/ricognizione-notebook-santa-rosa-centrino-duo-centrino-pro.html click on the CPUs image to start the animation
- evolution, when scrolling (up and) down fast between the email, the cpu goes to 100%, and the scrolling is slowed down a bit
- evince, when scrolling a pdf everything gets blocked until the image is drawn. scrolling is terribly slow

my distribution: ubuntu gutsy
my packages:
compiz 0.5.2-0ubuntu3
xserver-xorg-video-ati 6.6.193-1ubuntu1
xserver-xorg 7.2-5ubuntu6
xserver-xorg-core 1.3.0.0.dfsg-6ubuntu3
mesa 7.0.1-1ubuntu1
libdrm2 2.3.0-4ubuntu1

My xorg.conf is clean
Comment 1 Nicolò Chieffo 2007-08-20 07:31:20 UTC
I just managed to resolve 2 problems:
the evince one and the slow flash animation one

just adding Option "XAANoOffscreenPixmaps"

why is this option needed?
Comment 2 Nicolò Chieffo 2007-08-24 03:08:32 UTC
I have to correct myself: the animation in http://notebookitalia.it/ricognizione-notebook-santa-rosa-centrino-duo-centrino-pro.html is not flash! I really don't know which type is.
Comment 3 Vedran Rodic 2008-01-17 09:14:05 UTC
(In reply to comment #2)
> I have to correct myself: the animation in
> http://notebookitalia.it/ricognizione-notebook-santa-rosa-centrino-duo-centrino-pro.html
> is not flash! I really don't know which type is.
> 

Hi, I've had the same problem and I've described it here:

http://vrodic.blogspot.com/2008/01/firefoxmozilla-performance-under.html
Comment 4 Michel Dänzer 2008-01-17 10:05:02 UTC
Basically looks like software rendering fallback overhead. A lot of it could be due to missing RENDER acceleration.
Comment 5 Miguel Angel 2008-01-17 12:28:54 UTC
Confirmed on opensuse 10.3 (xorg 7.2 with fixes up to october 2007) with a radeon 9200SE (rv280).
Comment 6 Vedran Rodic 2008-01-17 13:11:39 UTC
this bug is actually also valid for the at least one additional driver: intel

Use Option "XAANoOffscreenPixmaps" "true" (and add Option "AccelMethod" "XAA" for newer drivers, since the EXA performance is also really bad for the intel driver).

I've changed the bug 12069 title, and the component and reassigned the bug to the default assignee, since this is clearly a wider XAA problem. 
Comment 7 Nicolò Chieffo 2008-03-27 11:22:15 UTC
fixed in EXA with migration heutistic = greedy
I've thrown away XAA


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.