Bug 12072 - Switch from console to X results in signal 11.
Summary: Switch from console to X results in signal 11.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-20 15:05 UTC by Kurt Roeckx
Modified: 2007-11-01 22:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Log file were when one the switches from console to X resulted in segfault (194.45 KB, text/x-log)
2007-08-20 15:06 UTC, Kurt Roeckx
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Roeckx 2007-08-20 15:05:13 UTC
Hi,

Most of the time when I switch from console to X, X seems to receive a signal 11 and then gets restarted by the dm.

My xorg.0.log shows:
Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c8631]
1: [0xffffe420]
2: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b3ff62]
3: /usr/bin/X(xf86CrtcSetMode+0x279) [0x80f9169]
4: /usr/bin/X(xf86SetDesiredModes+0x139) [0x80f9519]
5: /usr/lib/xorg/modules/drivers//intel_drv.so [0xb7b438c9]
6: /usr/lib/xorg/modules//libxaa.so [0xb7a163f2]
7: /usr/bin/X [0x80d08fc]
8: /usr/bin/X [0x80ddcd8]
9: /usr/lib/xorg/modules/extensions//libglx.so [0xb7bdd2ea]
10: /usr/bin/X(xf86Wakeup+0x3bd) [0x80c9d4d]
11: /usr/bin/X(WakeupHandler+0x59) [0x80929e9]
12: /usr/bin/X(WaitForSomething+0x1ae) [0x81b88ee]
13: /usr/bin/X(Dispatch+0x82) [0x808ec22]
14: /usr/bin/X(main+0x495) [0x8076e85]
15: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d28050]
16: /usr/bin/X(FontFileCompleteXLFD+0x1ed) [0x80761c1]

Fatal server error:
Caught signal 11.  Server aborting

I've tried commenting out dri/glx in xorg.conf but it seems it still gets loaded.

If you want I can build a version with debug info and provide a better stacktrace.

I'll attach a full log file shortly.


Kurt
Comment 1 Kurt Roeckx 2007-08-20 15:06:29 UTC
Created attachment 11184 [details]
Log file were when one the switches from console to X resulted in segfault
Comment 2 Yuval Kashtan 2007-10-24 09:19:03 UTC
it also happens to me, when I switch between X's (I have 2 Xorg instances):

Backtrace:
0: Xorg(xf86SigHandler+0x6d) [0x47c92d]
1: /lib64/libc.so.6 [0x2b254f957bd0]
2: Xorg [0x4b68a2]
3: Xorg(xf86_reload_cursors+0x90) [0x4b6a40]
4: /usr/lib64/xorg/modules//drivers/intel_drv.so [0x2b255100c1c6]
5: Xorg(xf86CrtcSetMode+0x25e) [0x4b4dee]
6: Xorg(xf86SetDesiredModes+0x129) [0x4b5169]
7: /usr/lib64/xorg/modules//drivers/intel_drv.so [0x2b255100fae4]
8: Xorg [0x477d45]
9: Xorg [0x49c0a9]
10: Xorg(xf86Wakeup+0x402) [0x47ddc2]
11: Xorg(WakeupHandler+0x4e) [0x454c4e]
12: Xorg(WaitForSomething+0x1f4) [0x56a5e4]
13: Xorg(Dispatch+0x9a) [0x450caa]
14: Xorg(main+0x475) [0x439a45]
15: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2b254f944b54]
16: Xorg(FontFileCompleteXLFD+0x231) [0x438d89]

Fatal server error:
Caught signal 11.  Server aborting
Comment 3 Michael Fu 2007-10-24 17:27:02 UTC
would you please post your HW info? thanks.
Comment 4 Yuval Kashtan 2007-10-25 00:56:51 UTC
Here is some more info:

lspci:
00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:03.0 Communication controller: Intel Corporation 82Q963/Q965 HECI Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DM Gigabit Network Connection (rev 02)
00:1a.0 USE Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HO (ICH8DO) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE Controller (rev 02)
02:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6101 single-port PATA133 interface (rev b1)
06:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

running on:
Linux Itamar-Suse103b3 2.6.22.5-31-default #1 SMP 2007/09/21 22:29:00 UTC x86_64 x86_64 x86_64 GNU/Linux


X uses this driver:
(II) LoadModule: "intel"
(II) Loading /usr/lib64/xorg/modules//drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 7.2.0, module version = 2.1.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2
(II) LoadModule: "kbd"
(II) Loading /usr/lib64/xorg/modules//input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 7.2.0, module version = 1.2.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.7
(II) LoadModule: "mouse"
(II) Loading /usr/lib64/xorg/modules//input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 7.2.0, module version = 1.2.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.7
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, 965G, 965Q, 946GZ,
        965GM, 965GME/GLE, G33, Q35, Q33

Comment 5 Kurt Roeckx 2007-11-01 13:43:45 UTC
I can't reproduce my problem with xserver 1.4 (instead of 1.3).  I have no idea which version Yuval Kashtan is using.


Kurt
Comment 6 Gordon Jin 2007-11-01 22:05:19 UTC
Since server 1.4 works, I'm closing this bug.
Yural, please submit a new bug if you still see the problem in the new driver (and new server 1.4)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.