Bug 12117 - 6.7.191/randr 1.2 issues on HP nw8240 (FireGL V5000 PCIE)
Summary: 6.7.191/randr 1.2 issues on HP nw8240 (FireGL V5000 PCIE)
Status: RESOLVED DUPLICATE of bug 12474
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-23 09:34 UTC by Luka Renko
Modified: 2007-09-18 18:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf as used with 6.6.193 driver (no issues) (3.10 KB, text/plain)
2007-08-23 09:35 UTC, Luka Renko
no flags Details
Xorg.0.log when running 6.6.193 (49.34 KB, text/plain)
2007-08-23 09:36 UTC, Luka Renko
no flags Details
Xorg.0.log when running 6.7.191 (wrong resolution detected) (119.20 KB, text/plain)
2007-08-23 09:37 UTC, Luka Renko
no flags Details
Xorg.0.log when running 6.7.191 (wrong display size) (151.73 KB, text/plain)
2007-08-23 09:37 UTC, Luka Renko
no flags Details
xorg.conf as used with 6.6.191 (with workarounds) (3.01 KB, text/plain)
2007-08-23 09:38 UTC, Luka Renko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luka Renko 2007-08-23 09:34:53 UTC
I am testing latest ATI driver prerelease with RandR 1.2 extensions support on Kubuntu Gutsy with packages provided by Tormod Volden. See  https://wiki.ubuntu.com/XorgOnTheEdge for package info.

HW: HP nw8240 laptop with ATI FireGL V5000 PCIE, 15.4" 1920x1200 laptop LCD panel

There are two issues:

1. Resolution not properly detected
X was started in 1280x800 resolution. The error reported in the log:
(II) RADEON(0): Not using mode "1920x1200" (width too large for virtual size)

I have solved this, by adding "Virtual 1920 1200" to Display section.

2. Display size not properly detected > wrong DPI
After solving resolution problem, I got wrong DPI, due to wrong detection of my 
LCD panel size.

xdpyinfo reports:
  dimensions:    1920x1200 pixels (507x317 millimeters)
  resolution:    96x96 dots per inch

It is strange, as from the log file, it does look that proper display size (330x210) is detected:

(II) RADEON(0): Max H-Image Size [cm]: horiz.: 33  vert.: 21

I have tried to workaround this by adding "DisplaySize 330 210" to Monitor section of xorg.conf, but it does not look like to help.

I will attach all conf and log files
Comment 1 Luka Renko 2007-08-23 09:35:56 UTC
Created attachment 11228 [details]
xorg.conf as used with 6.6.193 driver (no issues)
Comment 2 Luka Renko 2007-08-23 09:36:35 UTC
Created attachment 11229 [details]
Xorg.0.log when running 6.6.193
Comment 3 Luka Renko 2007-08-23 09:37:23 UTC
Created attachment 11230 [details]
Xorg.0.log when running 6.7.191 (wrong resolution detected)
Comment 4 Luka Renko 2007-08-23 09:37:50 UTC
Created attachment 11231 [details]
Xorg.0.log when running 6.7.191 (wrong display size)
Comment 5 Luka Renko 2007-08-23 09:38:35 UTC
Created attachment 11232 [details]
xorg.conf as used with 6.6.191 (with workarounds)
Comment 6 Luka Renko 2007-08-30 17:11:33 UTC
Problem 1 (resolution) is fixed with 6.7.192-1ubuntu1

Problem 2 is still there in that version, however I can workaround creating /etc/X11/Xsession.d/35ati-fix-displaysize file with following content:

/usr/bin/xrandr --fbmm 330x210 || true
Comment 7 Luka Renko 2007-09-18 15:51:04 UTC
Problem 2 still exists with 1:6.7.192-1ubuntu2 version.
Comment 8 Luka Renko 2007-09-18 15:52:33 UTC
Similar issue (just different HW) in bug 12474
Comment 9 Alex Deucher 2007-09-18 18:53:05 UTC

*** This bug has been marked as a duplicate of bug 12474 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.