Bug 12293 - Cannot install custom rgb.txt file in RHEL 5
Summary: Cannot install custom rgb.txt file in RHEL 5
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-05 13:30 UTC by Isaac W.
Modified: 2008-02-27 19:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Isaac W. 2007-09-05 13:30:48 UTC
Description of problem:
Cannot install a customized rgb.txt file because the /usr/share/X11/rgb.txt 
file is ignored by the X server.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 5 Server running Xorg 7.1.1

How reproducible:


Steps to Reproduce:
1.  Edit the rgb.txt file, changing the "Blue" and "blue" entries to "255 0 0".
2.  Start the X server.
3.  Create an xterm with the following command: "xterm -fg blue".
  
Actual results:
The xterm window appears with blue foreground text.

Expected results:
The xterm window should appear with red foreground text, since the rgb.txt was 
edited to associate the name "blue" with a red color "255 0 0".

Additional info:
No other copies of rgb.txt reside in the system.  Also, there were no errors in 
the /var/log/Xorg.0.log file.  RgbPath is set to "/usr/share/X11/rgb" in the 
xorg.conf file.
Comment 1 Adam Jackson 2008-02-24 17:53:22 UTC
rgb.txt is deprecated, sorry.  The default upstream is to build without support for it.

Your distribution may choose to do otherwise, of course, but that's not for X.org to enforce.
Comment 2 Aubrey Jaffer 2008-02-27 19:39:27 UTC
Is it color-from-name that is being deprecated by X.org or just the use of better color dictionaries (http://swiss.csail.mit.edu/~jaffer/Color/Dictionaries)?

I find no mention of rgb.txt in www.x.org/wiki/.  Is it discussed by X.org somewhere?


bug/show.html.tmpl processed on Mar 27, 2017 at 04:39:13.
(provided by the Example extension).