Bug 1236 - Blender menus are not drawn with Matrox G400 DualHead(FreeBSD 4.10, Slackware-current)
Summary: Blender menus are not drawn with Matrox G400 DualHead(FreeBSD 4.10, Slackware...
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/MGA (show other bugs)
Version: 6.1
Hardware: x86 (IA32) FreeBSD
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 6858 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-08-30 01:47 UTC by lauri järvenpää
Modified: 2015-11-30 23:40 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
C source code - test case (1.35 KB, text/plain)
2005-12-17 18:06 UTC, Glynn Clements
Details
Backtrace from Blender crash (3.30 KB, text/plain)
2006-04-19 01:37 UTC, Adam K Kirchhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lauri järvenpää 2004-08-30 01:47:33 UTC
New DRI versions act strangely: background of the menus in Blender are not drawn
making text hard to read and messy. And right click makes grid disappear until
next action.

Multiple Blender versions tested (2.32 and 2.34 at least).
DRI versions tested: 5.0.2 and CVS snapshot 6.1.p20040507 from FreeBSD ports
collection.
XFree tested: 4.3, 4.4.

System: XFree 4.4.0, FreeBSD 4.10, Matrox G400 DualHead.

This bug didn't exist with previous DRI version (the one before 5.0.2, probably).

Another user said that this also happens with Slackware-current. So it is not
Blender or FreeBSD specific.

How to fix: disable hardware acceleration.
Comment 1 Glynn Clements 2005-12-17 18:06:51 UTC
Created attachment 4117 [details]
C source code - test case

This test case demonstrates that glDrawBuffer() is essentially non-functional,
in that it appears to fail more often than it works.
Comment 2 Nick 2006-02-08 02:55:47 UTC
(In reply to comment #1)
> Created an attachment (id=4117) [edit]
> C source code - test case
> 
> This test case demonstrates that glDrawBuffer() is essentially non-functional,
> in that it appears to fail more often than it works.
> 

(In reply to comment #1)
> Created an attachment (id=4117) [edit]
> C source code - test case
> 
> This test case demonstrates that glDrawBuffer() is essentially non-functional,
> in that it appears to fail more often than it works.
> 

This bug has been present for more than 2 years now. Blender is unusable
on DRI/G400 (FreeBSD and Linux) because of it. Disabling hardware accelleration
is not an option because the program becomes very slow. Its very bad that
this hasnt been fixed yet, especially because g400 is a well documented card
and often brought up in the open source vs closed 3d drivers arguments.
Comment 3 Adam K Kirchhoff 2006-04-19 01:37:16 UTC
Created attachment 5361 [details]
Backtrace from Blender crash
Comment 4 Jacek Poplawski 2006-08-13 12:00:45 UTC
*** Bug 6858 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Baczyński 2011-09-29 14:34:13 UTC
Probably the MGA bugs can be closed now that the driver is removed from git?
Comment 6 Ian Romanick 2015-11-30 23:40:26 UTC
(In reply to Marcin Baczyński from comment #5)
> Probably the MGA bugs can be closed now that the driver is removed from git?

Yes. :)