Bug 12390 - Country shuffle: need layouts me and rs
Country shuffle: need layouts me and rs
Status: RESOLVED FIXED
Product: xkeyboard-config
Classification: Unclassified
Component: General
unspecified
All All
: medium normal
Assigned To: xkb
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 05:57 UTC by Chusslove Illich
Modified: 2007-11-01 13:39 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chusslove Illich 2007-09-11 05:57:17 UTC
About a year ago, the country of "Serbia and Montenegro" (code cs), split
into "Montenegro" and "Serbia" (codes me and rs). No physical changes to the
cs layout were requested so far, but keeping in with the policy of country-
layouts, me and rs should be introduced. (We are taking some flak in KDE due
to missing flags in the layout indicator, as the split of countries has
already been registered in other components.)

On a technical side, I guess cs should still remain as base for several
country layouts (as it has been providing so far), only removed as an end-
user choice in config data.
Comment 1 Sergey V. Udaltsov 2007-09-11 13:50:53 UTC
I do not like the idea of leaving cs (I will keep it as a compatibility rule though). So let's sort all variants between me and rs. The list of variants is as follows:
"basic"
"latin"
"yz"
"common"
"cyralpha"
"latalpha"
"twoletter"
"level3"
"latinunicode"
"latinyz"
"latinunicodeyz"
"alternatequotes"
"latinalternatequotes"
Which of them should go to me? Which of them go to rs? Which of them should be present in both?
Comment 2 Chusslove Illich 2007-09-11 14:08:57 UTC
With "no physical changes requested to the cs" I meant that both me and rs
layouts should be exact replicas of current cs, all variants included. cs
was indeed assembled by Serbian users, but to my knowledge, no dissenting
comments came from Montenegrian users so far.

(As far as I saw, cs is currently included by at least hr and ba layouts.)
Comment 3 Sergey V. Udaltsov 2007-09-11 14:15:35 UTC
> With "no physical changes requested to the cs" I meant that both me and rs
> layouts should be exact replicas of current cs, all variants included. 
I see. So what I'll do it move cs to, say, me (alphabetically first) and use a lot if "includes" in rs. But I would appreciate if you double-check whether we really need all variants in both cases.

> (As far as I saw, cs is currently included by at least hr and ba layouts.)
Yes, true - I'll fix them as well: ba, hr, si.

Comment 4 Chusslove Illich 2007-09-11 14:44:43 UTC
> So what I'll do it move cs to, say, me (alphabetically first) [...]

Preemting yet another political issue, are we? :) But this is Balkans --
once you get entangled, you can never disentangle. The tar pit of good
intentions.

Anyways, this resolution is perfectly fine with me. Though with those other
layouts in sight, "ba" is the one alphabetically first. Although I
personally would revel in "me" being the primary source, for reasons of
convolved local folklore...

> [...] I would appreciate if you double-check whether we really need all
> variants in both cases.

Since the layout was designed by Serbian users, all the variants should
remain in "rs". Montenegrian users are kind of hard to come by, especially
those having an opinion on keyboard layouts, so I would just leave it as is,
and wait for concrete issues to be raised in the future. Noone has
complained thus far either.

If you insist, I guess I could try to dig out some interested Montenegrians,
on the local fora or somewhere.
Comment 5 Sergey V. Udaltsov 2007-09-26 14:46:21 UTC
> Preemting yet another political issue, are we? :) But this is Balkans --
> once you get entangled, you can never disentangle. The tar pit of good
> intentions.
Every time I get involved into Balkanian layouts, I get extra grey hair :(

> personally would revel in "me" being the primary source, for reasons of
> convolved local folklore...
If it is not too offensive, could you share some?:)

> If you insist, I guess I could try to dig out some interested Montenegrians,
> on the local fora or somewhere.
Yes please, it could be helpful.

Actually, since originally the country was "Serbia and Montenegro", I could consider putting all variants into rs, using "includes" in "me". I will think of it. 

Looking forward to getting some comments from Montenegrians..
Comment 6 Chusslove Illich 2007-09-26 16:00:10 UTC
As a matter of fact, I was just about to write up that I did find
Montenegrian users willing to look into the matter. Although not in English,
just for the record, the discussion is here:
http://lug.itam.ws/forum/index.php?topic=117.0

We have agreed that it is best, for starters, to indeed make me an exact
copy of rs, and technically so that me includes from rs. Then, since the
next release freeze is planned for mid January, the good folks from that
thread will have some time to solicit opinions on changes that they now have
in mind as possibly useful for me. Once they come up with some, since the
CVS will already have me generally set up, it will be easier to create
appropriate patches.

By the way, out of those listed variants, the user-visible ones are:

  "basic"
  "yz"
  "alternatequotes"
  "latin"
  "latinyz"
  "latinunicode"
  "latinunicodeyz"
  "latinalternatequotes"

so they should be included by me.

> If it is not too offensive, could you share some?:)

Erm, mostly PIC, and I don't mean position-independent-code...

> Looking forward to getting some comments from Montenegrians.

I'll prompt someone from that thread to confirm my ramblings here ASAP, lest
you get any wrong impressions :)
Comment 7 Sergey V. Udaltsov 2007-10-04 14:51:39 UTC
Great! Thanks, committed!
Comment 8 Damir Mustafić 2007-10-07 21:59:32 UTC
Just to make it official (instead “wrong impressions”)  :)

First of all,  hi to all. My name is Damir Mustafić and I am from ”LUG Montenegro” community (the ”D“ user on lug.itam.ws). Basically, there are not words to be added after Časlav’s good interfering :) Anyway, just to repeat:

We have agreed to use same keyboard layout as Serbian. At least ‘till we “dig out” some constructive changes for making it more suitable for our language (dialect, whatever)

Best regards,
Damir