Bug 12391 - [855GM] Seg fault rotating display while movie playing
[855GM] Seg fault rotating display while movie playing
Status: VERIFIED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) Linux (All)
: medium critical
Assigned To: Wang Zhenyu
Xorg Project Team
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends on: 12243
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 06:11 UTC by Andrew Moise
Modified: 2008-03-06 18:14 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log from driver version 2.1.0-1 (159.31 KB, text/plain)
2007-09-11 06:13 UTC, Andrew Moise
no flags Details
Configuration for driver version 2.1.0-1 (4.17 KB, text/plain)
2007-09-11 06:14 UTC, Andrew Moise
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Moise 2007-09-11 06:11:56 UTC
While running the Debian-packaged version 2:2.1.0-1 of the intel driver, I got a server seg fault while rotating my display while playing a movie.  I'll copy-paste the information from that bug report below.  I've also seen this crash quite recently, in a version I pulled down from git on 2007-08-31 (git revision 7fd9a98178cdebda4213796fdc452a8a265a1197).

Information from the Debian bug follows:

  I got a lockup while twiddling xrandr between "right" and "normal"
rotations to investigate corruption playing movies when rotated.  The X
server dumped debugging information to the log and exited, and my
monitor and keyboard became unusable (with the monitor in DPMS mode),
but I could still ssh into the system and operate it from there as
normal.
  I'm attaching the log file and my configuration.  I've also filed a
separate bug about the corruption playing movies.  If you need anything
else, let me know.
Comment 1 Andrew Moise 2007-09-11 06:13:23 UTC
Created attachment 11504 [details]
Xorg.0.log from driver version 2.1.0-1
Comment 2 Andrew Moise 2007-09-11 06:14:28 UTC
Created attachment 11505 [details]
Configuration for driver version 2.1.0-1
Comment 3 WuNian 2007-09-12 01:53:23 UTC
I can not reproduce this bug when use 2D driver tip and xserver tip.
I do not use any OSD, I retest by running a nude Xorg. So current 2D driver and xserver have no this bug.

I use mplayer to play mpeg2 video on 915GM, then rotate screen to left, right, inverted, everything is OK except that I can not see the video because bug #12243.

I saw that your xorg.conf's Device section has the option:
Option          "VBERestore"    "true"
I do not find the "VBERestore" option in xorg.conf manual and intel manual. I think if this option is out-of-date. Anyway, when I also add this option in my xorg.conf, the screen flashed, but X and mplayer were running.


I noticed that your xorg.conf has lines in Monitor section:
        HorizSync	30-70
	VertRefresh	56-85
	DisplaySize	357 286

Now xserver will automatically inspect the monitor's capbility and may confused by these data, so you can remove these lines.
Comment 4 Andrew Moise 2007-09-12 06:24:41 UTC
One thing I should have mentioned is that this is an intermittent problem; it's not 100% reproducible, but it's not rare either (I would estimate that I've seen it one time in three that I've tried rotating the display while a movie is playing).

Also, my hardware is an 855GME; certainly it's possible that there is a bug in the 2d driver when running on an 855GME that does not show up when running on a 915GM, no?

Would you like me to resync my git source and try again, and/or to run under gdb and get a stack trace for the crash?
Comment 5 WuNian 2007-10-22 19:29:03 UTC
Can not reproduce this bug on 915GM. So the bug should be 855GM specified.
Comment 6 WuNian 2007-10-23 17:45:58 UTC
I tried this on 855gm.first I rotated to right ,the display had a little unormal at the display screen bottem,then I rotated left ,the machine crashed.
Comment 7 Gordon Jin 2007-11-15 17:47:08 UTC
We can reproduce this on 855GM with 2.2 driver, while it's ok on 915GM.
Comment 8 Jesse Barnes 2007-11-15 18:38:24 UTC
Can we get a backtrace?
Comment 9 WuNian 2007-11-16 01:10:53 UTC
Backtrace info:

#0  0xffffe410 in ?? ()
#1  0xbff6f9cc in ?? ()
#2  0x00000006 in ?? ()
#3  0x00000d4d in ?? ()
#4  0x00678159 in raise () from /lib/libc.so.6
#5  0x006796e3 in abort () from /lib/libc.so.6
#6  0x081b8561 in FatalError (f=0x0) at log.c:554
#7  0xb7ddc367 in I830WaitLpRing (pScrn=0x8213470, n=131064,
    timeout_millis=2000) at i830_accel.c:150
#8  0xb7ddc4c2 in I830Sync (pScrn=0x8213470) at i830_accel.c:201
#9  0xb7deefe5 in I830StopVideo (pScrn=0x8213470, data=0x8259794, shutdown=1)
    at i830_video.c:1012
#10 0x080de5cd in xf86XVLeaveVT (index=0, flags=0) at xf86xv.c:1262
#11 0xb7e79a2f in glxDRILeaveVT (index=0, flags=0) at glxdri.c:993
#12 0x080a1c16 in AbortDDX () at xf86Init.c:1102
#13 0x081b8258 in AbortServer () at log.c:406
#14 0x081b8554 in FatalError (f=0x0) at log.c:552
#15 0xb7ddc367 in I830WaitLpRing (pScrn=0x8213470, n=131064,
    timeout_millis=2000) at i830_accel.c:150
#16 0xb7ddc4c2 in I830Sync (pScrn=0x8213470) at i830_accel.c:201
#17 0xb7de7337 in i830WaitSync (pScrn=0x8213470) at i830_driver.c:3430
#18 0xb7deeae0 in i830_overlay_off (pScrn=0x8213470) at i830_video.c:497
#19 0xb7def062 in I830StopVideo (pScrn=0x8213470, data=0x8259794, shutdown=1)
#20 0x080df043 in xf86XVStopVideo (client=0x0, pPort=0x0, pDraw=0xd4d)
    at xf86xv.c:1640
#21 0xb7e9d22c in XvDestroyWindow (pWin=0x8270748) at xvmain.c:433
#22 0x080ddfe0 in xf86XVDestroyWindow (pWin=0x8270748) at xf86xv.c:1043
#23 0xb7fe02a8 in DbeDestroyWindow (pWin=0x8270748) at dbe.c:1720
#24 0x080fe9f5 in compDestroyWindow (pWin=0x8270748) at compwindow.c:630
#25 0x08071281 in FreeWindowResources (pWin=0x8270748) at window.c:881
#26 0x080753e8 in DeleteWindow (value=0x8270748, wid=4194305) at window.c:961
#27 0x0806fca8 in FreeResource (id=4194305, skipDeleteFuncType=0)
    at resource.c:576
#28 0x080805b1 in ProcDestroyWindow (client=0x8404768) at dispatch.c:649
#29 0x0814833d in XaceCatchDispatchProc (client=0x8404768) at xace.c:281
#30 0x08087597 in Dispatch () at dispatch.c:502
#31 0x0806e2d0 in main (argc=2, argv=0xbff70474, envp=0x0) at main.c:452

No matter of EXA or XAA, the bug exists.
Comment 10 Andrew Moise 2007-11-20 06:28:04 UTC
I just got more misbehavior in driver 2.2.0-1 from Debian -- I was playing a movie and attempted to move the window that it was playing in, and my screen suddenly went blank.  X is still running, nothing special is in the log, and I can't switch back to the text consoles.

If you think that problem would go better in a separate bug, let me know and I'll open one.

Thanks!
Comment 11 Gordon Jin 2007-11-20 17:57:05 UTC
Andrew, is the new issue just the one you filed at bug#13316?
Comment 12 Andrew Moise 2007-11-22 09:29:55 UTC
No, the incorrect positioning and display when playing movies has been a problem for a while (I filed it into Debian's BTS in July, and just now got around to putting it in xorg bugzilla).  The black screen while attempting to move the movie window is one I haven't seen before, but I haven't been playing movies very much using the new driver, since they don't work :-).

Cheers.
Comment 13 Gordon Jin 2007-11-22 18:50:38 UTC
Andrew, I'd suggest you to open a new bug for the new issue in comment#10. We want track only one issue in one bug report.
Comment 14 Andrew Moise 2007-11-23 06:19:42 UTC
Okay, I've put the information in a separate bug (#13369).  Thanks.
Comment 15 Andrew Moise 2008-02-06 22:52:57 UTC
I've not been able to reproduce this bug in driver version 2.2.0.90-2 from Debian sid.  I believe it's been fixed in that version.

Thanks!
Comment 16 Gordon Jin 2008-02-12 20:39:27 UTC
Nian, please close this after your verification.
Comment 17 Wang Zhenyu 2008-02-24 22:31:51 UTC
Fixed in current master.
Comment 18 WuNian 2008-03-06 18:14:13 UTC
Verified.