Bug 12425 - magictouch module fails to load
Summary: magictouch module fails to load
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/magictouch (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-14 05:48 UTC by José Jorge
Modified: 2010-10-31 14:18 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
magictouch driver for Xorg 7.3 ported from Xfree 4.7.99 (6.17 KB, application/x-gtar)
2008-09-17 06:39 UTC, Alexander Smirnov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description José Jorge 2007-09-14 05:48:54 UTC
On a Mandriva 2007.1 system, trying to use the included magictouch driver, I get the error in the log :

EE Module magictouch does not have a magictouchModuleData data object

then 

EE Failed to load module "magictouch" (invalid module, 0)

Looks like the driver was not updated for a long time?
This prevents from using RS232 Keytec touchscreen systems as input.
Comment 1 Brice Goglin 2007-09-14 05:56:55 UTC
It reminds me of:
< bgoglin> daniels: do you know why magictouch does not have a XF86ModuleData/XF86ModuleVersionInfo as the other drivers?
< daniels> bgoglin: wow.  i assume that means that it's incapable of actually, y'know, working.

You're probably the first one to try this driver for a long time :)
Comment 2 José Jorge 2007-09-14 06:49:21 UTC
Does it mean I can't hope any help on that?
Comment 3 Brice Goglin 2007-09-14 10:53:38 UTC
No, it just means that this driver really needs to be fixed since there is no way it could work for anybody right now.
Comment 4 Christopher Covington 2007-09-17 21:37:42 UTC
I can confirm this bug on my machine. I've also got a Keytec MagicTouch but with the USB connector.I'd be interested in helping fix this--sniffing the binary ETouch driver that shipped with the screen, testing or doing not-too-complicated changes to the code. I have a friend who can translate Italian if that's needed (a lot of the comments are in Italian). I don't suppose there's any documentation or examples from other drivers of what is wrong and how to fix it. If there is, I might be able to fumble around applying the information and accidentally fix the stuff.

I'm running a Gentoo system with xorg-server-1.4-r1, xf86-input-magictouch-1.0.0.5 and kernel 2.6.22-r6.
Comment 5 Alexander Smirnov 2008-07-15 00:00:37 UTC
The same trouble with Fedora-9 and Suse 10.3-11
Comment 6 Alexander Smirnov 2008-07-15 00:04:09 UTC
This trouble can be easy detected even if you haven't 
any real magictouch devices: just describe it in xorg.conf, 
start Xorg and get error message
(EE Module magictouch does not have a magictouchModuleData data object)
Comment 7 Peter Hutterer 2008-07-16 04:47:29 UTC
Just had a quick peek at the driver and I don't think this driver was ever
even close to working since the initial git import.

Unless someone actually steps up and writes the code, don't expect this driver
to work. I'll actually push for it to be removed from the xorg module set
until it is working.
Comment 8 Peter Hutterer 2008-09-15 23:18:28 UTC
Let's not pretend that we'll ever fix it...
Comment 9 Alexander Smirnov 2008-09-16 00:11:32 UTC
(In reply to comment #8)
> Let's not pretend that we'll ever fix it...
> 

It is quite easy 

- to port respective driver from XFree 4.7.99
- to build driver from manufacturer's sources (there is  
even one common driver for USB and COM)

I did both items. So, drivers can be build and loaded 
without any warnings/errors. But bouth drivers works incorrectly 
with my magictouch ProEX touchscreen. I am not able to calibrate device. 
So, probably I need some specs and-or suggestions from manyfacturer or 
from experienced touchscreen driver writer.
Comment 10 Peter Hutterer 2008-09-17 00:41:34 UTC
reopening then.

You need to submit the patches though, preferably by attaching them to this bugreport.
Comment 11 Alexander Smirnov 2008-09-17 06:39:40 UTC
Created attachment 18951 [details]
magictouch driver for Xorg 7.3 ported from Xfree 4.7.99

Original driver of Xorg can't be loaded. it seems to be completely obsoleted. I trivially ported current XFree 4.7.99 driver to Xorg 7.3. There are 2 files to replace respective files in original xorg magictouch driver package. 

Build is OK, loading is OK. Real work with my ProEX controller failed probably due to troubles with calibration or obsoleted algorithms in driver. 

So, this driver has to be tested more carefully by manufaturer. I can't do it because there are no public specs available for me to rewrite this driver.

BTW: I have built manufactiurer's "absolute" driver under Xorg 7.3. It works with COM controllers too. There are different source codes but the same trouble with my ProEX (COM) controller - can't use in spite of succesfull build and loading.
Comment 12 Jesse Adkins 2010-10-31 14:18:56 UTC
As of 2009-02-17 (git commit 09d1a226527c50a730d8eba2a7626bbea980a65c) this driver is marked as unmaintained and configure set to fail. This is a trivial bug (it just requires a rename of a var, if I recall correctly), there's no maintainer for this driver.

I'm closing this as WONTFIX since I doubt we'll see a patch. Even if that was fixed, there may be other problems.

If you don't like this, or you want to be the maintainer for magictouch, then feel free to reopen this.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.